]> git.pld-linux.org Git - packages/ant.git/blob - ant.spec
- updated to 1.6.5
[packages/ant.git] / ant.spec
1 # TODO: consider using external xerces-j
2 #
3 # Conditional build:
4 %bcond_with     basic_functionality     # generates package with only
5                                         # basic functionality, i.e. no deps
6 %bcond_without  junit                   # build without (commonly used) junit support
7 #
8 Summary:        ant build tool for Java
9 Summary(fr):    Outil de compilation pour java
10 Summary(it):    Tool per la compilazione di programmi java
11 Summary(pl):    ant - narzêdzie do budowania w Javie
12 Name:           jakarta-ant
13 Version:        1.6.5
14 %if %{with basic_functionality}
15 Release:        0.basic.1
16 %else
17 Release:        1
18 %endif
19 License:        Apache
20 Group:          Development/Languages/Java
21 Source0:        http://www.apache.org/dist/ant/source/apache-ant-%{version}-src.tar.bz2
22 # Source0-md5:  80a7ad191c40b7d8c82533524b282b6b
23 Patch0:         %{name}-ANT_HOME.patch
24 URL:            http://ant.apache.org/
25 BuildRequires:  jdk
26 %{?with_junit:BuildRequires:    junit}
27 %if %{without basic_functionality}
28 BuildRequires:  antlr
29 BuildRequires:  beanshell
30 BuildRequires:  bsf >= 2.3.0
31 BuildRequires:  jaf
32 BuildRequires:  jakarta-bcel
33 BuildRequires:  jakarta-commons-logging
34 BuildRequires:  jakarta-commons-net >= 1.2.2
35 BuildRequires:  jakarta-log4j
36 BuildRequires:  jakarta-oro >= 2.0.7
37 BuildRequires:  jakarta-regexp >= 1.3
38 BuildRequires:  javamail
39 BuildRequires:  jsch
40 BuildRequires:  netrexx
41 BuildRequires:  xalan-j
42 BuildRequires:  rhino >= 1.5R3
43 BuildRequires:  xml-commons-resolver >= 1.1
44 # TODO: icontract, jai, jdepend, starteam, stylebook, vaj, weblogic, xslp
45 %endif
46 Requires:       jdk
47 %{?with_junit:Provides: jakarta-ant(junit) = %{version}}
48 Provides:       jaxp_parser_impl
49 Provides:       xerces-j = 2.6.2
50 Obsoletes:      xerces-j
51 BuildArch:      noarch
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 Platform-independent build tool for Java. Ant is a Java based build
56 system. Ant is used by apache jakarta & xml projects.
57
58 %description -l fr
59 Ant est un outil de compilation multi-plateformes pour java. Il est
60 utilisé par les projets apache-jakarta et apache-xml.
61
62 %description -l it
63 Ant e' un tool indipendente dalla piattaforma creato per faciltare la
64 compilazione di programmi java.
65 Allo stato attuale viene utilizzato dai progetti apache jakarta ed
66 apache xml.
67
68 %description -l pl
69 Niezale¿ne od platformy narzêdzie do budowania w Javie. Ant jest
70 u¿ywany przez projekty apache jakarta i xml.
71
72 %package doc
73 Summary:        Online manual for ant
74 Summary(pl):    Dokumentacja online do ant
75 Group:          Documentation
76 Obsoletes:      ant-doc
77
78 %description doc
79 Documentation for ant, platform-independent build tool for Java. Used
80 by Apache Group for jakarta and xml projects.
81
82 %description doc -l pl
83 Dokumentacja do ant - niezale¿nego od platformy narzêdzia do budowania
84 w Javie.
85
86 %prep
87 %setup -q -n apache-ant-%{version}
88 %patch0 -p1
89
90 %build
91 export JAVA_HOME=%{_libdir}/java
92 # the same is probably needed for all other optional packages
93 %{?with_junit:export CLASSPATH=%{_javadir}/junit.jar}
94 sh build.sh
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT{%{_bindir},%{_javadir}}
99
100 install dist/bin/{ant,antRun,runant.pl,runant.py} $RPM_BUILD_ROOT%{_bindir}
101 install dist/lib/ant-*.jar $RPM_BUILD_ROOT%{_javadir}
102 install dist/lib/ant.jar $RPM_BUILD_ROOT%{_javadir}/ant-%{version}.jar
103 ln -sf ant-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/ant.jar
104
105 # xerces-j 2.6.2
106 install dist/lib/x*.jar $RPM_BUILD_ROOT%{_javadir}
107 ln -sf xercesImpl.jar $RPM_BUILD_ROOT%{_javadir}/jaxp_parser_impl.jar
108
109 # this looks strange
110 ln -sf . $RPM_BUILD_ROOT%{_javadir}/lib
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(644,root,root,755)
117 %doc KEYS LICENSE README WHATSNEW
118 %attr(755,root,root) %{_bindir}/ant
119 %attr(755,root,root) %{_bindir}/antRun
120 %attr(755,root,root) %{_bindir}/runant.pl
121 %attr(755,root,root) %{_bindir}/runant.py
122 %{_javadir}/lib
123 %{_javadir}/*.jar
124
125 %files doc
126 %defattr(644,root,root,755)
127 %doc docs
This page took 0.086294 seconds and 4 git commands to generate.