]> git.pld-linux.org Git - packages/ant.git/blob - ant.spec
- add todo
[packages/ant.git] / ant.spec
1 # TODO
2 # - consider using external xerces-j
3 # - add lots of subpackages like here: http://www.jpackage.org/rpm.php?id=912 ?
4 #
5 # Conditional build:
6 %bcond_with     basic_functionality     # generates package with only
7                                         # basic functionality, i.e. no deps
8 %bcond_without  junit                   # build without (commonly used) junit support
9 #
10 Summary:        ant build tool for Java
11 Summary(fr):    Outil de compilation pour java
12 Summary(it):    Tool per la compilazione di programmi java
13 Summary(pl):    ant - narzêdzie do budowania w Javie
14 Name:           jakarta-ant
15 Version:        1.6.5
16 %if %{with basic_functionality}
17 Release:        0.basic.1
18 %else
19 Release:        1
20 %endif
21 License:        Apache
22 Group:          Development/Languages/Java
23 Source0:        http://www.apache.org/dist/ant/source/apache-ant-%{version}-src.tar.bz2
24 # Source0-md5:  80a7ad191c40b7d8c82533524b282b6b
25 Patch0:         %{name}-ANT_HOME.patch
26 URL:            http://ant.apache.org/
27 BuildRequires:  jdk
28 %{?with_junit:BuildRequires:    junit}
29 %if %{without basic_functionality}
30 BuildRequires:  antlr
31 BuildRequires:  beanshell
32 BuildRequires:  bsf >= 2.3.0
33 BuildRequires:  jaf
34 BuildRequires:  jakarta-bcel
35 BuildRequires:  jakarta-commons-logging
36 BuildRequires:  jakarta-commons-net >= 1.2.2
37 BuildRequires:  jakarta-log4j
38 BuildRequires:  jakarta-oro >= 2.0.7
39 BuildRequires:  jakarta-regexp >= 1.3
40 BuildRequires:  javamail
41 BuildRequires:  jsch
42 BuildRequires:  netrexx
43 BuildRequires:  xalan-j
44 BuildRequires:  rhino >= 1.5R3
45 BuildRequires:  xml-commons-resolver >= 1.1
46 BuildRequires:  rpm-pythonprov
47 # TODO: icontract, jai, jdepend, starteam, stylebook, vaj, weblogic, xslp
48 %endif
49 Requires:       jdk
50 %{?with_junit:Provides: jakarta-ant(junit) = %{version}}
51 Provides:       jaxp_parser_impl
52 Provides:       xerces-j = 2.6.2
53 Obsoletes:      xerces-j
54 BuildArch:      noarch
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 Platform-independent build tool for Java. Ant is a Java based build
59 system. Ant is used by apache jakarta & xml projects.
60
61 %description -l fr
62 Ant est un outil de compilation multi-plateformes pour java. Il est
63 utilisé par les projets apache-jakarta et apache-xml.
64
65 %description -l it
66 Ant e' un tool indipendente dalla piattaforma creato per faciltare la
67 compilazione di programmi java.
68 Allo stato attuale viene utilizzato dai progetti apache jakarta ed
69 apache xml.
70
71 %description -l pl
72 Niezale¿ne od platformy narzêdzie do budowania w Javie. Ant jest
73 u¿ywany przez projekty apache jakarta i xml.
74
75 %package doc
76 Summary:        Online manual for ant
77 Summary(pl):    Dokumentacja online do ant
78 Group:          Documentation
79 Obsoletes:      ant-doc
80
81 %description doc
82 Documentation for ant, platform-independent build tool for Java. Used
83 by Apache Group for jakarta and xml projects.
84
85 %description doc -l pl
86 Dokumentacja do ant - niezale¿nego od platformy narzêdzia do budowania
87 w Javie.
88
89 %prep
90 %setup -q -n apache-ant-%{version}
91 %patch0 -p1
92
93 %build
94 export JAVA_HOME=%{_libdir}/java
95 # the same is probably needed for all other optional packages
96 %{?with_junit:export CLASSPATH=%{_javadir}/junit.jar}
97 sh build.sh
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 install -d $RPM_BUILD_ROOT{%{_bindir},%{_javadir}}
102
103 install dist/bin/{ant,antRun,runant.pl,runant.py} $RPM_BUILD_ROOT%{_bindir}
104 install dist/lib/ant-*.jar $RPM_BUILD_ROOT%{_javadir}
105 install dist/lib/ant.jar $RPM_BUILD_ROOT%{_javadir}/ant-%{version}.jar
106 ln -sf ant-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/ant.jar
107
108 # xerces-j 2.6.2
109 install dist/lib/x*.jar $RPM_BUILD_ROOT%{_javadir}
110 ln -sf xercesImpl.jar $RPM_BUILD_ROOT%{_javadir}/jaxp_parser_impl.jar
111
112 # this looks strange
113 ln -sf . $RPM_BUILD_ROOT%{_javadir}/lib
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120 %doc KEYS LICENSE README WHATSNEW
121 %attr(755,root,root) %{_bindir}/ant
122 %attr(755,root,root) %{_bindir}/antRun
123 %attr(755,root,root) %{_bindir}/runant.pl
124 %attr(755,root,root) %{_bindir}/runant.py
125 %{_javadir}/lib
126 %{_javadir}/*.jar
127
128 %files doc
129 %defattr(644,root,root,755)
130 %doc docs
This page took 0.077742 seconds and 4 git commands to generate.