]> git.pld-linux.org Git - packages/ant.git/blob - ant.spec
- rpm-pythonprov is needed to build it
[packages/ant.git] / ant.spec
1 # TODO: consider using external xerces-j
2 #
3 # Conditional build:
4 %bcond_with     basic_functionality     # generates package with only
5                                         # basic functionality, i.e. no deps
6 %bcond_without  junit                   # build without (commonly used) junit support
7 #
8 Summary:        ant build tool for Java
9 Summary(fr):    Outil de compilation pour java
10 Summary(it):    Tool per la compilazione di programmi java
11 Summary(pl):    ant - narzêdzie do budowania w Javie
12 Name:           jakarta-ant
13 Version:        1.6.5
14 %if %{with basic_functionality}
15 Release:        0.basic.1
16 %else
17 Release:        1
18 %endif
19 License:        Apache
20 Group:          Development/Languages/Java
21 Source0:        http://www.apache.org/dist/ant/source/apache-ant-%{version}-src.tar.bz2
22 # Source0-md5:  80a7ad191c40b7d8c82533524b282b6b
23 Patch0:         %{name}-ANT_HOME.patch
24 URL:            http://ant.apache.org/
25 BuildRequires:  jdk
26 %{?with_junit:BuildRequires:    junit}
27 %if %{without basic_functionality}
28 BuildRequires:  antlr
29 BuildRequires:  beanshell
30 BuildRequires:  bsf >= 2.3.0
31 BuildRequires:  jaf
32 BuildRequires:  jakarta-bcel
33 BuildRequires:  jakarta-commons-logging
34 BuildRequires:  jakarta-commons-net >= 1.2.2
35 BuildRequires:  jakarta-log4j
36 BuildRequires:  jakarta-oro >= 2.0.7
37 BuildRequires:  jakarta-regexp >= 1.3
38 BuildRequires:  javamail
39 BuildRequires:  jsch
40 BuildRequires:  netrexx
41 BuildRequires:  xalan-j
42 BuildRequires:  rhino >= 1.5R3
43 BuildRequires:  xml-commons-resolver >= 1.1
44 BuildRequires:  rpm-pythonprov
45 # TODO: icontract, jai, jdepend, starteam, stylebook, vaj, weblogic, xslp
46 %endif
47 Requires:       jdk
48 %{?with_junit:Provides: jakarta-ant(junit) = %{version}}
49 Provides:       jaxp_parser_impl
50 Provides:       xerces-j = 2.6.2
51 Obsoletes:      xerces-j
52 BuildArch:      noarch
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 Platform-independent build tool for Java. Ant is a Java based build
57 system. Ant is used by apache jakarta & xml projects.
58
59 %description -l fr
60 Ant est un outil de compilation multi-plateformes pour java. Il est
61 utilisé par les projets apache-jakarta et apache-xml.
62
63 %description -l it
64 Ant e' un tool indipendente dalla piattaforma creato per faciltare la
65 compilazione di programmi java.
66 Allo stato attuale viene utilizzato dai progetti apache jakarta ed
67 apache xml.
68
69 %description -l pl
70 Niezale¿ne od platformy narzêdzie do budowania w Javie. Ant jest
71 u¿ywany przez projekty apache jakarta i xml.
72
73 %package doc
74 Summary:        Online manual for ant
75 Summary(pl):    Dokumentacja online do ant
76 Group:          Documentation
77 Obsoletes:      ant-doc
78
79 %description doc
80 Documentation for ant, platform-independent build tool for Java. Used
81 by Apache Group for jakarta and xml projects.
82
83 %description doc -l pl
84 Dokumentacja do ant - niezale¿nego od platformy narzêdzia do budowania
85 w Javie.
86
87 %prep
88 %setup -q -n apache-ant-%{version}
89 %patch0 -p1
90
91 %build
92 export JAVA_HOME=%{_libdir}/java
93 # the same is probably needed for all other optional packages
94 %{?with_junit:export CLASSPATH=%{_javadir}/junit.jar}
95 sh build.sh
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{%{_bindir},%{_javadir}}
100
101 install dist/bin/{ant,antRun,runant.pl,runant.py} $RPM_BUILD_ROOT%{_bindir}
102 install dist/lib/ant-*.jar $RPM_BUILD_ROOT%{_javadir}
103 install dist/lib/ant.jar $RPM_BUILD_ROOT%{_javadir}/ant-%{version}.jar
104 ln -sf ant-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/ant.jar
105
106 # xerces-j 2.6.2
107 install dist/lib/x*.jar $RPM_BUILD_ROOT%{_javadir}
108 ln -sf xercesImpl.jar $RPM_BUILD_ROOT%{_javadir}/jaxp_parser_impl.jar
109
110 # this looks strange
111 ln -sf . $RPM_BUILD_ROOT%{_javadir}/lib
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(644,root,root,755)
118 %doc KEYS LICENSE README WHATSNEW
119 %attr(755,root,root) %{_bindir}/ant
120 %attr(755,root,root) %{_bindir}/antRun
121 %attr(755,root,root) %{_bindir}/runant.pl
122 %attr(755,root,root) %{_bindir}/runant.py
123 %{_javadir}/lib
124 %{_javadir}/*.jar
125
126 %files doc
127 %defattr(644,root,root,755)
128 %doc docs
This page took 0.099947 seconds and 4 git commands to generate.