]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
79e92debd91b729594077276f691a1516da5d6de
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 # - monitor http://bugs.kde.org/show_bug.cgi?id=137390 to remove the temporary fix
9 # - ProjectM (see README)
10 # - karma & MFS (see README)
11 #
12 # Conditional builds:
13 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
14 %bcond_without  mas             # disable MAS audio backend
15 %bcond_without  xine            # disable xine engine
16 %bcond_without  zeroconf        # disable support for zeroconf
17 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
18 %bcond_without  helix           # disable HelixPlayer engine
19 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
20 %bcond_with     nmm             # enable NMM audio backend
21 %bcond_with     mysql           # enable MySQL support
22 %bcond_with     pgsql           # enable PostgreSQL support
23 #
24 %ifarch i386
25 %undefine       with_helix
26 %endif
27
28 Summary:        A KDE audio player
29 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
30 Name:           amarok
31 Version:        1.4.9.1
32 Release:        12
33 License:        GPL
34 Group:          X11/Applications/Multimedia
35 Source0:        ftp://ftp.kde.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
36 # Source0-md5:  aa588778379a391ad3f4b3fc770217e4
37 Patch0:         %{name}-helixplayer-morearchs.patch
38 Patch1:         %{name}-libnjb.patch
39 Patch2:         %{name}-smp.patch
40 Patch3:         %{name}-sparc.patch
41 Patch4:         kde-ac260-lt.patch
42 Patch5:         kde-common-PLD.patch
43 Patch6:         %{name}-gcc4.patch
44 Patch7:         %{name}-titleorder.patch
45 Patch8:         %{name}-mongrel.patch
46 URL:            http://amarok.kde.org/
47 BuildRequires:  SDL-devel
48 BuildRequires:  alsa-lib-devel
49 BuildRequires:  autoconf
50 BuildRequires:  automake
51 BuildRequires:  dbus-glib-devel
52 BuildRequires:  gettext-devel
53 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
54 BuildRequires:  kdebase-devel
55 %{?with_akode:BuildRequires:    kdemultimedia-akode}
56 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
57 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.6.0}
58 %{?with_mp3players:BuildRequires:       libifp-devel >= 1.0.0.2}
59 BuildRequires:  libltdl-devel
60 %{?with_mp3players:BuildRequires:       libmtp-devel >= 0.1.1}
61 %{?with_mp3players:BuildRequires:       libnjb-devel >= 2.2.4}
62 %{?with_pgsql:BuildRequires:            libpqxx-devel}
63 BuildRequires:  libtunepimp-devel >= 0.5.1-6
64 BuildRequires:  libvisual-devel >= 0.4.0
65 BuildRequires:  mpeg4ip-devel >= 1:1.6
66 %{?with_mysql:BuildRequires:            mysql-devel}
67 BuildRequires:  pcre-devel
68 BuildRequires:  pkgconfig
69 BuildRequires:  rpm-pythonprov
70 BuildRequires:  rpmbuild(macros) >= 1.129
71 BuildRequires:  ruby-devel >= 1.8
72 BuildRequires:  sed >= 4.0
73 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
74 BuildRequires:  taglib-devel >= 1.4
75 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
76 Requires(post): /sbin/ldconfig
77 Requires:       %{name}-plugin = %{version}-%{release}
78 Requires:       kdebase-core >= 9:3.1.93
79 Requires:       kdelibs-libs >= 9:3.5.9
80 Requires:       ruby-mongrel
81 Obsoletes:      amarok-arts
82 Suggests:       kdemultimedia(audiocd) >= 9:3.1.93
83 Suggests:       libvisual-plugin-actor-JESS
84 Suggests:       libvisual-plugin-actor-bumpscope
85 Suggests:       libvisual-plugin-actor-corona
86 Suggests:       libvisual-plugin-actor-flower
87 Suggests:       libvisual-plugin-actor-gdkpixbuf
88 Suggests:       libvisual-plugin-actor-gforce
89 Suggests:       libvisual-plugin-actor-gstreamer
90 Suggests:       libvisual-plugin-actor-infinite
91 Suggests:       libvisual-plugin-actor-jakdaw
92 Suggests:       libvisual-plugin-actor-lv_analyzer
93 Suggests:       libvisual-plugin-actor-lv_gltest
94 Suggests:       libvisual-plugin-actor-lv_scope
95 Suggests:       libvisual-plugin-actor-madspin
96 Suggests:       libvisual-plugin-actor-nastyfft
97 Suggests:       libvisual-plugin-actor-oinksie
98 Suggests:       libvisual-plugin-input-alsa
99 Suggests:       libvisual-plugin-input-esd
100 Suggests:       libvisual-plugin-input-jack
101 Suggests:       libvisual-plugin-input-mplayer
102 Suggests:       libvisual-plugin-morph-alphablend
103 Suggests:       libvisual-plugin-morph-flash
104 Suggests:       libvisual-plugin-morph-slide
105 Suggests:       libvisual-plugin-morph-tentacle
106 Suggests:       python-PyKDE
107 Obsoletes:      amarok-xmms
108 # sr@Latn vs. sr@latin
109 Conflicts:      glibc-misc < 6:2.7
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 # temporary hack for proper libgpod::itdb_get_mountpoint() detection.
113 %define         filterout_ld    -Wl,--as-needed
114
115 %description
116 A KDE audio player.
117
118 %description -l pl.UTF-8
119 Odtwarzacz audio dla KDE.
120
121 %package akode
122 Summary:        Plugin akode
123 Summary(pl.UTF-8):      Wtyczka akode
124 Group:          X11/Applications/Multimedia
125 Requires:       %{name} = %{version}-%{release}
126 Provides:       %{name}-plugin = %{version}-%{release}
127
128 %description akode
129 Plugin akode.
130
131 %description akode -l pl.UTF-8
132 Wtyczka akode.
133
134 %package helix
135 Summary:        Helix/Realplayer playback support for amarok
136 Summary(pl.UTF-8):      Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
137 Group:          X11/Applications/Multimedia
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       helix-core
140 Provides:       %{name}-plugin = %{version}-%{release}
141
142 %description helix
143 Helix/Realplayer playback support for amarok.
144
145 %description helix -l pl.UTF-8
146 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
147
148 %package gstreamer
149 Summary:        Plugin gstreamer
150 Summary(pl.UTF-8):      Wtyczka gstreamer
151 Group:          X11/Applications/Multimedia
152 # deps, to get it working:
153 # mp3 decoder:  gstreamer-mad
154 # ogg decoder:  gstreamer-vorbis
155 # audio output driver:  gstreamer-audiosink-alsa
156 # from gstreamer-audio-effects to control volume, etc
157 # needed libs:
158 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
159 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
160 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
161 # gstreamer-musicbrainz for being able to edit id3 tags on files.
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       gstreamer-audio-effects
164 Requires:       gstreamer-audiosink
165 Requires:       gstreamer-mad
166 Requires:       gstreamer-musicbrainz
167 Requires:       gstreamer-vorbis
168 Provides:       %{name}-plugin = %{version}-%{release}
169
170 %description gstreamer
171 Plugin gstreamer.
172
173 %description gstreamer -l pl.UTF-8
174 Wtyczka gstreamer.
175
176 %package xine
177 Summary:        Plugin xine
178 Summary(pl.UTF-8):      Wtyczka xine
179 Group:          X11/Applications/Multimedia
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       xine-plugin-audio
182 Provides:       %{name}-plugin = %{version}-%{release}
183
184 %description xine
185 Plugin xine.
186
187 %description xine -l pl.UTF-8
188 Wtyczka xine.
189
190 %package zeroconf
191 Summary:        Zeroconf data
192 Summary(pl.UTF-8):      Dane dla zeroconf
193 Group:          X11/Applications/Multimedia
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       kdenetwork-kdnssd
196 Provides:       %{name}-plugin = %{version}-%{release}
197
198 %description zeroconf
199 Zeroconf data.
200
201 %description zeroconf -l pl.UTF-8
202 Dane dla zeroconf.
203
204 %package scripts
205 Summary:        amaroK scripts
206 Summary(pl.UTF-8):      Skrypty amaroKa
207 Group:          X11/Applications/Multimedia
208 Requires:       %{name} = %{version}-%{release}
209 Requires:       kdebase-kdialog
210 Requires:       python-PyQt
211 Requires:       ruby-modules
212
213 %description scripts
214 amaroK scripts allow you extend amaroK functionality.
215
216 You can learn more about scripts in amaroK from here:
217 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
218
219 %description scripts -l pl.UTF-8
220 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
221
222 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
223 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
224
225 %prep
226 %setup -q
227 %patch0 -p1
228 %patch1 -p1
229 %patch2 -p1
230 %patch3 -p1
231 %patch4 -p1
232 %patch5 -p1
233 %patch6 -p1
234 %patch7 -p1
235 %patch8 -p1
236
237 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
238         amarok/src/amarok.desktop \
239
240 # see kde bug #110909
241 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
242
243 # kill env, call interpreter directly, so rpm automatics could rule
244 %{__sed} -i -e '
245         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
246         1s,#!.*bin/env.*python,#!%{__python},
247 ' amarok/src/scripts/*/*.{py,rb} amarok/src/amarok_proxy.rb
248
249 %build
250 cp -f /usr/share/automake/config.sub admin
251 %{__make} -f admin/Makefile.common cvs
252
253 # hack: passing something other than "no" or "yes" to --with-helix allows
254 # us to pass HELIX_LIBS
255 %configure \
256         HELIX_LIBS=%{_libdir}/helixplayer \
257         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
258         --disable-rpath \
259         --with%{!?with_mas:out}-mas \
260         --with%{!?with_xine:out}-xine \
261         --with%{!?with_gstreamer:out}-gstreamer10 \
262         --with%{!?with_akode:out}-akode \
263         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
264         --with%{!?with_nmm:out}-nmm \
265         --with%{!?with_mp3players:out}-libgpod \
266         --with%{!?with_mp3players:out}-libnjb \
267         --with%{!?with_mp3players:out}-libmtp \
268         --with%{!?with_mp3players:out}-ifp \
269         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
270         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
271         --disable-final \
272         --with-mp4v2 \
273         --with-qt-libraries=%{_libdir} \
274         --with%{!?with_included_sqlite:out}-included-sqlite
275
276 %{__make}
277
278 %install
279 rm -rf $RPM_BUILD_ROOT
280
281 %{__make} install \
282         DESTDIR=$RPM_BUILD_ROOT \
283         ruby_rubylibdir=%{ruby_rubylibdir} \
284         kde_htmldir=%{_kdedocdir} \
285         kde_libs_htmldir=%{_kdedocdir}
286
287 # remove bogus dir
288 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
289
290 rm $RPM_BUILD_ROOT%{_libdir}/kde3/*.la
291 rm $RPM_BUILD_ROOT%{_libdir}/libamarok.{so,la}
292
293 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
294         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
295 %find_lang amarok --all-name --with-kde
296
297 %clean
298 rm -rf $RPM_BUILD_ROOT
299
300 %post -p /sbin/ldconfig
301
302 %postun -p /sbin/ldconfig
303
304 %files -f amarok.lang
305 %defattr(644,root,root,755)
306 %doc AUTHORS ChangeLog README
307 %attr(755,root,root) %{_bindir}/amarok
308 %attr(755,root,root) %{_bindir}/amarokapp
309 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
310 %attr(755,root,root) %{_bindir}/amarok_libvisual
311 # used by last.fm and daap
312 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
313 # used by daap
314 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
315 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
316 %attr(755,root,root) %ghost %{_libdir}/libamarok.so.0
317 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
318 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
319 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
320 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
321 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
322 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
323 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
324 %dir %{_datadir}/apps/amarok
325 %dir %{_datadir}/apps/amarok/scripts
326 %{_datadir}/apps/amarok/*.rc
327 %{_datadir}/apps/amarok/data
328 %{_datadir}/apps/amarok/icons
329 %{_datadir}/apps/amarok/images
330 %{_datadir}/apps/amarok/themes
331 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
332 %{_datadir}/apps/konqueror/servicemenus/amarok_addaspodcast.desktop
333 %{_datadir}/apps/konqueror/servicemenus/amarok_play_audiocd.desktop
334 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
335 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
336 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
337 %{_datadir}/apps/profiles/amarok.profile.xml
338 %{_datadir}/config/amarokrc
339 %{_datadir}/config.kcfg/amarok.kcfg
340 %{_datadir}/services/amarok_generic-mediadevice.desktop
341 %{_datadir}/services/amarok_void-engine_plugin.desktop
342 %{_datadir}/services/amarok_daap-mediadevice.desktop
343 %{_datadir}/services/amarok_massstorage-device.desktop
344 %{_datadir}/services/amarok_nfs-device.desktop
345 %{_datadir}/services/amarok_smb-device.desktop
346 %{_datadir}/services/amaroklastfm.protocol
347 %{_datadir}/services/amarokitpc.protocol
348 %{_datadir}/services/amarokpcast.protocol
349 %{_datadir}/servicetypes/amarok_codecinstall.desktop
350 %{_datadir}/servicetypes/amarok_plugin.desktop
351 %{_desktopdir}/kde/amarok.desktop
352 %{_iconsdir}/*/*/apps/amarok.*
353
354 # TODO: move to subpackage
355 %dir %{ruby_rubylibdir}/amarok
356 # used by daap
357 %{ruby_rubylibdir}/amarok/codes.rb
358 # used by daap and lyrics_lyrc
359 %{ruby_rubylibdir}/amarok/debug.rb
360
361 # TODO: move to subpackage
362 %if %{with mp3players}
363 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
364 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
365 %attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
366 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
367 %{_datadir}/services/amarok_ifp-mediadevice.desktop
368 %{_datadir}/services/amarok_ipod-mediadevice.desktop
369 %{_datadir}/services/amarok_mtp-mediadevice.desktop
370 %{_datadir}/services/amarok_njb-mediadevice.desktop
371 %endif
372
373 %if %{with akode}
374 %files akode
375 %defattr(644,root,root,755)
376 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
377 %{_datadir}/services/amarok_aKode-engine.desktop
378 %endif
379
380 %if %{with gstreamer}
381 %files gstreamer
382 %defattr(644,root,root,755)
383 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
384 %{_datadir}/config.kcfg/gstconfig.kcfg
385 %{_datadir}/services/amarok_gst10engine_plugin.desktop
386 %endif
387
388 %if %{with helix}
389 %files helix
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
392 %{_datadir}/config.kcfg/helixconfig.kcfg
393 %{_datadir}/services/amarok_helixengine_plugin.desktop
394 %endif
395
396 %if %{with xine}
397 %files xine
398 %defattr(644,root,root,755)
399 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
400 %{_datadir}/config.kcfg/xinecfg.kcfg
401 %{_datadir}/services/amarok_xine-engine.desktop
402 %endif
403
404 %if 0
405 %if %{with zeroconf}
406 %files zeroconf
407 %defattr(644,root,root,755)
408 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
409 %endif
410 %endif
411
412 %files scripts
413 %defattr(644,root,root,755)
414 %dir %{_datadir}/apps/amarok/scripts/common
415 %{_datadir}/apps/amarok/scripts/common/Publisher.py
416 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
417
418 %dir %{_datadir}/apps/amarok/scripts/templates
419 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
420 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
421 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
422
423 # amarok searches for executable programs for scripts
424 # to figure out which files need to have execute permission, use this
425 # find command:
426 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
427
428 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
429 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
430 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
431
432 %dir %{_datadir}/apps/amarok/scripts/playlist2html
433 %{_datadir}/apps/amarok/scripts/playlist2html/README
434 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
435 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
436 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
437 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.spec
438 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.spec
439
440
441 %dir %{_datadir}/apps/amarok/scripts/webcontrol
442 %{_datadir}/apps/amarok/scripts/webcontrol/README
443 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
444 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
445 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
446 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
447 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
448 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
449 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
450 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
451 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
452 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
453 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
454 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
455 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
456 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
457 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
458 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
459 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
460 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
461 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
462
463 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
464 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
465 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
466 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
467 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
468
469 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
470 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
471 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
472 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
473 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
474
475 %dir %{_datadir}/apps/amarok/scripts/score_default
476 %{_datadir}/apps/amarok/scripts/score_default/COPYING
477 %{_datadir}/apps/amarok/scripts/score_default/README
478 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
479 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
480 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
481 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
482 %{_datadir}/apps/amarok/scripts/score_impulsive/README
483 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
484 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
485
486 %if 0
487 %dir %{_datadir}/apps/amarok/scripts/amarok_live
488 %{_datadir}/apps/amarok/scripts/amarok_live/README
489 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
490 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
491 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
492 %endif
This page took 0.11396 seconds and 2 git commands to generate.