]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- src/vis/xmms dropped (i don't see it in sources and didn't got any reasonable answe...
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 # - monitor http://bugs.kde.org/show_bug.cgi?id=137390 to remove the temporary fix
9 # - karma & MFS (see README)
10 # - ProjectM (see README)
11 #
12 # Conditional builds:
13 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
14 %bcond_without  mas             # disable MAS audio backend
15 %bcond_without  xine            # disable xine engine
16 %bcond_without  zeroconf        # disable support for zeroconf
17 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
18 %bcond_without  helix           # disable HelixPlayer engine
19 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
20 %bcond_with     nmm             # enable NMM audio backend
21 %bcond_with     mysql           # enable MySQL support
22 %bcond_with     pgsql           # enable PostgreSQL support
23 #
24 %ifarch i386
25 %undefine       with_helix
26 %endif
27
28 Summary:        A KDE audio player
29 Summary(pl.UTF-8):   Odtwarzacz audio dla KDE
30 Name:           amarok
31 Version:        1.4.5
32 Release:        2
33 License:        GPL
34 Group:          X11/Applications/Multimedia
35 Source0:        ftp://ftp.kde.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
36 # Source0-md5:  1dac1cb5ac9c9cdabdab5f69b39e92c8
37 Patch0:         %{name}-helixplayer-morearchs.patch
38 Patch1:         %{name}-libnjb.patch
39 Patch3:         %{name}-sparc.patch
40 Patch4:         kde-ac260-lt.patch
41 Patch5:         kde-common-PLD.patch
42 Patch6:         %{name}-gcc4.patch
43 Patch7:         %{name}-titleorder.patch
44 URL:            http://amarok.kde.org/
45 BuildRequires:  SDL-devel
46 BuildRequires:  alsa-lib-devel
47 BuildRequires:  autoconf
48 BuildRequires:  automake
49 BuildRequires:  dbus-glib-devel
50 BuildRequires:  gettext-devel
51 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
52 BuildRequires:  kdebase-devel
53 %{?with_akode:BuildRequires:    kdemultimedia-akode}
54 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
55 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.4.2}
56 %{?with_mp3players:BuildRequires:       libifp-devel >= 1.0.0.2}
57 BuildRequires:  libltdl-devel
58 %{?with_mp3players:BuildRequires:       libmtp-devel >= 0.1.1}
59 %{?with_mp3players:BuildRequires:       libnjb-devel >= 2.2.4}
60 %{?with_pgsql:BuildRequires:            libpqxx-devel}
61 BuildRequires:  libtunepimp-devel >= 0.5.1-6
62 BuildRequires:  libvisual-devel >= 0.4.0
63 BuildRequires:  mpeg4ip-devel >= 1:1.5
64 %{?with_mysql:BuildRequires:            mysql-devel}
65 BuildRequires:  pcre-devel
66 BuildRequires:  pkgconfig
67 BuildRequires:  rpm-pythonprov
68 BuildRequires:  rpmbuild(macros) >= 1.129
69 BuildRequires:  ruby-devel >= 1.8
70 BuildRequires:  sed >= 4.0
71 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
72 BuildRequires:  taglib-devel >= 1.4
73 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
74 Requires(post): /sbin/ldconfig
75 Requires:       %{name}-plugin = %{version}-%{release}
76 Requires:       kdebase-core >= 9:3.1.93
77 Requires:       kdemultimedia-audiocd >= 9:3.1.93
78 Obsoletes:      amarok-arts
79 Obsoletes:      amarok-xmms
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 # temporary hack for proper libgpod::itdb_get_mountpoint() detection.
83 %define         filterout_ld    -Wl,--as-needed
84
85 %description
86 A KDE audio player.
87
88 %description -l pl.UTF-8
89 Odtwarzacz audio dla KDE.
90
91 %package akode
92 Summary:        Plugin akode
93 Summary(pl.UTF-8):   Wtyczka akode
94 Group:          X11/Applications/Multimedia
95 Requires:       %{name} = %{version}-%{release}
96 Provides:       %{name}-plugin = %{version}-%{release}
97
98 %description akode
99 Plugin akode.
100
101 %description akode -l pl.UTF-8
102 Wtyczka akode.
103
104 %package helix
105 Summary:        Helix/Realplayer playback support for amarok
106 Summary(pl.UTF-8):   Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
107 Group:          X11/Applications/Multimedia
108 Requires:       %{name} = %{version}-%{release}
109 Requires:       helix-core
110 Provides:       %{name}-plugin = %{version}-%{release}
111
112 %description helix
113 Helix/Realplayer playback support for amarok.
114
115 %description helix -l pl.UTF-8
116 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
117
118 %package gstreamer
119 Summary:        Plugin gstreamer
120 Summary(pl.UTF-8):   Wtyczka gstreamer
121 Group:          X11/Applications/Multimedia
122 # deps, to get it working:
123 # mp3 decoder:  gstreamer-mad
124 # ogg decoder:  gstreamer-vorbis
125 # audio output driver:  gstreamer-audiosink-alsa
126 # from gstreamer-audio-effects to control volume, etc
127 # needed libs:
128 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
129 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
130 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
131 # gstreamer-musicbrainz for being able to edit id3 tags on files.
132 Requires:       %{name} = %{version}-%{release}
133 Requires:       gstreamer-audio-effects
134 Requires:       gstreamer-audiosink
135 Requires:       gstreamer-mad
136 Requires:       gstreamer-musicbrainz
137 Requires:       gstreamer-vorbis
138 Provides:       %{name}-plugin = %{version}-%{release}
139
140 %description gstreamer
141 Plugin gstreamer.
142
143 %description gstreamer -l pl.UTF-8
144 Wtyczka gstreamer.
145
146 %package xine
147 Summary:        Plugin xine
148 Summary(pl.UTF-8):   Wtyczka xine
149 Group:          X11/Applications/Multimedia
150 Requires:       %{name} = %{version}-%{release}
151 Requires:       xine-plugin-audio
152 Provides:       %{name}-plugin = %{version}-%{release}
153
154 %description xine
155 Plugin xine.
156
157 %description xine -l pl.UTF-8
158 Wtyczka xine.
159
160 %package zeroconf
161 Summary:        Zeroconf data
162 Summary(pl.UTF-8):   Dane dla zeroconf
163 Group:          X11/Applications/Multimedia
164 Requires:       %{name} = %{version}-%{release}
165 Requires:       kdenetwork-kdnssd
166 Provides:       %{name}-plugin = %{version}-%{release}
167
168 %description zeroconf
169 Zeroconf data.
170
171 %description zeroconf -l pl.UTF-8
172 Dane dla zeroconf.
173
174 %package scripts
175 Summary:        amaroK scripts
176 Summary(pl.UTF-8):   Skrypty amaroKa
177 Group:          X11/Applications/Multimedia
178 Requires:       %{name} = %{version}-%{release}
179 Requires:       kdebase-kdialog
180 Requires:       python-PyQt
181 Requires:       ruby-modules
182
183 %description scripts
184 amaroK scripts allow you extend amaroK functionality.
185
186 You can learn more about scripts in amaroK from here:
187 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
188
189 %description scripts -l pl.UTF-8
190 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
191
192 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
193 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
194
195 %prep
196 %setup -q
197 %patch0 -p1
198 %patch1 -p1
199 %patch3 -p1
200 %patch4 -p1
201 %patch5 -p1
202 %patch6 -p1
203 %patch7 -p1
204
205 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
206         amarok/src/amarok.desktop \
207
208 # see kde bug #110909
209 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
210
211 # kill env, call interpreter directly, so rpm automatics could rule
212 %{__sed} -i -e '
213         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
214         1s,#!.*bin/env.*python,#!%{__python},
215         1s,#!.*bin/env.*bash,#!/bin/bash,
216 ' amarok/src/scripts/*/*.{py,rb,sh} amarok/src/amarok_proxy.rb
217
218 %build
219 cp -f /usr/share/automake/config.sub admin
220 %{__make} -f admin/Makefile.common cvs
221
222 # hack: passing something other than "no" or "yes" to --with-helix allows
223 # us to pass HELIX_LIBS
224 %configure \
225         HELIX_LIBS=%{_libdir}/helixplayer \
226         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
227         --disable-rpath \
228         --with%{!?with_mas:out}-mas \
229         --with%{!?with_xine:out}-xine \
230         --with%{!?with_gstreamer:out}-gstreamer10 \
231         --with%{!?with_akode:out}-akode \
232         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
233         --with%{!?with_nmm:out}-nmm \
234         --with%{!?with_mp3players:out}-libgpod \
235         --with%{!?with_mp3players:out}-libnjb \
236         --with%{!?with_mp3players:out}-libmtp \
237         --with%{!?with_mp3players:out}-ifp \
238         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
239         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
240         --disable-final \
241         --with-mp4v2 \
242         --with-qt-libraries=%{_libdir} \
243         --with%{!?with_included_sqlite:out}-included-sqlite
244
245 %{__make}
246
247 %install
248 rm -rf $RPM_BUILD_ROOT
249
250 %{__make} install \
251         DESTDIR=$RPM_BUILD_ROOT \
252         kde_htmldir=%{_kdedocdir} \
253         kde_libs_htmldir=%{_kdedocdir}
254
255 # remove bogus dir
256 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
257
258 rm $RPM_BUILD_ROOT%{_libdir}/kde3/*.la
259 rm $RPM_BUILD_ROOT%{_libdir}/ruby_lib/libhttp11.la
260
261 %find_lang amarok --all-name --with-kde
262
263 %clean
264 rm -rf $RPM_BUILD_ROOT
265
266 %post
267 /sbin/ldconfig
268 if [ "$1" = 1 ]; then
269         echo "Remember to install libvisual-plugins-* packages if you"
270         echo "want to have a visualizations in amaroK."
271 fi
272
273 %postun -p /sbin/ldconfig
274
275 %files -f amarok.lang
276 %defattr(644,root,root,755)
277 %doc AUTHORS ChangeLog README
278 %attr(755,root,root) %{_bindir}/amarok
279 %attr(755,root,root) %{_bindir}/amarokapp
280 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
281 %attr(755,root,root) %{_bindir}/amarok_libvisual
282 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
283 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
284 %attr(755,root,root) %{_libdir}/libamarok.so
285 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
286 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
287 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
288 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
289 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
290 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
291 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
292 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
293 %{_libdir}/ruby_lib/http11.rb
294 %attr(755,root,root) %{_libdir}/ruby_lib/libhttp11.so
295 %attr(755,root,root) %{_libdir}/ruby_lib/libhttp11.so.0.0.0
296 %dir %{_datadir}/apps/amarok
297 %dir %{_datadir}/apps/amarok/scripts
298 %{_datadir}/apps/amarok/ruby_lib
299 %{_datadir}/apps/amarok/*.rc
300 %{_datadir}/apps/amarok/data
301 %{_datadir}/apps/amarok/icons
302 %{_datadir}/apps/amarok/images
303 %{_datadir}/apps/amarok/themes
304 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
305 %{_datadir}/apps/konqueror/servicemenus/amarok_addaspodcast.desktop
306 %{_datadir}/apps/konqueror/servicemenus/amarok_play_audiocd.desktop
307 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
308 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
309 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
310 %{_datadir}/apps/profiles/amarok.profile.xml
311 %{_datadir}/config/amarokrc
312 %{_datadir}/config.kcfg/amarok.kcfg
313 %{_datadir}/services/amarok_generic-mediadevice.desktop
314 %{_datadir}/services/amarok_void-engine_plugin.desktop
315 %{_datadir}/services/amarok_daap-mediadevice.desktop
316 %{_datadir}/services/amarok_massstorage-device.desktop
317 %{_datadir}/services/amarok_nfs-device.desktop
318 %{_datadir}/services/amarok_smb-device.desktop
319 %{_datadir}/services/amaroklastfm.protocol
320 %{_datadir}/services/amarokitpc.protocol
321 %{_datadir}/services/amarokpcast.protocol
322 %{_datadir}/servicetypes/amarok_codecinstall.desktop
323 %{_datadir}/servicetypes/amarok_plugin.desktop
324 %{_desktopdir}/kde/amarok.desktop
325 %{_iconsdir}/*/*/apps/amarok.*
326 # TODO: move to subpackage
327 %if %{with mp3players}
328 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
329 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
330 %attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
331 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
332 %{_datadir}/services/amarok_ifp-mediadevice.desktop
333 %{_datadir}/services/amarok_ipod-mediadevice.desktop
334 %{_datadir}/services/amarok_mtp-mediadevice.desktop
335 %{_datadir}/services/amarok_njb-mediadevice.desktop
336 %endif
337
338 %if %{with akode}
339 %files akode
340 %defattr(644,root,root,755)
341 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
342 %{_datadir}/services/amarok_aKode-engine.desktop
343 %endif
344
345 %if %{with gstreamer}
346 %files gstreamer
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
349 %{_datadir}/config.kcfg/gstconfig.kcfg
350 %{_datadir}/services/amarok_gst10engine_plugin.desktop
351 %endif
352
353 %if %{with helix}
354 %files helix
355 %defattr(644,root,root,755)
356 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
357 %{_datadir}/config.kcfg/helixconfig.kcfg
358 %{_datadir}/services/amarok_helixengine_plugin.desktop
359 %endif
360
361 %if %{with xine}
362 %files xine
363 %defattr(644,root,root,755)
364 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
365 %{_datadir}/config.kcfg/xinecfg.kcfg
366 %{_datadir}/services/amarok_xine-engine.desktop
367 %endif
368
369 %if 0
370 %if %{with zeroconf}
371 %files zeroconf
372 %defattr(644,root,root,755)
373 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
374 %endif
375 %endif
376
377 %files scripts
378 %defattr(644,root,root,755)
379 %dir %{_datadir}/apps/amarok/scripts/common
380 %{_datadir}/apps/amarok/scripts/common/Publisher.py
381 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
382
383 %dir %{_datadir}/apps/amarok/scripts/templates
384 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
385 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
386 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
387
388 # amarok searches for executable programs for scripts
389 # to figure out which files need to have execute permission, use this
390 # find command:
391 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
392
393 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
394 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
395 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
396
397 %dir %{_datadir}/apps/amarok/scripts/playlist2html
398 %{_datadir}/apps/amarok/scripts/playlist2html/README
399 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
400 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
401 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
402
403 %dir %{_datadir}/apps/amarok/scripts/webcontrol
404 %{_datadir}/apps/amarok/scripts/webcontrol/README
405 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
406 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
407 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
408 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
409 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
410 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
411 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
412 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
413 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
414 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
415 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
416 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
417 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
418 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
419 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
420 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
421 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
422 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
423 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
424
425 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
426 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
427 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
428 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
429 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
430
431 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
432 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
433 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
434 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
435 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
436
437 %dir %{_datadir}/apps/amarok/scripts/score_default
438 %{_datadir}/apps/amarok/scripts/score_default/COPYING
439 %{_datadir}/apps/amarok/scripts/score_default/README
440 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
441 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
442 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
443 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
444 %{_datadir}/apps/amarok/scripts/score_impulsive/README
445 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
446 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
447
448 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
449 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
450
451 %if 0
452 %dir %{_datadir}/apps/amarok/scripts/amarok_live
453 %{_datadir}/apps/amarok/scripts/amarok_live/README
454 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
455 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
456 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
457 %endif
This page took 0.076062 seconds and 3 git commands to generate.