]> git.pld-linux.org Git - packages/Zope-OrderedFolderSupportPatch.git/blob - Zope-OrderedFolderSupportPatch.spec
- initial release
[packages/Zope-OrderedFolderSupportPatch.git] / Zope-OrderedFolderSupportPatch.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    OrderedFolderSupportPatch
3 Summary:        This is a patch-product that modifies ObjectManager
4 Summary(pl):    Poprawka modyfikuj±ca ObjectManagera
5 Name:           Zope-%{zope_subname}
6 Version:        1.0
7 Release:        1
8 License:        GPL
9 Group:          Development/Tools
10 Source0:        OrderedFolderSupportPatch.tar.gz
11 URL:            http://www.nuxeo.org
12 BuildRequires:  python >= 2.2
13 Requires(post,postun):  /usr/sbin/installzopeproduct
14 %pyrequires_eq  python-modules
15 Requires:       Zope >= 2.6
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This is a patch-product that modifies ObjectManager to allow folders
21 to be ordered by the user.
22
23 %description -l pl
24 Poprawka modyfikuj±ca dostêp do ObjectManagera przez u¿ytkownika.
25
26 %prep
27 %setup -q -n %{zope_subname}
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
32
33 cp -af *.py $RPM_BUILD_ROOT%{_datadir}/%{name}
34
35 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
36 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
37
38 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %post
44 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
45 if [ -f /var/lock/subsys/zope ]; then
46         /etc/rc.d/init.d/zope restart >&2
47 fi
48
49 %postun
50 if [ "$1" = "0" ]; then
51         /usr/sbin/installzopeproduct -d %{zope_subname}
52         if [ -f /var/lock/subsys/zope ]; then
53                 /etc/rc.d/init.d/zope restart >&2
54         fi
55 fi
56
57 %files
58 %defattr(644,root,root,755)
59 %doc CHANGES HISTORY LICENSE.txt README.txt
60 %{_datadir}/%{name}
This page took 2.669402 seconds and 3 git commands to generate.