]> git.pld-linux.org Git - packages/Zope-CMFCollector.git/blob - Zope-CMFCollector.spec
d9765e198e18c326c1b6311623c62ae460404794
[packages/Zope-CMFCollector.git] / Zope-CMFCollector.spec
1
2 %include        /usr/lib/rpm/macros.python
3
4 %define         zope_subname    CMFCollector
5
6 Summary:        CMFCollector is an issue collector for Zope.
7 Summary(pl):    CMFCollector jest dodatkiem do Zope umo¿liwiaj±cy zbieranie wyników
8 Name:           Zope-%{zope_subname}
9 Version:        0.9b
10 Release:        1
11 License:        GNU
12 Group:          Development/Tools
13 Source0:        http://cvs.zope.org/CMF/%{zope_subname}/%{zope_subname}.tar.gz?tarball=1
14 # Source0-md5:  151c906d1058115f3f98155ec042f8fe
15 URL:            http://cvs.zope.org/CMF/%{zope_subname}/
16 %pyrequires_eq  python-modules
17 Requires:       Zope
18 Requires:       CMF
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         product_dir     /usr/lib/zope/Products
22
23 %description
24 CMFCollector is an issue collector for Zope.
25
26 %description -l pl
27 CMFCollector jest dodatkiem do Zope umo¿liwiaj±cy zbieranie wyników
28
29 %prep
30 %setup -q -c %{zope_subname}.tar.gz?tarball=1
31
32 %build
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36
37 install -d $RPM_BUILD_ROOT%{product_dir}
38 cp -af * $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
39
40 %py_comp $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
41 %py_ocomp $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
42
43 rm -rf $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}/*.txt
44 find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %post
50 if [ -f /var/lock/subsys/zope ]; then
51         /etc/rc.d/init.d/zope restart >&2
52 fi
53
54 %preun
55
56 %postun
57 if [ -f /var/lock/subsys/zope ]; then
58         /etc/rc.d/init.d/zope restart >&2
59 fi
60
61 %files
62 %defattr(644,root,root,755)
63 %doc %{zope_subname}/*.txt
64 %{product_dir}/%{zope_subname}
This page took 0.054209 seconds and 3 git commands to generate.