]> git.pld-linux.org Git - packages/Thunar.git/blob - Thunar.spec
- added R: libexo-devel to the devel subpackage
[packages/Thunar.git] / Thunar.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         _pre            rc1
6 %define         xfce_version    4.3.99.1
7 Summary:        Xfce file manager
8 Summary(pl):    Zarz±dca plików Xfce
9 Name:           Thunar
10 Version:        0.4.0
11 Release:        0.%{_pre}.1
12 License:        GPL v2 / LGPL v2
13 Group:          X11/Applications
14 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/%{name}-%{version}%{_pre}.tar.bz2
15 # Source0-md5:  b07ae97a69964112e0af84ba2f63585d
16 URL:            http://thunar.xfce.org/
17 BuildRequires:  GConf2-devel >= 2.14.0
18 BuildRequires:  dbus-glib-devel >= 0.62
19 # XXX: gamin (>= 0.1.0) is preferred over fam
20 BuildRequires:  fam-devel
21 BuildRequires:  gettext-devel
22 BuildRequires:  glib2-devel >= 1:2.12.0
23 BuildRequires:  gtk+2-devel >= 2:2.10.0
24 BuildRequires:  hal-devel >= 0.5.7
25 BuildRequires:  intltool
26 BuildRequires:  libexif-devel >= 0.6.13
27 BuildRequires:  libexo-devel >= 0.3.1.10
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng-devel >= 1.2.12
30 BuildRequires:  libxfce4util-devel >= %{xfce_version}
31 BuildRequires:  pcre-devel >= 6.0
32 BuildRequires:  perl-base
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(macros) >= 1.311
35 BuildRequires:  startup-notification-devel >= 0.8
36 Requires:       %{name}-libs = %{version}-%{release}
37 Requires(post,postun):  gtk+2 >= 2:2.10.0
38 Requires:       hal >= 0.5.7
39 Requires(post,postun):  hicolor-icon-theme
40 Requires:       libexo >= 0.3.1.10
41 Requires:       shared-mime-info >= 0.15
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Thunar is a modern file manager, aiming to be easy-to-use and fast.
46
47 %description -l pl
48 Thunar jest nowoczesnym zarz±dc± plików, nakierowanym na ³atwo¶æ i
49 szybko¶æ u¿ycia.
50
51 %package libs
52 Summary:        Thunar libraries
53 Summary(pl):    Biblioteki Thunar
54 Group:          Libraries
55
56 %description libs
57 Thunar libraries.
58
59 %description libs -l pl
60 Biblioteki Thunar.
61
62 %package devel
63 Summary:        Header files for Thunar libraries
64 Summary(pl):    Pliki nag³ówkowe bibliotek Thunar
65 Group:          Development/Libraries
66 Requires:       %{name}-libs = %{version}-%{release}
67 Requires:       GConf2-devel >= 2.14.0
68 Requires:       dbus-glib-devel >= 0.62
69 Requires:       fam-devel
70 Requires:       hal-devel >= 0.5.7
71 Requires:       libexo-devel >= 0.3.1.10
72 Requires:       libjpeg-devel
73
74 %description devel
75 This is the package containing the header files for Thunar libraries.
76
77 %description devel -l pl
78 Ten pakiet zawiera pliki nag³ówkowe biblioteki Thunar.
79
80 %package static
81 Summary:        Static Thunar library
82 Summary(pl):    Statyczna biblioteka libraries
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static Thunar libraries.
88
89 %description static -l pl
90 Statyczna biblioteki Thunar
91
92 %prep
93 %setup -qn %{name}-%{version}%{_pre}
94
95 %build
96 %configure \
97         %{?with_static_libs:--enable-static}
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 rm -f $RPM_BUILD_ROOT%{_libdir}/thunarx-1/*.{a,la}
108
109 %find_lang %{name} --all-name
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 %update_icon_cache hicolor
116
117 %postun
118 %update_icon_cache hicolor
119
120 %post   libs -p /sbin/ldconfig
121 %postun libs -p /sbin/ldconfig
122
123 %files -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS README THANKS TODO
126 %attr(755,root,root) %{_bindir}/*
127 %dir %{_sysconfdir}/xdg/Thunar
128 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/Thunar/*.xml
129 %attr(755,root,root) %{_libdir}/ThunarBulkRename
130 %attr(755,root,root) %{_libdir}/ThunarHelp
131 %attr(755,root,root) %{_libdir}/thunar-vfs-*
132 %attr(755,root,root) %{_libdir}/thunar-sendto-email
133 %dir %{_libdir}/thunarx-1
134 %attr(755,root,root) %{_libdir}/thunarx-1/*.so
135 %attr(755,root,root) %{_libdir}/xfce4/panel-plugins/thunar-tpa
136
137 %{_datadir}/Thunar
138 %{_datadir}/xfce4/panel-plugins/*.desktop
139 %{_datadir}/dbus-1/services/*.service
140 %{_desktopdir}/*.desktop
141 %{_iconsdir}/hicolor/*/*/*
142 %{_pixmapsdir}/Thunar
143 %{_mandir}/man1/Thunar*
144
145 %dir %{_docdir}/Thunar
146 # move it to proper place
147 %{_docdir}/Thunar/README*
148
149 %dir %{_docdir}/Thunar/html
150 %{_docdir}/Thunar/*.txt
151 %{_docdir}/Thunar/html/C
152 %{_docdir}/Thunar/html/*.css
153 %lang(es) %{_docdir}/Thunar/html/es
154 %lang(fr) %{_docdir}/Thunar/html/fr
155 %lang(ja) %{_docdir}/Thunar/html/ja
156 %lang(ru) %{_docdir}/Thunar/html/ru
157 %lang(zh_TW) %{_docdir}/Thunar/html/zh_TW
158
159 %files libs
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/lib*.so.*.*
162
163 %files devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/lib*.so
166 %{_libdir}/lib*.la
167 %{_includedir}/thunar*
168 %{_pkgconfigdir}/*.pc
169
170 %if %{with static_libs}
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/*.a
174 %endif
This page took 0.051506 seconds and 4 git commands to generate.