]> git.pld-linux.org Git - packages/Thunar.git/blob - Thunar.spec
- up to 0.5.0rc2 (Xfce 4.4RC2)
[packages/Thunar.git] / Thunar.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         _pre            rc2
6 %define         xfce_version    4.3.99.2
7 Summary:        Xfce file manager
8 Summary(pl):    Zarz±dca plików Xfce
9 Name:           Thunar
10 Version:        0.5.0
11 Release:        0.%{_pre}.1
12 License:        GPL v2 / LGPL v2
13 Group:          X11/Applications
14 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/%{name}-%{version}%{_pre}.tar.bz2
15 # Source0-md5:  c97f6a011eb72b8653ad799290c71d52
16 URL:            http://thunar.xfce.org/
17 BuildRequires:  GConf2-devel >= 2.16.0
18 BuildRequires:  dbus-glib-devel >= 0.62
19 # XXX: gamin (>= 0.1.0) is preferred over fam
20 BuildRequires:  fam-devel
21 BuildRequires:  gettext-devel
22 BuildRequires:  glib2-devel >= 1:2.12.4
23 BuildRequires:  gtk+2-devel >= 2:2.10.6
24 BuildRequires:  hal-devel >= 0.5.7
25 BuildRequires:  intltool
26 BuildRequires:  libexif-devel >= 0.6.13
27 BuildRequires:  libexo-devel >= 0.3.1.12
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng-devel >= 1.2.12
30 BuildRequires:  libxfce4util-devel >= %{xfce_version}
31 BuildRequires:  pcre-devel >= 6.0
32 BuildRequires:  perl-base
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(macros) >= 1.311
35 BuildRequires:  startup-notification-devel >= 0.8
36 BuildRequires:  xfce4-panel-devel >= %{xfce_version}
37 Requires:       %{name}-libs = %{version}-%{release}
38 Requires(post,postun):  gtk+2 >= 2:2.10.6
39 Requires:       hal >= 0.5.7
40 Requires(post,postun):  hicolor-icon-theme
41 Requires:       libexo >= 0.3.1.12
42 Requires:       shared-mime-info >= 0.15
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Thunar is a modern file manager, aiming to be easy-to-use and fast.
47
48 %description -l pl
49 Thunar jest nowoczesnym zarz±dc± plików, nakierowanym na ³atwo¶æ i
50 szybko¶æ u¿ycia.
51
52 %package libs
53 Summary:        Thunar libraries
54 Summary(pl):    Biblioteki Thunar
55 Group:          Libraries
56
57 %description libs
58 Thunar libraries.
59
60 %description libs -l pl
61 Biblioteki Thunar.
62
63 %package devel
64 Summary:        Header files for Thunar libraries
65 Summary(pl):    Pliki nag³ówkowe bibliotek Thunar
66 Group:          Development/Libraries
67 Requires:       %{name}-libs = %{version}-%{release}
68 Requires:       GConf2-devel >= 2.16.0
69 Requires:       dbus-glib-devel >= 0.62
70 Requires:       fam-devel
71 Requires:       hal-devel >= 0.5.7
72 Requires:       libexo-devel >= 0.3.1.12
73 Requires:       libjpeg-devel
74
75 %description devel
76 This is the package containing the header files for Thunar libraries.
77
78 %description devel -l pl
79 Ten pakiet zawiera pliki nag³ówkowe biblioteki Thunar.
80
81 %package static
82 Summary:        Static Thunar libraries
83 Summary(pl):    Statyczne biblioteki Thunar
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 Static Thunar libraries.
89
90 %description static -l pl
91 Statyczne biblioteki Thunar.
92
93 %prep
94 %setup -qn %{name}-%{version}%{_pre}
95
96 %build
97 %configure \
98         --enable-dbus \
99         --enable-exif \
100         --enable-gnome-thumbnailers \
101         --enable-pcre \
102         --enable-startup-notification \
103         %{?with_static_libs:--enable-static}
104         
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 rm -f $RPM_BUILD_ROOT%{_libdir}/thunarx-1/*.{a,la}
114
115 %find_lang %{name} --all-name
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 %update_icon_cache hicolor
122
123 %postun
124 %update_icon_cache hicolor
125
126 %post   libs -p /sbin/ldconfig
127 %postun libs -p /sbin/ldconfig
128
129 %files -f %{name}.lang
130 %defattr(644,root,root,755)
131 %doc AUTHORS ChangeLog NEWS README THANKS TODO
132 %attr(755,root,root) %{_bindir}/*
133 %dir %{_sysconfdir}/xdg/Thunar
134 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/Thunar/*.xml
135 %attr(755,root,root) %{_libdir}/ThunarBulkRename
136 %attr(755,root,root) %{_libdir}/ThunarHelp
137 %attr(755,root,root) %{_libdir}/thunar-vfs-*
138 %attr(755,root,root) %{_libdir}/thunar-sendto-email
139 %dir %{_libdir}/thunarx-1
140 %attr(755,root,root) %{_libdir}/thunarx-1/*.so
141 %attr(755,root,root) %{_libdir}/xfce4/panel-plugins/thunar-tpa
142
143 %{_datadir}/Thunar
144 %{_datadir}/xfce4/panel-plugins/*.desktop
145 %{_datadir}/dbus-1/services/*.service
146 %{_desktopdir}/*.desktop
147 %{_iconsdir}/hicolor/*/*/*
148 %{_pixmapsdir}/Thunar
149 %{_mandir}/man1/Thunar*
150
151 %dir %{_docdir}/Thunar
152 # move it to proper place
153 %{_docdir}/Thunar/README*
154
155 %dir %{_docdir}/Thunar/html
156 %{_docdir}/Thunar/*.txt
157 %{_docdir}/Thunar/html/C
158 %{_docdir}/Thunar/html/*.css
159 %lang(es) %{_docdir}/Thunar/html/es
160 %lang(fr) %{_docdir}/Thunar/html/fr
161 %lang(ja) %{_docdir}/Thunar/html/ja
162 %lang(ru) %{_docdir}/Thunar/html/ru
163 %lang(zh_TW) %{_docdir}/Thunar/html/zh_TW
164
165 %files libs
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/lib*.so.*.*
168
169 %files devel
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/lib*.so
172 %{_libdir}/lib*.la
173 %{_includedir}/thunar*
174 %{_pkgconfigdir}/*.pc
175
176 %if %{with static_libs}
177 %files static
178 %defattr(644,root,root,755)
179 %{_libdir}/*.a
180 %endif
This page took 0.068949 seconds and 4 git commands to generate.