]> git.pld-linux.org Git - packages/Thunar.git/blob - Thunar.spec
- -devel R: {GConf2,dbus-glib,fam,hal,libjpeg}-devel
[packages/Thunar.git] / Thunar.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         _pre    beta1
6 Summary:        Xfce file manager
7 Summary(pl):    Zarz±dca plików Xfce
8 Name:           Thunar
9 Version:        0.3.0
10 Release:        0.%{_pre}.1
11 License:        GPL v2 / LGPL v2
12 Group:          Applications
13 Source0:        http://www.xfce.org/archive/xfce-4.3.90.1/src/%{name}-%{version}%{_pre}.tar.bz2
14 # Source0-md5:  e77437fa7b3a36f78b8db548f133ae6e
15 URL:            http://thunar.xfce.org/
16 BuildRequires:  GConf2-devel >= 2.4.0
17 BuildRequires:  dbus-glib-devel >= 0.34
18 # XXX: gamin (>= 0.1.0) is preferred over fam
19 BuildRequires:  fam-devel
20 BuildRequires:  gettext-devel
21 BuildRequires:  glib2-devel >= 1:2.6.4
22 BuildRequires:  gtk+2-devel >= 2:2.6.0
23 BuildRequires:  hal-devel >= 0.5.0
24 BuildRequires:  intltool
25 BuildRequires:  libexif-devel >= 0.6.0
26 BuildRequires:  libexo-devel >= 0.3.1.6
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel >= 1.2.0
29 BuildRequires:  libxfce4util-devel >= 4.2.2
30 BuildRequires:  pcre-devel >= 6.0
31 BuildRequires:  perl-base
32 BuildRequires:  pkgconfig
33 BuildRequires:  startup-notification-devel >= 0.8
34 Requires:       %{name}-libs = %{version}-%{release}
35 Requires:       hal >= 0.5.0
36 Requires:       hicolor-icon-theme
37 Requires:       shared-mime-info >= 0.15
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Thunar is a modern file manager, aiming to be easy-to-use and fast.
42
43 %description -l pl
44 Thunar jest nowoczesnym zarz±dc± plików, nakierowanym na ³atwo¶æ i
45 szybko¶æ u¿ycia.
46
47 %package libs
48 Summary:        Thunar libraries
49 Summary(pl):    Biblioteki Thunar
50 Group:          Libraries
51
52 %description libs
53 Thunar libraries.
54
55 %description libs -l pl
56 Biblioteki Thunar.
57
58 %package devel
59 Summary:        Header files for Thunar libraries
60 Summary(pl):    Pliki nag³ówkowe bibliotek Thunar
61 Group:          Development/Libraries
62 Requires:       %{name}-libs = %{version}-%{release}
63 Requires:       GConf2-devel >= 2.4.0
64 Requires:       dbus-glib-devel >= 0.34
65 Requires:       fam-devel
66 Requires:       hal-devel >= 0.5.0
67 Requires:       libjpeg-devel
68
69 %description devel
70 This is the package containing the header files for Thunar libraries.
71
72 %description devel -l pl
73 Ten pakiet zawiera pliki nag³ówkowe biblioteki Thunar.
74
75 %package static
76 Summary:        Static Thunar library
77 Summary(pl):    Statyczna biblioteka libraries
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Static Thunar libraries.
83
84 %description static -l pl
85 Statyczna biblioteki Thunar
86
87 %prep
88 %setup -qn %{name}-%{version}%{_pre}
89
90 %build
91 %configure \
92         %{?with_static_libs:--enable-static}
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 rm -f $RPM_BUILD_ROOT%{_libdir}/thunarx-1/*.{a,la}
103
104 %find_lang %{name} --all-name
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   libs -p /sbin/ldconfig
110 %postun libs -p /sbin/ldconfig
111
112 %files -f %{name}.lang
113 %defattr(644,root,root,755)
114 %doc AUTHORS ChangeLog NEWS README THANKS TODO
115 %attr(755,root,root) %{_bindir}/*
116 %dir %{_sysconfdir}/xdg/Thunar
117 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/Thunar/*.xml
118 %attr(755,root,root) %{_libdir}/ThunarBulkRename
119 %attr(755,root,root) %{_libdir}/ThunarHelp
120 %attr(755,root,root) %{_libdir}/thunar-vfs-mime-cleaner-1
121 %dir %{_libdir}/thunarx-1
122 %attr(755,root,root) %{_libdir}/thunarx-1/*.so
123
124 %{_datadir}/dbus-1/services/*.service
125 %{_desktopdir}/*.desktop
126 %{_iconsdir}/hicolor/*/*/*
127 %{_pixmapsdir}/Thunar
128
129 %dir %{_docdir}/Thunar
130 # move it to proper place
131 %{_docdir}/Thunar/README*
132
133 %dir %{_docdir}/Thunar/html
134 %{_docdir}/Thunar/html/C
135 %{_docdir}/Thunar/html/*.css
136 %lang(es) %{_docdir}/Thunar/html/es
137 %lang(fr) %{_docdir}/Thunar/html/fr
138 %lang(ja) %{_docdir}/Thunar/html/ja
139
140 %files libs
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/lib*.so.*.*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/lib*.so
147 %{_libdir}/lib*.la
148 %{_includedir}/thunar*
149 %{_pkgconfigdir}/*.pc
150
151 %if %{with static_libs}
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/*.a
155 %endif
This page took 0.042733 seconds and 4 git commands to generate.