]> git.pld-linux.org Git - packages/SDL2_mixer.git/blob - SDL2_mixer.spec
d5ff79435bd49358ee1225a3bf8789d1626da2f9
[packages/SDL2_mixer.git] / SDL2_mixer.spec
1 #
2 # Conditional build:
3 %bcond_with     mikmod  # mikmod use for MOD support (modplug is used by default)
4 %bcond_without  modplug # modplug use for MOD support
5 #
6 # NOTE: libraries dlopened by sonames detected at build time:
7 # libFLAC.so.8
8 # libfluidsynth.so.1
9 # libmikmod.so.2
10 # libmodplug.so.1
11 # libsmpeg-2.0.so.0
12 # libvorbisfile.so.3
13 #
14 Summary:        Simple DirectMedia Layer - Sample Mixer Library
15 Summary(pl.UTF-8):      Simple DirectMedia Layer - biblioteka miksująca próbki dźwiękowe
16 Summary(pt_BR.UTF-8):   SDL2 - Biblioteca para mixagem
17 Name:           SDL2_mixer
18 Version:        2.0.0
19 Release:        2
20 License:        Zlib-like
21 Group:          Libraries
22 Source0:        http://www.libsdl.org/projects/SDL_mixer/release/%{name}-%{version}.tar.gz
23 # Source0-md5:  65f6d80df073a1fb3bb537fbda031b50
24 Patch0:         %{name}-modplug.patch
25 URL:            http://www.libsdl.org/projects/SDL_mixer/
26 BuildRequires:  SDL2-devel >= 2.0.0
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  flac-devel >= 1.3.0
30 BuildRequires:  fluidsynth-devel
31 BuildRequires:  libtool >= 2:2.0
32 %{?with_mikmod:BuildRequires:   libmikmod-devel >= 3.1.10}
33 %{?with_modplug:BuildRequires:  libmodplug-devel >= 0.8.8}
34 BuildRequires:  libogg-devel
35 BuildRequires:  libvorbis-devel >= 1:1.0
36 BuildRequires:  pkgconfig >= 1:0.9.0
37 BuildRequires:  smpeg2-devel >= 2.0.0
38 Requires:       SDL2 >= 2.0.0
39 %{?with_mikmod:Suggests:        libmikmod >= 3.1.10}
40 %{?with_modplug:Suggests:       libmodplug >= 0.8.8}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Due to popular demand, here is a simple multi-channel audio mixer. It
45 supports 4 channels of 16 bit stereo audio, plus a single channel of
46 music, mixed by the popular MikMod MOD, Timidity MIDI and SMPEG MP3
47 libraries.
48
49 %description -l pl.UTF-8
50 SDL2_mixer to prosty wielokanałowy mikser audio. Obsługuje 4 kanały
51 16-bitowego dźwięku stereo plus jeden kanał dla muzyki miksowanej
52 przez popularne biblioteki MikMod MOD, Timitity MIDI i SMPEG MP3.
53
54 %description -l pt_BR.UTF-8
55 Biblioteca que suporta 4 canais de áudio estéreo 16 bit, mais um canal
56 de música, mixado pelo populares bibliotecas MOD MikMod, MIDI timidity
57 e SMPEG MP3.
58
59 %package devel
60 Summary:        Header files and more to develop SDL_mixer applications
61 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwoju aplikacji używających biblioteki SDL_mixer
62 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento de aplicações SDL
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       SDL2-devel >= 2.0.0
66
67 %description devel
68 Header files and more to develop SDL2_mixer applications.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe do rozwoju aplikacji używających biblioteki
72 SDL2_mixer.
73
74 %description devel -l pt_BR.UTF-8
75 Bibliotecas e arquivos de inclusão para desenvolvimento de aplicações
76 SDL2.
77
78 %package static
79 Summary:        Static SDL2_mixer library
80 Summary(pl.UTF-8):      Statyczna biblioteka SDL2_mixer
81 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com SDL2_mixer
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static SDL2_mixer library.
87
88 %description static -l pl.UTF-8
89 Statyczna biblioteka SDL2_mixer.
90
91 %description static -l pt_BR.UTF-8
92 Bibliotecas estáticas para desenvolvimento com SDL2_mixer.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97
98 %{__rm} acinclude/{libtool,lt*}.m4
99
100 %build
101 %{__libtoolize}
102 %{__aclocal} -I acinclude
103 %{__autoconf}
104 %configure \
105         %{?with_mikmod:--enable-music-mod-mikmod} \
106         %{!?with_modplug:--disable-music-mod-modplug}
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install install-bin \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 mv $RPM_BUILD_ROOT/%{_bindir}/playmus $RPM_BUILD_ROOT/%{_bindir}/playmus2
116 mv $RPM_BUILD_ROOT/%{_bindir}/playwave $RPM_BUILD_ROOT/%{_bindir}/playwave2
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc CHANGES.txt COPYING.txt README.txt
127 %attr(755,root,root) %{_bindir}/playmus2
128 %attr(755,root,root) %{_bindir}/playwave2
129 %attr(755,root,root) %{_libdir}/libSDL2_mixer-2.0.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libSDL2_mixer-2.0.so.0
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libSDL2_mixer.so
135 %{_libdir}/libSDL2_mixer.la
136 %{_includedir}/SDL2/SDL_mixer.h
137 %{_pkgconfigdir}/SDL2_mixer.pc
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libSDL2_mixer.a
This page took 0.048342 seconds and 2 git commands to generate.