]> git.pld-linux.org Git - packages/SDL2_mixer.git/blob - SDL2_mixer.spec
42ac185d6c646dbfffec03ffebc304bd7ffd0090
[packages/SDL2_mixer.git] / SDL2_mixer.spec
1 #
2 # Conditional build:
3 %bcond_without  libxmp          # libxmp use for MOD support
4 %bcond_with     modplug         # modplug use for MOD support (libxmp is used by default)
5 %bcond_without  mpg123          # libmpg123 use for MP3 support
6 %bcond_without  static_libs     # static library
7 #
8 # NOTE: libraries dlopened by sonames detected at build time:
9 # libFLAC.so.8
10 # libfluidsynth.so.1
11 # libgme.so.0
12 # libmodplug.so.1
13 # libmpg123.so.0
14 # libopusfile.so.0
15 # libvorbisfile.so.3
16 # libwavpack.so.1
17 # libxmp.so.4
18 #
19 Summary:        Simple DirectMedia Layer - Sample Mixer Library
20 Summary(pl.UTF-8):      Simple DirectMedia Layer - biblioteka miksująca próbki dźwiękowe
21 Summary(pt_BR.UTF-8):   SDL2 - Biblioteca para mixagem
22 Name:           SDL2_mixer
23 Version:        2.8.0
24 Release:        1
25 License:        Zlib-like
26 Group:          Libraries
27 Source0:        https://github.com/libsdl-org/SDL_mixer/releases/download/release-%{version}/%{name}-%{version}.tar.gz
28 # Source0-md5:  6c4b2936784856c575b838a5731a23d1
29 URL:            https://github.com/libsdl-org/SDL_mixer
30 BuildRequires:  SDL2-devel >= 2.0.9
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  flac-devel >= 1.3.0
34 BuildRequires:  fluidsynth-devel
35 BuildRequires:  game-music-emu-devel
36 BuildRequires:  libtool >= 2:2.0
37 %{?with_modplug:BuildRequires:  libmodplug-devel >= 0.8.8}
38 %{?with_mpg123:BuildRequires:   libmpg123-devel}
39 BuildRequires:  libogg-devel
40 BuildRequires:  libvorbis-devel >= 1:1.0
41 %{?with_libxmp:BuildRequires:   libxmp-devel >= 4.2}
42 BuildRequires:  opusfile-devel >= 0.2
43 BuildRequires:  pkgconfig >= 1:0.9.0
44 BuildRequires:  rpmbuild(macros) >= 1.527
45 BuildRequires:  wavpack-devel >= 4.0
46 Requires:       SDL2 >= 2.0.9
47 %{?with_libxmp:Suggests:        libxmp >= 4.2}
48 %{?with_modplug:Suggests:       libmodplug >= 0.8.8}
49 Suggests:       opusfile >= 0.2
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Due to popular demand, here is a simple multi-channel audio mixer. It
54 supports 4 channels of 16 bit stereo audio, plus a single channel of
55 music, mixed by the popular MikMod MOD, Timidity MIDI and MPG123 MP3
56 libraries.
57
58 %description -l pl.UTF-8
59 SDL2_mixer to prosty wielokanałowy mikser audio. Obsługuje 4 kanały
60 16-bitowego dźwięku stereo plus jeden kanał dla muzyki miksowanej
61 przez popularne biblioteki MikMod MOD, Timitity MIDI i MPG123 MP3.
62
63 %description -l pt_BR.UTF-8
64 Biblioteca que suporta 4 canais de áudio estéreo 16 bit, mais um canal
65 de música, mixado pelo populares bibliotecas MOD MikMod, MIDI timidity
66 e MPG123 MP3.
67
68 %package devel
69 Summary:        Header files and more to develop SDL_mixer applications
70 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwoju aplikacji używających biblioteki SDL_mixer
71 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento de aplicações SDL
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       SDL2-devel >= 2.0.9
75
76 %description devel
77 Header files and more to develop SDL2_mixer applications.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe do rozwoju aplikacji używających biblioteki
81 SDL2_mixer.
82
83 %description devel -l pt_BR.UTF-8
84 Bibliotecas e arquivos de inclusão para desenvolvimento de aplicações
85 SDL2.
86
87 %package static
88 Summary:        Static SDL2_mixer library
89 Summary(pl.UTF-8):      Statyczna biblioteka SDL2_mixer
90 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com SDL2_mixer
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 Static SDL2_mixer library.
96
97 %description static -l pl.UTF-8
98 Statyczna biblioteka SDL2_mixer.
99
100 %description static -l pt_BR.UTF-8
101 Bibliotecas estáticas para desenvolvimento com SDL2_mixer.
102
103 %prep
104 %setup -q
105
106 %{__rm} acinclude/{libtool,lt*}.m4
107
108 %build
109 %{__libtoolize}
110 %{__aclocal} -I acinclude
111 %{__autoconf}
112 %configure \
113         %{__enable_disable static_libs static} \
114         --disable-music-flac-drflac \
115         --disable-music-mp3-minimp3 \
116         --disable-music-ogg-stb \
117         --enable-music-flac-libflac \
118         --enable-music-ogg-vorbis \
119         %{!?with_libxmp:--disable-music-mod-xmp} \
120         %{?with_modplug:--enable-music-mod-modplug} \
121         %{?with_mpg123:--enable-music-mp3-mpg123}
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install install-bin \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %{__mv} $RPM_BUILD_ROOT%{_bindir}/playmus $RPM_BUILD_ROOT%{_bindir}/playmus2
131 %{__mv} $RPM_BUILD_ROOT%{_bindir}/playwave $RPM_BUILD_ROOT%{_bindir}/playwave2
132
133 # obsoleted by pkg-config
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libSDL2_mixer.la
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc CHANGES.txt LICENSE.txt README.txt
145 %attr(755,root,root) %{_bindir}/playmus2
146 %attr(755,root,root) %{_bindir}/playwave2
147 %attr(755,root,root) %{_libdir}/libSDL2_mixer-2.0.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libSDL2_mixer-2.0.so.0
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libSDL2_mixer.so
153 %{_libdir}/cmake/SDL2_mixer
154 %{_includedir}/SDL2/SDL_mixer.h
155 %{_pkgconfigdir}/SDL2_mixer.pc
156
157 %if %{with static_libs}
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/libSDL2_mixer.a
161 %endif
This page took 0.093862 seconds and 3 git commands to generate.