]> git.pld-linux.org Git - packages/Razor.git/blob - Razor.spec
- bcond style, changelog cleanups
[packages/Razor.git] / Razor.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Collection of files for checking, reporting, and revoking spam
7 Summary(pl):    Zbiór plików do sprawdzania, raportowania i odrzucania spamu
8 Name:           Razor
9 Version:        2.36
10 Release:        4
11 License:        Artistic
12 Group:          Applications/Mail
13 Source0:        http://dl.sourceforge.net/sourceforge/razor/razor-agents-%{version}.tar.gz
14 # Source0-md5:  5deaae3ea2300bf480b6904f8a69a7f1
15 Patch0: %{name}2.patch-quinlan
16 URL:            http://razor.sourceforge.net/
17 BuildRequires:  perl-devel >= 5.8.0
18 %if %{with autodeps}
19 BuildRequires:  perl-Net-DNS
20 BuildRequires:  perl-Class-Fields
21 BuildRequires:  perl-Digest-Nilsimsa
22 BuildRequires:  perl-Digest-SHA1
23 BuildRequires:  perl-Time-HiRes
24 BuildRequires:  perl-URI
25 %endif
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 Requires:       perl-Razor = %{version}
28 BuildArch:      noarch
29 Obsoletes:      perl-Vipuls-Razor-V1
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Vipul's Razor is a distributed, collaborative, spam detection, reporting,
34 and filtering network.  The primary focus of the system is to identify
35 and remove all email spam from the internet.  Visit the website at
36 <http://razor.sourceforge.net/>.
37
38 %description -l pl
39 Vipul's Razor jest dystrybuowaln±, tworzon± dziêki wspó³pracy sieci±,
40 s³u¿±c± do wykrywania spamu, raportowania i filtrowania.  Podstawowym
41 zadaniem systemu jest identyfikacja spamu z poczty internetowej.
42 Odwied¼ stronê domow±: <http://razor.sourceforge.net/>.
43
44 %package -n perl-Razor
45 Summary:        Perl modules for Razor
46 Summary(pl):    Modu³y Perla dla Razora
47 Group:          Development/Languages/Perl
48
49 %description -n perl-Razor
50 Perl modules for Razor, class Razor2::.
51
52 %description -n perl-Razor -l pl
53 Modu³y Perla dla Razora, klasa Razor2::.
54
55 %prep
56 %setup -q -n razor-agents-%{version}
57 cd lib/Razor2
58 %patch0 -p0
59 cd -
60
61 %build
62 %{__perl} Makefile.PL \
63         INSTALLDIRS=vendor
64
65 %{__make}
66
67 #%%{__make} test
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT \
74         PERL5LIB=$RPM_BUILD_ROOT/usr/lib/perl5/vendor_perl/5.8.0/i686-pld-linux-thread-multi
75
76 for f in check register report revoke; do
77         ln -sf razor-client $RPM_BUILD_ROOT%{_bindir}/razor-$f
78 done
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc Change* BUGS README INSTALL CREDITS
86 %attr(755,root,root) %{_bindir}/*
87 %{_mandir}/man[15]/*
88
89 %files -n perl-Razor
90 %defattr(644,root,root,755)
91 %{perl_vendorarch}/Razor2
92 %{perl_vendorarch}/auto/Razor2
93 %{_mandir}/man3/*
This page took 0.065682 seconds and 4 git commands to generate.