]> git.pld-linux.org Git - packages/LPRng.git/blob - LPRng.spec
- typo in %%install
[packages/LPRng.git] / LPRng.spec
1 Summary:        A next-generation printing system for UNIX
2 Summary(pl):    System drukowania nowej generacji
3 Name:           LPRng
4 Version:        3.7.5
5 Release:        1
6 License:        GPL
7 Group:          Applications/System
8 Group(de):      Applikationen/System
9 Group(pl):      Aplikacje/System
10 Source0:        ftp://ftp.astart.com/pub/LPRng/LPRng/%{name}-%{version}.tgz
11 Source1:        %{name}.init
12 Source2:        %{name}.conf
13 Patch0:         %{name}-jobfilescan.patch
14 Patch1:         %{name}-ac_fixes.patch
15 Patch2:         %{name}-inet_ntop.patch
16 Patch3:         %{name}-direct.patch
17 Patch4:         %{name}-manpage.patch
18 Patch5:         %{name}-shutdown.patch
19 Patch6:         %{name}-lockfile.patch
20 Patch7:         %{name}-setgroups.patch
21 URL:            http://www.astart.com/lprng/LPRng.html
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  gettext-devel
25 BuildRequires:  ncurses-devel >= 5.0
26 Prereq:         /sbin/chkconfig
27 Prereq:         rc-scripts >= 0.2.0
28 Provides:       lpr
29 Obsoletes:      lpr
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32
33 %description
34 The LPRng software is an enhanced, extended, and portable
35 implementation of the Berkeley LPR print spooler functionality. While
36 providing the same interface and meeting RFC1179 requirements, the
37 implementation is completely new and provides support for the
38 following features: lightweight (no databases needed) lpr, lpc, and
39 lprm programs; dynamic redirection of print queues; automatic job
40 holding; highly verbose diagnostics; multiple printers serving a
41 single queue; client programs do not need to run SUID root; greatly
42 enhanced security checks; and a greatly improved permission and
43 authorization mechanism.
44
45 The source software compiles and runs on a wide variety of UNIX
46 systems, and is compatible with other print spoolers and network
47 printers that use the LPR interface and meet RFC1179 requirements.
48 LPRng provides emulation packages for the SVR4 lp and lpstat programs,
49 eliminating the need for another print spooler package. These
50 emulation packages can be modified according to local requirements, in
51 order to support vintage printing systems.
52
53 For users that require secure and/or authenticated printing support,
54 LPRng supports Kerberos V, MIT Kerberos IV Print Support, and PGP
55 authentication. LPRng is being adopted by MIT for use as their Campus
56 Wide printing support system. Additional authentication support is
57 extremely simple to add. LPRng is Open Source Software, and the
58 current public distribution is available from the listed FTP and Web
59 Sites.
60
61 %description -l pl
62 LPRng jest systemem drukowania nowej generacji zwiêkszaj±cym
63 niezawodno¶æ i bezpieczeñstwo.
64
65 %prep
66 %setup  -q
67 %patch0 -p1
68 %patch1 -p1
69 %patch2 -p1
70 %patch3 -p1
71 %patch4 -p1
72 %patch5 -p1
73 %patch6 -p1
74 %patch7 -p1
75
76 %build
77 rm -f missing
78 gettextize --copy --force
79 aclocal
80 autoconf
81 (cd gdbm-1.8.0 ; aclocal ; autoconf )
82 %configure \
83         --disable-setuid \
84         --with-userid=lp \
85         --with-groupid=lp \
86         --with-filterdir=%{_libdir}/lpfilters \
87         --with-lockfile=%{_var}/spool/lpd/lpd
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d  $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_var}/spool/lpd}
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/lpd
99 # yes, overwrite distribution lpd.conf
100 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lpd.conf
101 echo "default_printer = lp" >>$RPM_BUILD_ROOT%{_sysconfdir}/lpd.conf
102 install printcap $RPM_BUILD_ROOT%{_sysconfdir}/printcap
103 install lpd.perms $RPM_BUILD_ROOT%{_sysconfdir}/
104 # default spool
105 install -d $RPM_BUILD_ROOT%{_var}/spool/lpd/lp
106
107 rm -fr TESTSUPPORT/{Makefile*,LPD}
108 mv -f lpd.conf TESTSUPPORT/lpd.conf.distrib
109
110 gzip -9nf CHANGES CONTRIBUTORS README* TESTSUPPORT/*
111
112 %find_lang %{name}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post
118 /sbin/chkconfig --add lpd
119 if [ -f /var/lock/subsys/lpd ]; then
120         /etc/rc.d/init.d/lpd restart 1>&2
121 else
122         echo "Run \"/etc/rc.d/init.d/lpd start\" to start LPRng lpd daemon."
123 fi
124
125 %preun
126 if [ "$1" = "0" ]; then
127         if [ -f /var/lock/subsys/lpd ]; then
128                 /etc/rc.d/init.d/lpd stop 1>&2
129         fi
130         /sbin/chkconfig --del lpd
131 fi
132
133 %files -f %{name}.lang
134 %defattr(644,root,root,755)
135 %doc *.gz TESTSUPPORT HOWTO/LPRng-HOWTO.html HOWTO/CHANGES
136 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/lpd.conf
137 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/lpd.perms
138 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/printcap
139 %attr(754,root,root) /etc/rc.d/init.d/lpd
140 %attr(755,root,root) %{_bindir}/*
141 %attr(755,root,root) %{_sbindir}/*
142 %dir %{_libdir}/lpfilters
143 %attr(755,root,root) %{_libdir}/lpfilters/*
144 %dir %attr(750,root,lp) %{_var}/spool/lpd
145 %dir %attr(770,root,lp) %{_var}/spool/lpd/lp
146 %{_mandir}/man[158]/*
This page took 0.059687 seconds and 4 git commands to generate.