]> git.pld-linux.org Git - packages/DirectFB.git/blob - DirectFB.spec
- 0.9.16, flash video provider is gone (to DirectFB-extra)
[packages/DirectFB.git] / DirectFB.spec
1 #
2 # Conditional build:
3 # _without_mpg          - don't build support for MPG/MPEG3
4 #
5 Summary:        DirectFB - Hardware graphics acceleration
6 Summary(pl):    DirectFB - Wspomaganie grafiki
7 Name:           DirectFB
8 Version:        0.9.16
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://www.directfb.org/download/%{name}/%{name}-%{version}.tar.gz
13 Source1:        http://www.directfb.org/download/DirectFB/DFBTutorials-0.5.0.tar.gz
14 Patch0:         %{name}-am.patch
15 URL:            http://www.directfb.org/
16 #BuildRequires: SDL-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  freetype-devel >= 2.0.2
20 BuildRequires:  libjpeg-devel >= 6b
21 %{!?_without_mpg:BuildRequires: libmpeg3-devel}
22 BuildRequires:  libpng-devel >= 1.0
23 BuildRequires:  libtool
24 BuildRequires:  zlib-devel >= 1.1.3
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         dfbdir  %{_libdir}/directfb-%{version}
28
29 %description
30 DirectFB hardware graphics acceleration - libraries.
31
32 %description -l pl
33 Wspomaganie grafiki DirectFB - biblioteki.
34
35 %package devel
36 Summary:        DirectFB - development package
37 Summary(pl):    DirectFB - pliki nag³ówkowe
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}
40
41 %description devel
42 DirectFB header files.
43
44 %description devel -l pl
45 Pliki nag³ówkowe dla DirectFB.
46
47 %package static
48 Summary:        DirectFB static libraries
49 Summary(pl):    Statyczne biblioteki DirectFB
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}
52
53 %description static
54 DirectFB static libraries.
55
56 %description static -l pl
57 Statyczne biblioteki DirectFB.
58
59 %package doc
60 Summary:        DirectFB - documentation
61 Summary(pl):    DirectFB - dokumentacja
62 Group:          Development/Libraries
63
64 %description doc
65 DirectFB documentation and tutorials.
66
67 %description doc -l pl
68 Dokumentacja dla systemu DirectFB wraz z wprowadzeniem.
69
70 %package font-ft2
71 Summary:        FreeType2 font provider for DirectFB
72 Summary(pl):    DirectFB - wtyczka dostarczaj±ca fonty poprzez FreeType2
73 Group:          Libraries
74 Requires:       %{name} = %{version}
75
76 %description font-ft2
77 This package contains FreeType2 font provider for DirectFB.
78
79 %description font-ft2 -l pl
80 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± fonty poprzez
81 bibliotekê FreeType2.
82
83 %package image-jpeg
84 Summary:        JPEG image provider for DirectFB
85 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê JPEG
86 Group:          Libraries
87 Requires:       %{name} = %{version}
88
89 %description image-jpeg
90 This package contains JPEG image provider for DirectFB.
91
92 %description image-jpeg -l pl
93 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê JPEG.
94
95 %package image-png
96 Summary:        PNG image provider for DirectFB
97 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê PNG
98 Group:          Libraries
99 Requires:       %{name} = %{version}
100
101 %description image-png
102 This package contains PNG image provider for DirectFB.
103
104 %description image-png -l pl
105 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê PNG.
106
107 %package video-libmpeg3
108 Summary:        MPEG video provider for DirectFB
109 Summary(pl):    DirectFB - wtyczka dostarczaj±ca obraz MPEG
110 Group:          Libraries
111 Requires:       %{name} = %{version}
112
113 %description video-libmpeg3
114 This package contains MPEG (MPEG-1 and MPEG-2) video provider for
115 DirectFB. It uses libmpeg3 library.
116
117 %description video-libmpeg3 -l pl
118 Ten pakiet zawiera wtyczkê dla DirectFB dostarczajac± obraz MPEG
119 (MPEG-1 i MPEG-2) przy u¿yciu biblioteki libmpeg3. 
120
121 %prep
122 %setup -q -a1
123 %patch0 -p1
124
125 %build
126 rm -f missing
127 %{__libtoolize}
128 %{__aclocal}
129 %{__autoconf}
130 %{__automake}
131 CPPFLAGS="-I/usr/include/libmpeg3"
132 # SDL core disabled (used directly, not through plugin - too many deps)
133 # MMX and SSE are detected at runtime, so it's safe to enable
134 %configure \
135         --disable-maintainer-mode \
136         --enable-shared \
137         --enable-static \
138         --disable-fast-install \
139         --disable-debug \
140         %{?_without_mpg:--disable-libmpeg3} \
141         --disable-sdl \
142 %ifarch i586 i686 athlon
143         --enable-mmx \
144 %endif
145 %ifarch i686 athlon
146         --enable-sse
147 %endif
148
149 %{__make}
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153 %{__make} DESTDIR=$RPM_BUILD_ROOT install
154
155 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
156 cp -rf DFBTutorials* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post   -p /sbin/ldconfig
162 %postun -p /sbin/ldconfig
163
164 %files
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/lib*.so.*.*
167 %dir %{dfbdir}
168 %dir %{dfbdir}/gfxdrivers
169 %attr(755,root,root) %{dfbdir}/gfxdrivers/*.so
170 %{dfbdir}/gfxdrivers/*.la
171 %dir %{dfbdir}/inputdrivers
172 %attr(755,root,root) %{dfbdir}/inputdrivers/*.so
173 %{dfbdir}/inputdrivers/*.la
174 %dir %{dfbdir}/interfaces
175 %dir %{dfbdir}/interfaces/IDirectFBFont
176 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_default.so
177 %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_default.la
178 %dir %{dfbdir}/interfaces/IDirectFBImageProvider
179 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.so
180 %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.la
181 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.so
182 %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.la
183 %dir %{dfbdir}/interfaces/IDirectFBVideoProvider
184 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.so
185 %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.la
186 %{_datadir}/directfb-%{version}
187 %{_mandir}/man5/*
188
189 %files devel
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/directfb-config
192 %attr(755,root,root) %{_bindir}/directfb-csource
193 %attr(755,root,root) %{_libdir}/*.so
194 %{_libdir}/*.la
195 %{_includedir}/directfb
196 %{_includedir}/directfb-internal
197 %{_pkgconfigdir}/*
198 %{_mandir}/man1/directfb-csource.1*
199
200 %files static
201 %defattr(644,root,root,755)
202 %{_libdir}/lib*.a
203 %{dfbdir}/gfxdrivers/*.a
204 %{dfbdir}/inputdrivers/*.a
205 %{dfbdir}/interfaces/*/*.a
206
207 %files doc
208 %defattr(644,root,root,755)
209 %doc docs/html/*
210 %{_examplesdir}/%{name}-%{version}
211
212 %files font-ft2
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_ft2.so
215 %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_ft2.la
216
217 %files image-jpeg
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.so
220 %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.la
221
222 %files image-png
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.so
225 %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.la
226
227 %if 0%{!?_without_mpg:1}
228 %files video-libmpeg3
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_libmpeg3.so
231 %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_libmpeg3.la
232 %endif
This page took 0.037604 seconds and 3 git commands to generate.