]> git.pld-linux.org Git - packages/ClanLib.git/blob - ClanLib.spec
- adapterized.
[packages/ClanLib.git] / ClanLib.spec
1 Summary:        ClanLib, the platform independent game SDK
2 Summary(pl):    ClanLib, niezale¿ny od platformy SDK do gier
3 Summary(pt_BR): SDK Clanlib
4 Name:           ClanLib
5 Version:        0.5.1
6 Release:        3
7 License:        LGPL
8 Group:          Libraries
9 Source0:        http://dark.x.dtu.dk/~mbn/clanlib/download/download-japj/%{name}-%{version}/%{name}-%{version}-1.tar.gz
10 Patch0:         %{name}-OPT.patch
11 URL:            http://www.clanlib.org/
12 Requires:       Hermes >= 1.3.1
13 #OpenGL is disabled in ClanLib 0.5.0 so we disable this requirement
14 #Requires:      OpenGL
15 BuildRequires:  Hermes-devel >= 1.3.1
16 BuildRequires:  XFree86-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  freetype-devel >= 2.0
20 #BuildRequires: OpenGL-devel
21 BuildRequires:  libmikmod-devel
22 BuildRequires:  libpng-devel >= 1.0.8
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libvorbis-devel
25 BuildRequires:  perl
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
29
30 %description
31 The ClanLib SDK is designed to provide an platform independent game
32 SDK using a lot cleaner (and object oriented) interface than the
33 traditional way it is done in DirectX, SDL and such. The goals is to
34 avoid game developers constantly reinventing the wheel by providing
35 smarter ways to eg. load surfaces.
36
37 %description -l pl
38 ClanLib SDK jest projektowany jako niezale¿ny od platformy SDK dla
39 gier. Stosuje prosty (i zorientowany obiektowo) interfejs,
40 przejrzystszy ni¿ DirectX, SDL i inne.
41
42 %description -l pt_BR
43 A Clanlib é uma biblioteca de jogos multi-plataforma desenhada para
44 facilitar o trabalho dos desenvolvedores. A idéia principal é fornecer
45 uma interface comum para os problemas clássicos dos jogos (carregar
46 gráficos por exemplo).
47
48 %package devel
49 Summary:        ClanLib development package
50 Summary(pl):    pakiet programistyczny dla ClanLib
51 Summary(pt_BR): Arquivos para desenvolvimento usando a Clanlib
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}
54 #Requires:      %{name}-OpenGL = %{version}
55 Requires:       %{name}-MikMod = %{version}
56 Requires:       %{name}-TTF = %{version}
57 Requires:       %{name}-Vorbis = %{version}
58 Requires:       Hermes-devel
59
60 %description devel
61 This is the development add-on package that includes the header files
62 needed to compile new ClanLib applications.
63
64 %description devel -l pl
65 Programistyczne dodatki do ClanLib-a, zawieraj± pliki nag³ówkowe
66 potrzebne do kompilacji programów korzystaj±cych z ClanLib.
67
68 %description devel -l pt_BR
69 Arquivos que possibilitam o desenvolvimento de aplicativos utilizando
70 a biblioteca Clanlib.
71
72 %package svgalib
73 Summary:        svgalib target for ClanLib
74 Summary(pl):    obs³uga svgalib dla ClanLib
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}
77
78 %description svgalib
79 This is the svgalib target for ClanLib.
80
81 %description svgalib -l pl
82 Obs³uga svgalib dla ClanLib-a.
83
84 %package OpenGL
85 Summary:        OpenGL target for ClanLib
86 Summary(pl):    obs³uga OpenGL dla ClanLib
87 Group:          Development/Libraries
88 Requires:       %{name} = %{version}
89
90 %description OpenGL
91 This is the OpenGL target for ClanLib.
92
93 %description OpenGL -l pl
94 Obs³uga OpenGL dla ClanLib-a.
95
96 %package GGI
97 Summary:        GGI target for ClanLib
98 Summary(pl):    obs³uga GGI dla ClanLib
99 Group:          Development/Libraries
100 Requires:       %{name} = %{version}
101
102 %description GGI
103 This is the GGI target for ClanLib.
104
105 %description GGI -l pl
106 Obs³uga OpenGL dla ClanLib-a.
107
108 %package MikMod
109 Summary:        MikMod module for ClanLib
110 Summary(pl):    Modu³ Mikmod dla ClanLib
111 Group:          Development/Libraries
112 Requires:       %{name} = %{version}
113
114 %description MikMod
115 MikMod module for ClanLib.
116
117 %description MikMod -l pl
118 Modu³ Mikmod dla ClanLib-a.
119
120 %package Vorbis
121 Summary:        Vorbis module for ClanLib
122 Summary(pl):    Modu³ Vorbis dla ClanLib
123 Group:          Development/Libraries
124 Requires:       %{name} = %{version}
125
126 %description Vorbis
127 Vorbis module for ClanLib.
128
129 %description Vorbis -l pl
130 Modu³ Vorbis dla ClanLib-a.
131
132 %package TTF
133 Summary:        TTF module for ClanLib
134 Summary(pl):    Modu³ TTF dla ClanLib
135 Group:          Development/Libraries
136 Requires:       %{name} = %{version}
137
138 %description TTF
139 TTF module for ClanLib.
140
141 %description TTF -l pl
142 Modu³ TTF dla ClanLib-a.
143
144 %package static
145 Summary:        ClanLib development package
146 Summary(pl):    pakiet programistyczny dla ClanLib
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}
149
150 %description static
151 This is the development add-on package that includes the header files
152 needed to compile new ClanLib applications.
153
154 %description static -l pl
155 Programistyczne dodatki do ClanLib-a, zawieraj± pliki nag³ówkowe
156 potrzebne do kompilacji programów korzystaj±cych z ClanLib.
157
158 %prep
159 %setup -q
160 #%patch0 -p1
161
162 %build
163 # note: rtti is needed --- ClanLib uses exceptions!
164 aclocal
165 autoconf
166 %configure \
167         --enable-static \
168         --enable-shared \
169         %{?debug:--enable-debug}%{!?debug:--disable-debug} \
170         --disable-debug \
171         --enable-x11 \
172         --enable-fbdev \
173         --enable-vidmode \
174         --enable-clansound \
175         --enable-network \
176 %ifarch %{ix86}
177         --enable-asm386 \
178 %endif
179         --enable-dyn \
180         --enable-gui \
181         --enable-vorbis \
182         --enable-mikmod \
183         --enable-png \
184         --enable-jpeg \
185         --enable-smalljpeg \
186         --enable-ttf \
187         --disable-lua   # broken
188
189 # not functional right now
190 #       --enable-opengl \
191 #       --enable-mpeg
192
193
194 %{__make}
195 %{__make} docs
196
197 %install
198 rm -rf $RPM_BUILD_ROOT
199 %{__make} install \
200         LIB_PREFIX="$RPM_BUILD_ROOT%{_libdir}" \
201         TARGET_PREFIX="$RPM_BUILD_ROOT%{_libdir}/ClanLib" \
202         BIN_PREFIX="$RPM_BUILD_ROOT%{_bindir}" \
203         INC_PREFIX="$RPM_BUILD_ROOT%{_includedir}"
204
205 %{__make} docs_install \
206         MAN_PREFIX="$RPM_BUILD_ROOT%{_mandir}" \
207         HTML_PREFIX="`pwd`/html"
208
209 gzip -9nf README CREDITS
210
211 %post   -p /sbin/ldconfig
212 %postun -p /sbin/ldconfig
213
214 %post   OpenGL -p /sbin/ldconfig
215 %postun OpenGL -p /sbin/ldconfig
216
217 %post   MikMod -p /sbin/ldconfig
218 %postun MikMod -p /sbin/ldconfig
219
220 %post   TTF -p /sbin/ldconfig
221 %postun TTF -p /sbin/ldconfig
222
223 %post   Vorbis -p /sbin/ldconfig
224 %postun Vorbis -p /sbin/ldconfig
225
226 %clean
227 rm -rf $RPM_BUILD_ROOT
228
229 %files
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_libdir}/libclanApp.so.*.*
232 %attr(755,root,root) %{_libdir}/libclanCore.so.*.*
233 %attr(755,root,root) %{_libdir}/libclanDisplay.so.*.*
234 %attr(755,root,root) %{_libdir}/libclanGUI.so.*.*
235 %attr(755,root,root) %{_libdir}/libclan*JPEG.so.*.*
236 %attr(755,root,root) %{_libdir}/libclanNetwork.so.*.*
237 #%attr(755,root,root) %{_libdir}/libclanMPEG.so.*.*
238 %attr(755,root,root) %{_libdir}/libclanPNG.so.*.*
239 %attr(755,root,root) %{_libdir}/libclanSound.so.*.*
240
241 #%files OpenGL
242 #%defattr(644,root,root,755)
243 #%attr(755,root,root) %{_libdir}/libclanGL.so.*.*
244 #%attr(755,root,root) %{_libdir}/ClanLib/libclan-display-glx.so*
245
246 %files MikMod
247 %defattr(644,root,root,755)
248 %attr(755,root,root) %{_libdir}/libclanMikMod.so.*.*
249
250 %files Vorbis
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{_libdir}/libclanVorbis.so.*.*
253
254 %files TTF
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{_libdir}/libclanTTF.so.*.*
257
258 %files devel
259 %defattr(644,root,root,755)
260 %doc *gz
261 %doc html
262 %attr(755,root,root) %{_libdir}/*.so
263 %attr(755,root,root) %{_bindir}/*
264 %{_includedir}/ClanLib
265
266 %files static
267 %defattr(644,root,root,755)
268 #%{_libdir}/lib*.a
This page took 0.134983 seconds and 4 git commands to generate.