]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
- fix install on x32
[packages/CEGUI.git] / CEGUI.spec
1 #
2 # Conditional build:
3 %bcond_without  xercesc         # build XercesParser
4 %bcond_without  ogre            # build without Ogre renderer
5 %bcond_without  opengl          # build without OpenGL renderer
6 %bcond_with     directb         # unsupported by upstream
7 %bcond_with     samples         # build samples
8 #
9 Summary:        CEGUI - a free library providing windowing and widgets
10 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
11 Name:           CEGUI
12 Version:        0.8.4
13 Release:        3
14 License:        LGPL v2.1+ (with MIT parts)
15 Group:          Libraries
16 Source0:        http://downloads.sourceforge.net/crayzedsgui/cegui-%{version}.tar.bz2
17 # Source0-md5:  344917301b5ed867a07575ee6a828667
18 Source1:        http://downloads.sourceforge.net/crayzedsgui/cegui-docs-%{version}.tar.bz2
19 # Source1-md5:  1096bf8c84bf6a22e8892ab9258c22f6
20 Patch0:         pthread.patch
21 Patch1:         %{name}-glfw3.patch
22 Patch2:         %{name}-python.patch
23 Patch3:         x32.patch
24 URL:            http://www.cegui.org.uk/
25 BuildRequires:  DevIL-devel
26 %{?with_directfb:BuildRequires: DirectFB-devel >= 1.2.0}
27 BuildRequires:  FreeImage-devel
28 BuildRequires:  GLM
29 BuildRequires:  OpenGL-devel
30 BuildRequires:  SILLY-devel >= 0.1.0
31 BuildRequires:  boost-devel >= 1.36.0
32 BuildRequires:  boost-python-devel >= 1.36.0
33 BuildRequires:  cmake >= 2.8
34 BuildRequires:  corona-devel
35 BuildRequires:  doxygen
36 BuildRequires:  expat-devel
37 BuildRequires:  fribidi-devel
38 BuildRequires:  freetype-devel >= 2.0
39 BuildRequires:  glew-devel
40 # for SampleFramework
41 BuildRequires:  glfw-devel
42 BuildRequires:  gtk+2-devel >= 2:2.4
43 BuildRequires:  irrlicht-devel >= 1.4
44 BuildRequires:  libstdc++-devel
45 BuildRequires:  libtool >= 2:1.5
46 BuildRequires:  libxml2-devel >= 1:2.6
47 BuildRequires:  lua51-devel >= 5.1
48 BuildRequires:  minizip-devel
49 %if %{with ogre}
50 BuildRequires:  ogre-devel >= 1.6.0
51 BuildRequires:  ois-devel >= 1.0.0
52 %endif
53 BuildRequires:  pcre-devel >= 5.0
54 BuildRequires:  pkgconfig
55 BuildRequires:  python-devel >= 2
56 BuildRequires:  rapidxml
57 BuildRequires:  sed >= 4.0
58 BuildRequires:  tinyxml-devel
59 BuildRequires:  tolua++-devel
60 %{?with_xercesc:BuildRequires:  xerces-c-devel}
61 # for irrlicht renderer
62 BuildRequires:  xorg-lib-libXxf86vm-devel
63 %if %{with opengl}
64 BuildRequires:  GLM
65 BuildRequires:  OpenGL-GLU-devel
66 BuildRequires:  glew-devel
67 BuildRequires:  glfw-devel
68 %endif
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 CEGUI stands for Crazy Eddie's Gui System; a free library providing
73 windowing and widgets for graphics APIs / engines where such
74 functionality is not natively available, or severely lacking. The
75 library is object orientated, written in C++, and targeted at games
76 developers who should be spending their time creating great games, not
77 building GUI sub-systems!
78
79 %description -l pl.UTF-8
80 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
81 zapewniającą okienka i widgety dla graficznych API i silników tam,
82 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
83 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
84 skierowana dla programistów gier, którzy powinni spędzać czas na
85 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
86
87 %package devel
88 Summary:        Development files for CEGUI
89 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
90 Group:          Development/Libraries
91 Requires:       %{name} = %{version}-%{release}
92 Requires:       freetype-devel >= 2.0
93 Requires:       libstdc++-devel
94 Requires:       pcre-devel >= 5.0
95
96 %description devel
97 CEGUI headers.
98
99 %description devel -l pl.UTF-8
100 Pliki nagłówkowe CEGUI.
101
102 %package docs
103 Summary:        Documentation files for CEGUI
104 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
105 Group:          Documentation
106 Requires:       %{name} = %{version}-%{release}
107
108 %description docs
109 CEGUI documentation.
110
111 %description docs -l pl.UTF-8
112 Dokumentacja CEGUI.
113
114 %package ImageCodec-Corona
115 Summary:        CoronaImageCodec library for CEGUI
116 Summary(pl.UTF-8):      Biblioteka CoronaImageCodec dla CEGUI
117 Group:          Libraries
118 Requires:       %{name} = %{version}-%{release}
119
120 %description ImageCodec-Corona
121 CoronaImageCodec library for CEGUI.
122
123 %description ImageCodec-Corona -l pl.UTF-8
124 Biblioteka CoronaImageCodec dla CEGUI
125
126 %package ImageCodec-Corona-devel
127 Summary:        Header files for CEGUI CoronaImageCodec library
128 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec
129 Group:          Development/Libraries
130 Requires:       %{name}-ImageCodec-Corona = %{version}-%{release}
131 Requires:       %{name}-devel = %{version}-%{release}
132 Requires:       corona-devel
133
134 %description ImageCodec-Corona-devel
135 Header files for CEGUI CoronaImageCodec library.
136
137 %description ImageCodec-Corona-devel -l pl.UTF-8
138 Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec.
139
140 %package ImageCodec-DevIL
141 Summary:        DevILImageCodec library for CEGUI
142 Summary(pl.UTF-8):      Biblioteka DevILImageCodec dla CEGUI
143 Group:          Libraries
144 Requires:       %{name} = %{version}-%{release}
145
146 %description ImageCodec-DevIL
147 DevILImageCodec library for CEGUI.
148
149 %description ImageCodec-DevIL -l pl.UTF-8
150 Biblioteka DevILImageCodec dla CEGUI
151
152 %package ImageCodec-DevIL-devel
153 Summary:        Header files for CEGUI DevILImageCodec library
154 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI DevILImageCodec
155 Group:          Development/Libraries
156 Requires:       %{name}-ImageCodec-DevIL = %{version}-%{release}
157 Requires:       %{name}-devel = %{version}-%{release}
158 Requires:       DevIL-devel
159
160 %description ImageCodec-DevIL-devel
161 Header files for CEGUI DevILImageCodec library.
162
163 %description ImageCodec-DevIL-devel -l pl.UTF-8
164 Pliki nagłówkowe biblioteki CEGUI DevILImageCodec.
165
166 %package ImageCodec-FreeImage
167 Summary:        FreeImageImageCodec library for CEGUI
168 Summary(pl.UTF-8):      Biblioteka FreeImageImageCodec dla CEGUI
169 Group:          Libraries
170 Requires:       %{name} = %{version}-%{release}
171
172 %description ImageCodec-FreeImage
173 FreeImageImageCodec library for CEGUI.
174
175 %description ImageCodec-FreeImage -l pl.UTF-8
176 Biblioteka FreeImageImageCodec dla CEGUI
177
178 %package ImageCodec-FreeImage-devel
179 Summary:        Header files for CEGUI FreeImageImageCodec library
180 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec
181 Group:          Development/Libraries
182 Requires:       %{name}-ImageCodec-FreeImage = %{version}-%{release}
183 Requires:       %{name}-devel = %{version}-%{release}
184 Requires:       FreeImage-devel
185
186 %description ImageCodec-FreeImage-devel
187 Header files for CEGUI FreeImageImageCodec library.
188
189 %description ImageCodec-FreeImage-devel -l pl.UTF-8
190 Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec.
191
192 %package ImageCodec-SILLY
193 Summary:        SILLYImageCodec library for CEGUI
194 Summary(pl.UTF-8):      Biblioteka SILLYImageCodec dla CEGUI
195 Group:          Libraries
196 Requires:       %{name} = %{version}-%{release}
197 Requires:       SILLY >= 0.1.0
198
199 %description ImageCodec-SILLY
200 SILLYImageCodec library for CEGUI.
201
202 %description ImageCodec-SILLY -l pl.UTF-8
203 Biblioteka SILLYImageCodec dla CEGUI
204
205 %package ImageCodec-SILLY-devel
206 Summary:        Header files for CEGUI SILLYImageCodec library
207 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec
208 Group:          Development/Libraries
209 Requires:       %{name}-ImageCodec-SILLY = %{version}-%{release}
210 Requires:       %{name}-devel = %{version}-%{release}
211 Requires:       SILLY-devel >= 0.1.0
212
213 %description ImageCodec-SILLY-devel
214 Header files for CEGUI SILLYImageCodec library.
215
216 %description ImageCodec-SILLY-devel -l pl.UTF-8
217 Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec.
218
219 %package Parser-Expat
220 Summary:        Expat-based XML parser module
221 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece Expat
222 Group:          Libraries
223 Requires:       %{name} = %{version}-%{release}
224
225 %description Parser-Expat
226 Expat-based XML parser module.
227
228 %description Parser-Expat -l pl.UTF-8
229 Moduł analizatora XML oparty na bibliotece Expat.
230
231 %package Parser-LibXML
232 Summary:        LibXML-based XML parser module
233 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece LibXML
234 Group:          Libraries
235 Requires:       %{name} = %{version}-%{release}
236 Requires:       libxml2 >= 1:2.6
237
238 %description Parser-LibXML
239 LibXML-based XML parser module.
240
241 %description Parser-LibXML -l pl.UTF-8
242 Moduł analizatora XML oparty na bibliotece LibXML.
243
244 %package Parser-RapidXML
245 Summary:        RapidXML-based XML parser module
246 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece RapidXML
247 Group:          Libraries
248 Requires:       %{name} = %{version}-%{release}
249
250 %description Parser-RapidXML
251 RapidXML-based XML parser module.
252
253 %description Parser-RapidXML -l pl.UTF-8
254 Moduł analizatora XML oparty na bibliotece RapidXML.
255
256 %package Parser-TinyXML
257 Summary:        TinyXML-based XML parser module
258 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece TinyXML
259 Group:          Libraries
260 Requires:       %{name} = %{version}-%{release}
261
262 %description Parser-TinyXML
263 TinyXML-based XML parser module.
264
265 %description Parser-TinyXML -l pl.UTF-8
266 Moduł analizatora XML oparty na bibliotece TinyXML.
267
268 %package Parser-Xerces
269 Summary:        Xerces-based XML parser module
270 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece Xerces
271 Group:          Libraries
272 Requires:       %{name} = %{version}-%{release}
273
274 %description Parser-Xerces
275 Xerces-based XML parser module.
276
277 %description Parser-Xerces -l pl.UTF-8
278 Moduł analizatora XML oparty na bibliotece Xerces.
279
280 %package Renderer-DirectFB
281 Summary:        DirectFBRenderer library for CEGUI
282 Summary(pl.UTF-8):      Biblioteka DirectFBRenderer dla CEGUI
283 Group:          Libraries
284 Requires:       %{name} = %{version}-%{release}
285 Requires:       DirectFB >= 1.2.0
286
287 %description Renderer-DirectFB
288 DirectFBRenderer library for CEGUI.
289
290 %description Renderer-DirectFB -l pl.UTF-8
291 Biblioteka DirectFBRenderer dla CEGUI
292
293 %package Renderer-DirectFB-devel
294 Summary:        Header files for CEGUI DirectFBRenderer library
295 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI DirectFBRenderer
296 Group:          Development/Libraries
297 Requires:       %{name}-Renderer-DirectFB = %{version}-%{release}
298 Requires:       %{name}-devel = %{version}-%{release}
299 Requires:       DirectFB-devel >= 1.2.0
300
301 %description Renderer-DirectFB-devel
302 Header files for CEGUI DirectFBRenderer library.
303
304 %description Renderer-DirectFB-devel -l pl.UTF-8
305 Pliki nagłówkowe biblioteki CEGUI DirectFBRenderer.
306
307 %package Renderer-Irrlicht
308 Summary:        IrrlichtRenderer library for CEGUI
309 Summary(pl.UTF-8):      Biblioteka IrrlichtRenderer dla CEGUI
310 Group:          Libraries
311 Requires:       %{name} = %{version}-%{release}
312 Requires:       irrlicht >= 1.4
313
314 %description Renderer-Irrlicht
315 IrrlichtRenderer library for CEGUI.
316
317 %description Renderer-Irrlicht -l pl.UTF-8
318 Biblioteka IrrlichtRenderer dla CEGUI
319
320 %package Renderer-Irrlicht-devel
321 Summary:        Header files for CEGUI IrrlichtRenderer library
322 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer
323 Group:          Development/Libraries
324 Requires:       %{name}-Renderer-Irrlicht = %{version}-%{release}
325 Requires:       %{name}-devel = %{version}-%{release}
326 Requires:       irrlicht-devel >= 1.4
327
328 %description Renderer-Irrlicht-devel
329 Header files for CEGUI IrrlichtRenderer library.
330
331 %description Renderer-Irrlicht-devel -l pl.UTF-8
332 Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer.
333
334 %package Renderer-Ogre
335 Summary:        OgreRenderer library for CEGUI
336 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
337 Group:          Libraries
338 Requires:       %{name} = %{version}-%{release}
339 Obsoletes:      CEGUI-Ogre
340
341 %description Renderer-Ogre
342 OgreRenderer library for CEGUI.
343
344 %description Renderer-Ogre -l pl.UTF-8
345 Biblioteka OgreRenderer dla CEGUI
346
347 %package Renderer-Ogre-devel
348 Summary:        Header files for CEGUI OgreRenderer library
349 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OgreRenderer
350 Group:          Development/Libraries
351 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
352 Requires:       %{name}-devel = %{version}-%{release}
353 Requires:       ogre-devel >= 1.6.0
354 Obsoletes:      CEGUI-Ogre-devel
355
356 %description Renderer-Ogre-devel
357 Header files for CEGUI OgreRenderer library.
358
359 %description Renderer-Ogre-devel -l pl.UTF-8
360 Pliki nagłówkowe biblioteki CEGUI OgreRenderer.
361
362 %package Renderer-OpenGL
363 Summary:        OpenGLRenderer library for CEGUI
364 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
365 Group:          Libraries
366 Requires:       %{name} = %{version}-%{release}
367 Obsoletes:      CEGUI-OpenGL
368
369 %description Renderer-OpenGL
370 OpenGLRenderer library for CEGUI.
371
372 %description Renderer-OpenGL -l pl.UTF-8
373 Biblioteka OpenGLRenderer dla CEGUI.
374
375 %package Renderer-OpenGL-devel
376 Summary:        Header files for CEGUI OpenGLRenderer library
377 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer
378 Group:          Development/Libraries
379 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
380 Requires:       %{name}-devel = %{version}-%{release}
381 Requires:       OpenGL-GLU-devel
382 Requires:       OpenGL-glut-devel
383 Requires:       glew-devel
384 Obsoletes:      CEGUI-OpenGL-devel
385
386 %description Renderer-OpenGL-devel
387 Header files for CEGUI OpenGLRenderer library.
388
389 %description Renderer-OpenGL-devel -l pl.UTF-8
390 Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer.
391
392 %package -n python-CEGUI
393 Summary:        Python binding for CEGUI
394 Summary(pl.UTF-8):      Wiązania Pythona do CEGUI
395 Group:          Libraries/Python
396 Requires:       %{name} = %{version}-%{release}
397
398 %description -n python-CEGUI
399 Python binding for CEGUI.
400
401 %description -n python-CEGUI -l pl.UTF-8
402 Wiązania Pythona do CEGUI.
403
404 %package -n python-CEGUI-Renderer-Ogre
405 Summary:        Python binding for CEGUI OgreRenderer library
406 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OgreRenderer
407 Group:          Libraries/Python
408 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
409 Requires:       python-CEGUI = %{version}-%{release}
410
411 %description -n python-CEGUI-Renderer-Ogre
412 Python binding for CEGUI OgreRenderer library.
413
414 %description -n python-CEGUI-Renderer-Ogre -l pl.UTF-8
415 Wiązania Pythona do biblioteki CEGUI OgreRenderer.
416
417 %package -n python-CEGUI-Renderer-OpenGL
418 Summary:        Python binding for CEGUI OpenGLRenderer library
419 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OpenGLRenderer
420 Group:          Libraries/Python
421 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
422 Requires:       python-CEGUI = %{version}-%{release}
423
424 %description -n python-CEGUI-Renderer-OpenGL
425 Python binding for CEGUI OpenGLRenderer library.
426
427 %description -n python-CEGUI-Renderer-OpenGL -l pl.UTF-8
428 Wiązania Pythona do biblioteki CEGUI OpenGLRenderer.
429
430 %prep
431 %setup -q -a 1 -n cegui-%{version}
432 %patch0 -p1
433 %patch1 -p1
434 %patch2 -p1
435 %patch3 -p1
436
437 %build
438 install -d build
439 cd build
440 %cmake .. \
441         -DCEGUI_SAMPLES_ENABLED:BOOL=%{?with_samples:ON}%{!?with_samples:OFF} \
442         -DCEGUI_BUILD_RENDERER_DIRECTFB:BOOL=%{?with_directfb:ON}%{!?with_directfb:OFF} \
443         -DCEGUI_BUILD_RENDERER_OPENGL:BOOL=%{?with_opengl:ON}%{!?with_opengl:OFF} \
444         -DCEGUI_BUILD_RENDERER_OGRE:BOOL=%{?with_ogre:ON}%{!?with_ogre:OFF} \
445         -DCEGUI_BUILD_XMLPARSER_XERCES:BOOL=%{?with_xercesc:ON}%{!?with_xercesc:OFF} \
446         -DCEGUI_OPTION_DEFAULT_IMAGECODEC:STRING=FreeImageImageCodec \
447         -DCEGUI_OPTION_DEFAULT_XMLPARSER:STRING=LibxmlParser \
448         -DCEGUI_PYTHON_INSTALL_DIR=%{py_sitedir}
449
450 %{__make} -j1
451
452 %install
453 rm -rf $RPM_BUILD_ROOT
454
455 %{__make} -C build install/fast \
456         DESTDIR=$RPM_BUILD_ROOT
457
458 %if %{without samples}
459 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/cegui-0/{animations,fonts,imagesets,layouts,looknfeel,lua_scripts,schemes,xml_schemas}
460 %endif
461
462 %clean
463 rm -rf $RPM_BUILD_ROOT
464
465 %post   -p /sbin/ldconfig
466 %postun -p /sbin/ldconfig
467
468 %post   Renderer-Irrlicht -p /sbin/ldconfig
469 %postun Renderer-Irrlicht -p /sbin/ldconfig
470 %post   Renderer-Ogre -p /sbin/ldconfig
471 %postun Renderer-Ogre -p /sbin/ldconfig
472 %post   Renderer-OpenGL -p /sbin/ldconfig
473 %postun Renderer-OpenGL -p /sbin/ldconfig
474
475 %files
476 %defattr(644,root,root,755)
477 %doc doc/README.orig
478 %attr(755,root,root) %{_libdir}/libCEGUIBase-0.so.*.*.*
479 %attr(755,root,root) %ghost %{_libdir}/libCEGUIBase-0.so.2
480 %attr(755,root,root) %{_libdir}/libCEGUICommonDialogs-0.so.*.*.*
481 %attr(755,root,root) %ghost %{_libdir}/libCEGUICommonDialogs-0.so.2
482 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-0.so.*.*.*
483 %attr(755,root,root) %ghost %{_libdir}/libCEGUILuaScriptModule-0.so.2
484 # plugins
485 %dir %{_libdir}/cegui-0.8
486 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUICoreWindowRendererSet.so
487
488 %files docs
489 %defattr(644,root,root,755)
490 %doc cegui-docs-%{version}/*
491
492 %files devel
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{_bindir}/toluappcegui-0.8
495 %attr(755,root,root) %{_libdir}/libCEGUIBase-0.so
496 %attr(755,root,root) %{_libdir}/libCEGUICommonDialogs-0.so
497 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-0.so
498 %dir %{_includedir}/cegui-0
499 %dir %{_includedir}/cegui-0/%{name}
500 %{_includedir}/cegui-0/%{name}/*.h
501 %{_includedir}/cegui-0/%{name}/CommonDialogs
502 %dir %{_includedir}/cegui-0/%{name}/ImageCodecModules
503 %dir %{_includedir}/cegui-0/%{name}/RendererModules
504 %{_includedir}/cegui-0/%{name}/ScriptModules
505 %{_includedir}/cegui-0/%{name}/WindowRendererSets
506 %{_includedir}/cegui-0/%{name}/XMLParserModules
507 %{_includedir}/cegui-0/%{name}/falagard
508 %{_includedir}/cegui-0/%{name}/widgets
509 %{_pkgconfigdir}/CEGUI-0.pc
510 %{_pkgconfigdir}/CEGUI-0-LUA.pc
511
512 %files ImageCodec-Corona
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUICoronaImageCodec.so
515
516 %files ImageCodec-Corona-devel
517 %defattr(644,root,root,755)
518 %{_includedir}/cegui-0/%{name}/ImageCodecModules/Corona
519
520 %files ImageCodec-DevIL
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIDevILImageCodec.so
523
524 %files ImageCodec-DevIL-devel
525 %defattr(644,root,root,755)
526 %{_includedir}/cegui-0/%{name}/ImageCodecModules/DevIL
527
528 %files ImageCodec-FreeImage
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIFreeImageImageCodec.so
531
532 %files ImageCodec-FreeImage-devel
533 %defattr(644,root,root,755)
534 %{_includedir}/cegui-0/%{name}/ImageCodecModules/FreeImage
535
536 %files ImageCodec-SILLY
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUISILLYImageCodec.so
539
540 %files ImageCodec-SILLY-devel
541 %defattr(644,root,root,755)
542 %{_includedir}/cegui-0/%{name}/ImageCodecModules/SILLY
543
544 %files Parser-Expat
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIExpatParser.so
547
548 %files Parser-LibXML
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUILibXMLParser.so
551
552 %files Parser-RapidXML
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIRapidXMLParser.so
555
556 %files Parser-TinyXML
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUITinyXMLParser.so
559
560 %files Parser-Xerces
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIXercesParser.so
563
564 %if %{with directfb}
565 %files Renderer-DirectFB
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{_libdir}/libCEGUIDirectFBRenderer-0.so.*.*.*
568 %attr(755,root,root) %ghost %{_libdir}/libCEGUIDirectFBRenderer-0.so.2
569
570 %files Renderer-DirectFB-devel
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_libdir}/libCEGUIDirectFBRenderer-0.so
573 %{_includedir}/cegui-0/%{name}/RendererModules/DirectFB
574 %endif
575
576 %files Renderer-Irrlicht
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-0.so.*.*.*
579 %attr(755,root,root) %ghost %{_libdir}/libCEGUIIrrlichtRenderer-0.so.2
580
581 %files Renderer-Irrlicht-devel
582 %defattr(644,root,root,755)
583 %{_includedir}/cegui-0/%{name}/RendererModules/Irrlicht
584 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-0.so
585 %{_pkgconfigdir}/CEGUI-0-IRRLICHT.pc
586
587 %if %{with ogre}
588 %files Renderer-Ogre
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-0.so.*.*.*
591 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOgreRenderer-0.so.2
592
593 %files Renderer-Ogre-devel
594 %defattr(644,root,root,755)
595 %{_includedir}/cegui-0/%{name}/RendererModules/Ogre
596 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-0.so
597 %{_pkgconfigdir}/CEGUI-0-OGRE.pc
598 %endif
599
600 %if %{with opengl}
601 %files Renderer-OpenGL
602 %defattr(644,root,root,755)
603 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-0.so.*.*.*
604 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOpenGLRenderer-0.so.2
605
606 %files Renderer-OpenGL-devel
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-0.so
609 %{_includedir}/cegui-0/%{name}/RendererModules/OpenGL
610 %{_pkgconfigdir}/CEGUI-0-OPENGL.pc
611 %{_pkgconfigdir}/CEGUI-0-OPENGL3.pc
612 %endif
613
614 %files -n python-CEGUI
615 %defattr(644,root,root,755)
616 %dir %{py_sitedir}/cegui-0.8
617 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUI.so
618
619 %if %{with ogre}
620 %files -n python-CEGUI-Renderer-Ogre
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUIOgreRenderer.so
623 %endif
624
625 %if %{with opengl}
626 %files -n python-CEGUI-Renderer-OpenGL
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUIOpenGLRenderer.so
629 %endif
This page took 0.100685 seconds and 4 git commands to generate.