]> git.pld-linux.org Git - packages/Atari800.git/blob - Atari800.spec
- more specific BR: svgalib4ggi on ppc
[packages/Atari800.git] / Atari800.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # with unzipped ROM files instead of xf25.zip
4 %bcond_without  svga                    # without SVGA version
5 #
6 %ifnarch %{ix86} alpha ppc
7 %undefine       with_svga
8 %endif
9 Summary:        Atari 800 Emulator
10 Summary(pl):    Emulator Atari 800
11 Name:           Atari800
12 Version:        1.3.1
13 Release:        3
14 License:        GPL (Atari800), distributable if unmodified (xf25 with ROMs)
15 Group:          Applications/Emulators
16 Source0:        http://dl.sourceforge.net/atari800/atari800-%{version}.tar.gz
17 # Source0-md5:  02c824a4648732a3646d377ee02efd7d
18 # NOTE: ROMs probably can be redistributed only in original XF25 archive
19 Source1:        http://joy.sophics.cz/www/xf25.zip
20 # Source1-md5:  4dc3b6b4313e9596c4d474785a37b94d
21 Source2:        %{name}-chooser
22 URL:            http://atari800.atari.org/
23 BuildRequires:  SDL-devel
24 BuildRequires:  XFree86-devel
25 %if %{with svga}
26 %ifarch ppc
27 BuildRequires:  svgalib4ggi-devel
28 %else
29 BuildRequires:  svgalib-devel
30 %endif
31 %endif
32 %if %{with license_agreement}
33 BuildRequires:  unzip
34 %endif
35 BuildRequires:  zlib-devel
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         specflags       -fomit-frame-pointer
39
40 %description
41 This is Atari 800, 800XL, 130XE and 5200 emulator.
42
43 %description -l pl
44 To jest emulator Atari 800, 800XL, 130XE i 5200.
45
46 %package common
47 Summary:        Atari 800 Emulator - common files for svgalib and X11 versions
48 Summary(pl):    Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
49 Group:          Applications/Emulators
50 Obsoletes:      Atari800
51 %if %{without license_agreement}
52 Requires(post): unzip
53 %endif
54
55 %description common
56 This is Atari 800, 800XL, 130XE and 5200 emulator.
57
58 This package contains common files for both svgalib and X11 versions
59 of Atari800.
60 %if %{without license_agreement}
61 Note: because of license problems we had to include whole X-Former
62 archive (xf25.zip). If you don't want it - rebuild Atari800 (--with
63 license_agreement)
64 %endif 
65
66 %description common -l pl
67 To jest emulator Atari 800, 800XL, 130XE i 5200.
68
69 Ten pakiet zawiera pliki wspólne dla wersji dzia³aj±cych pod svgalib
70 oraz X11.
71 %if %{without license_agreement}
72 Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê
73 z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -
74 przebuduj pakiet z opcja --with license_agreement.
75 %endif
76
77 %package svga
78 Summary:        Atari 800 Emulator - svgalib version
79 Summary(pl):    Emulator Atari 800 - wersja pod svgalib
80 License:        GPL
81 Group:          Applications/Emulators
82 Requires:       %{name}-common = %{version}
83
84 %description svga
85 This is Atari 800, 800XL, 130XE and 5200 emulator.
86
87 This package contains Atari800 executable file configured for svgalib
88 with sound and joystick support.
89
90 %description svga -l pl
91 To jest emulator Atari 800, 800XL, 130XE i 5200.
92
93 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla
94 svgalib z obs³ug± d¼wiêku i joysticka.
95
96 %package x11
97 Summary:        Atari 800 Emulator - X Window version
98 Summary(pl):    Emulator Atari 800 - wersja pod X Window
99 License:        GPL
100 Group:          Applications/Emulators
101 Requires:       %{name}-common = %{version}
102
103 %description x11
104 This is Atari 800, 800XL, 130XE and 5200 emulator.
105
106 This package contains Atari800 executable file configured for X11 with
107 sound and joystick support.
108
109 %description x11 -l pl
110 To jest emulator Atari 800, 800XL, 130XE i 5200.
111
112 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla X11 z
113 obs³ug± d¼wiêku i joysticka.
114
115 %package SDL
116 Summary:        Atari 800 Emulator - SDL version
117 Summary(pl):    Emulator Atari 800 - wersja pod SDL
118 License:        GPL
119 Group:          Applications/Emulators
120 Requires:       %{name}-common = %{version}
121
122 %description SDL
123 This is Atari 800, 800XL, 130XE and 5200 emulator.
124
125 This package contains Atari800 executable file configured for SDL with
126 sound and joystick support.
127
128 %description SDL -l pl
129 To jest emulator Atari 800, 800XL, 130XE i 5200.
130
131 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla SDL z
132 obs³ug± d¼wiêku i joysticka.
133
134 %prep
135 %setup -q -n atari800-%{version}
136
137 %build
138 cd src
139
140 CFLAGS="%{rpmcflags}"
141
142 %if %{with svga}
143 %configure \
144         --target=svgalib \
145         --disable-VERY_SLOW \
146         --enable-NO_CYCLE_EXACT \
147         --enable-CRASH_MENU \
148         --enable-MONITOR_BREAK \
149         --enable-MONITOR_HINTS \
150         --enable-MONITOR_ASSEMBLER \
151         --enable-COMPILED_PALETTE \
152         --enable-SNAILMETER \
153         --disable-SVGA_SPEEDUP \
154         --enable-USE_CURSORBLOCK \
155         --disable-JOYMOUSE \
156         --enable-LINUX_JOYSTICK \
157         --enable-SOUND \
158         --enable-NO_VOL_ONLY \
159         --enable-NO_CONSOL_SOUND \
160         --disable-SERIO_SOUND \
161         --enable-NOSNDINTER \
162         --disable-CLIP \
163         --disable-STEREO \
164         --disable-BUFFERED_LOG \
165         --enable-SET_LED \
166         --enable-NO_LED_ON_SCREEN
167
168 %{__make}
169
170 mv -f atari800 atari800-svga
171
172 %{__make} clean
173 %endif
174
175 %configure \
176         --target=sdl \
177         --disable-VERY_SLOW \
178         --enable-NO_CYCLE_EXACT \
179         --enable-CRASH_MENU \
180         --enable-MONITOR_BREAK \
181         --enable-MONITOR_HINTS \
182         --enable-MONITOR_ASSEMBLER \
183         --enable-COMPILED_PALETTE \
184         --enable-SNAILMETER \
185         --enable-LINUX_JOYSTICK \
186         --enable-SOUND \
187         --enable-NO_VOL_ONLY \
188         --enable-NO_CONSOL_SOUND \
189         --disable-SERIO_SOUND \
190         --enable-NOSNDINTER \
191         --disable-CLIP \
192         --disable-STEREO \
193         --disable-BUFFERED_LOG \
194         --enable-SET_LED \
195         --enable-NO_LED_ON_SCREEN
196
197 %{__make}
198
199 mv -f atari800 atari800-SDL
200
201 %{__make} clean
202
203 %configure \
204         --target=shm \
205         --disable-VERY_SLOW \
206         --enable-NO_CYCLE_EXACT \
207         --enable-CRASH_MENU \
208         --enable-MONITOR_BREAK \
209         --enable-MONITOR_HINTS \
210         --enable-MONITOR_ASSEMBLER \
211         --enable-COMPILED_PALETTE \
212         --enable-SNAILMETER \
213         --enable-LINUX_JOYSTICK \
214         --enable-SOUND \
215         --enable-NO_VOL_ONLY \
216         --enable-NO_CONSOL_SOUND \
217         --disable-SERIO_SOUND \
218         --enable-NOSNDINTER \
219         --disable-CLIP \
220         --disable-STEREO
221
222 %{__make}
223
224 mv -f atari800 atari800-x11
225
226 %install
227 rm -rf $RPM_BUILD_ROOT
228 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/atari800,%{_mandir}/man1}
229
230 %if %{with svga}
231 install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}
232 %endif
233 install src/atari800-x11 $RPM_BUILD_ROOT%{_bindir}
234 install src/atari800-SDL $RPM_BUILD_ROOT%{_bindir}
235 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
236 install src/atari800.man $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
237
238 %if %{with license_agreement}
239 unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
240 rm -f $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
241 %else
242 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
243 %endif
244
245 %clean
246 rm -rf $RPM_BUILD_ROOT
247
248 %if %{without license_agreement}
249 %post common
250 cd %{_datadir}/atari800
251 unzip -q -L xf25.zip
252 %endif
253
254 %files common
255 %defattr(644,root,root,755)
256 %doc DOC/{BUGS,CHANGES,CREDITS,FAQ,README,TODO,USAGE} README.1ST
257 %doc DOC/{LPTjoy.txt,cart.txt,emuos.txt,pokeysnd.txt}
258 %attr(755,root,root) %{_bindir}/atari800
259 %{_datadir}/atari800
260 %{_mandir}/man1/atari800.1*
261
262 %files x11
263 %defattr(644,root,root,755)
264 %attr(755,root,root) %{_bindir}/atari800-x11
265
266 %files SDL
267 %defattr(644,root,root,755)
268 %attr(755,root,root) %{_bindir}/atari800-SDL
269
270 %if %{with svga}
271 %files svga
272 %defattr(644,root,root,755)
273 %attr(755,root,root) %{_bindir}/atari800-svga
274 %endif
This page took 0.050631 seconds and 3 git commands to generate.