]> git.pld-linux.org Git - packages/balsa.git/blame_incremental - balsa.spec
- more fixes
[packages/balsa.git] / balsa.spec
... / ...
CommitLineData
1# TODO:
2# - not packaged /usr/share/locale/ar/LC_MESSAGES/balsa.mo
3# - problems with id locale
4# - finish support for gtkhtml-4
5#
6# Conditional build:
7%bcond_without ldap # build without LDAP support
8%bcond_with gpgme # build with GPG support (experimental)
9%bcond_without esmtp # build without ESMTP support
10%bcond_without gtkhtml # build without HTML support
11%bcond_with gtkhtml2 # build with libgtkhtml-2 (default gtkhtml-3)
12%bcond_with compface # build with Compface
13%bcond_with gtksourceview # build with GtkSourceView
14%bcond_without gtkspell # build without GtkSpell
15%bcond_with sqlite # build with SQLite for GPE address books
16#
17Summary: Balsa Mail Client
18Summary(es.UTF-8): Balsa es un lector de e-mail
19Summary(pl.UTF-8): Balsa - klient poczty
20Summary(pt_BR.UTF-8): Balsa é um leitor de e-mail
21Name: balsa
22Version: 2.4.9
23Release: 0.1
24License: GPL v3+
25Group: X11/Applications
26Source0: http://pawsa.fedorapeople.org/balsa/%{name}-%{version}.tar.bz2
27# Source0-md5: bd7ac44f0cf3117a5fdb46d17dac2b51
28Patch0: %{name}-desktop.patch
29Patch1: %{name}-gtkhtml4.patch
30URL: http://balsa.gnome.org/
31BuildRequires: ORBit2-devel >= 1:2.12.4
32BuildRequires: aspell-devel >= 2:0.50
33BuildRequires: autoconf >= 2.52
34BuildRequires: automake
35%{?with_compface:BuildRequires: compface-devel}
36BuildRequires: docbook-dtd412-xml
37BuildRequires: gettext-devel
38BuildRequires: glib2-devel >= 2.6.4-1
39BuildRequires: gmime-devel >= 2.4.0
40BuildRequires: gnome-doc-utils
41%{?with_gpgme:BuildRequires: gpgme-devel >= 1:0.9.0}
42BuildRequires: gtk+2-devel >= 2:2.10.0
43%{?with_gtksourceview:BuildRequires: gtksourceview-devel}
44%{?with_gtkspell:BuildRequires: gtkspell-devel}
45BuildRequires: heimdal-devel
46BuildRequires: intltool
47%{?with_esmtp:BuildRequires: libesmtp-devel >= 1.0.4}
48%if %{with gtkhtml}
49%{!?with_gtkhtml2:BuildRequires: gtkhtml-devel >= 3.14}
50%{?with_gtkhtml2:BuildRequires: libgtkhtml-devel >= 2.0}
51%endif
52BuildRequires: libgnomeui-devel >= 2.3.3.1-2
53BuildRequires: libltdl-devel
54BuildRequires: libnotify-devel
55BuildRequires: libtool
56%{?with_ldap:BuildRequires: openldap-devel >= 2.4.6}
57BuildRequires: openssl-devel >= 0.9.7d
58BuildRequires: pcre-devel >= 3.0
59BuildRequires: pkgconfig
60BuildRequires: rpmbuild(macros) >= 1.197
61BuildRequires: scrollkeeper >= 0.1.4
62# actually, it requires sqlite >= 2.8
63%{?with_sqlite:BuildRequires: sqlite3-devel}
64%{?with_gpgme:Requires: gpgme >= 1:0.9.0}
65Requires(post,postun): scrollkeeper
66# sr@Latn vs. sr@latin
67Conflicts: glibc-misc < 6:2.7
68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70%description
71Balsa is an e-mail reader. This client is part of the GNOME
72desktop environment. It supports local mailboxes, POP3 and
73IMAP.
74
75%description -l es.UTF-8
76Balsa es un lector de e-mail. Es parte del entorno GNOME. Soporta
77cajas de correo electrónico locales, POP3 y IMAP.
78
79%description -l pl.UTF-8
80Balsa to klient e-mail. Jest częścią środowiska GNOME. Obsługuje POP3,
81IMAP oraz lokalne skrzynki pocztowe.
82
83%description -l pt_BR.UTF-8
84Balsa é um leitor de e-mail, parte do ambiente de desktop GNOME.
85Suporta caixas de correio locais, POP3 a IMAP.
86
87%prep
88%setup -q
89%patch0 -p1
90%patch1 -p1
91
92%build
93%{__libtoolize}
94%{__aclocal}
95%{__autoconf}
96%{__autoheader}
97%{__autoconf}
98%configure \
99 --with-gss \
100 --with-ssl \
101 %{!?with_esmtp:--without-esmtp} \
102 %{!?with_gtkhtml:--disable-gtkhtml}\
103 %{?with_gtkhtml2:--with-gtkhtml=2}\
104 %{?with_gpgme:--with-gpgme} \
105 %{?with_compface:--with-compface} \
106 %{?with_gtksourceview:--with-gtksourceview} \
107 %{?with_gtkspell:--with-gtkspell} \
108 %{?with_sqlite:--with-sqlite} \
109 %{?with_ldap:--with-ldap}
110%{__make}
111
112%install
113rm -rf $RPM_BUILD_ROOT
114
115%{__make} install \
116 DESTDIR=$RPM_BUILD_ROOT
117
118[ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
119 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
120%find_lang %{name} --with-gnome --all-name
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%post
126%scrollkeeper_update_post
127
128%postun
129%scrollkeeper_update_postun
130
131%files -f %{name}.lang
132%defattr(644,root,root,755)
133%doc AUTHORS ChangeLog NEWS README TODO
134%attr(755,root,root) %{_bindir}/*
135%{_sysconfdir}/sound/events/*
136%{_datadir}/%{name}
137%{_datadir}/sounds/%{name}
138%{_libdir}/bonobo/servers/*.server
139%{_datadir}/idl/*.idl
140%{_mandir}/man1/*
141%{_omf_dest_dir}/%{name}
142%{_desktopdir}/*.desktop
143%{_pixmapsdir}/*
144%{_iconsdir}/hicolor/48x48/mimetypes/*.png
This page took 0.052818 seconds and 4 git commands to generate.