]> git.pld-linux.org Git - packages/apache1-mod_xslt.git/blame_incremental - apache1-mod_xslt.spec
- tabs in preamble
[packages/apache1-mod_xslt.git] / apache1-mod_xslt.spec
... / ...
CommitLineData
1# TODO
2# - doesn't build
3# mod_xslt.c:212: warning: passing arg 6 of `SablotRunProcessor' from incompatible pointer type
4# ...
5%define mod_name xslt
6%define apxs /usr/sbin/apxs1
7Summary: Module to serve XML based content
8Summary(pl.UTF-8): Moduł do udostępniania dokumentów XML
9Name: apache1-mod_%{mod_name}
10Version: 1.1
11Release: 1.2
12License: GPL
13Group: Networking/Daemons
14Source0: http://dl.sourceforge.net/modxslt/mod_%{mod_name}-%{version}.tar.gz
15# Source0-md5: ce458a48f56cc857c808b71ec27f592d
16Source1: %{name}.conf
17Patch0: %{name}-includes.patch
18Patch1: %{name}-regex.patch
19Patch2: %{name}-make.patch
20Patch3: %{name}-module.patch
21URL: http://modxslt.userworld.com/
22BuildRequires: %{apxs}
23BuildRequires: apache1-devel >= 1.3.33-2
24BuildRequires: rpmbuild(macros) >= 1.268
25BuildRequires: sablotron-devel
26Requires: apache1 >= 1.3.33-2
27Requires: expat
28Requires: sablotron
29Obsoletes: apache-mod_xslt <= 1.1
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
33%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
34
35%description
36mod_xslt is a simple Apache module to serve XML based content. Data is
37stored in XML files on the server. The user requests the XML file and
38the translation method via a url such as this:
39http://localhost/sourcefile.html. The module will parse this URL into
40a XML source file and an XSL source file. In the example above, the
41XML file will be sourcefile.xml. The module will open sourcefile.xml
42and determine its DOCTYPE. Based on the DOCTYPE, the XSL file will be
43opened. Should the DOCTYPE be "tutorial", the XSL file opened would be
44tutorial_html.xsl. The content-type returned to the browser is
45text/html. The translation occurs transparently to the user.
46
47%description -l pl.UTF-8
48mod_xslt jest prostym modułem Apache do udostępniania dokumentów XML.
49Dane są zapisane w plikach XML na serwerze. Użytkownik żąda pliku XML
50i tłumaczenia poprzez URL w stylu http://localhost/sourcefile.html.
51Moduł zamienia ten URL na pliki źródłowe XML i XSL. W tym przykładzie
52plikiem XML będzie sourcefile.xml. Moduł otworzy plik sourcefile.xml i
53określi DOCTYPE, na podstawie którego otworzy odpowiedni plik XSL.
54Jeżeli DOCTYPE jest "tutorial", plikiem XSL będzie tutorial_html.xsl.
55Następnie moduł dokona przetwarzania pliku XML za pomocą arkusza XSLT
56i zwróci przeglądarce powstały w ten sposób text/html. Cały proces
57odbywa się w sposób niewidoczny dla użytkownika.
58
59%prep
60%setup -q -n mod%{mod_name}
61%patch0 -p1
62%patch1 -p1
63%patch2 -p1
64%patch3 -p1
65
66%build
67%{__make} \
68 APXS=%{apxs} \
69 CFLAGS="%{rpmcflags} -DEAPI"
70
71%install
72rm -rf $RPM_BUILD_ROOT
73install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
74
75install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
76install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post
82%service -q apache restart
83
84%postun
85if [ "$1" = "0" ]; then
86 %service -q apache restart
87fi
88
89%files
90%defattr(644,root,root,755)
91%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
92%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.025361 seconds and 4 git commands to generate.