]> git.pld-linux.org Git - packages/apache1-mod_suid.git/blame_incremental - apache1-mod_suid.spec
- BR s@%{apxs}@apache1-apxs@g
[packages/apache1-mod_suid.git] / apache1-mod_suid.spec
... / ...
CommitLineData
1%define mod_name suid
2%define apxs /usr/sbin/apxs1
3Summary: Apache module: execution of scripts under their own uids
4Summary(pl.UTF-8): Moduł do apache: wykonywanie skryptów pod wskazanym uidem
5Name: apache1-mod_%{mod_name}
6Version: 1.1
7Release: 4
8License: GPL
9Group: Networking/Daemons
10Source0: http://www.jdimedia.nl/igmar/mod_%{mod_name}/files/mod_%{mod_name}-%{version}.tar.gz
11# Source0-md5: 1e47d40d8f0404d9faa3040655df44a2
12URL: http://www.jdimedia.nl/igmar/mod_suid/
13BuildRequires: apache1-apxs
14BuildRequires: apache1-devel >= 1.3.33-2
15BuildRequires: rpmbuild(macros) >= 1.268
16BuildRequires: zlib-devel
17Requires(triggerpostun): %{apxs}
18Requires: apache1(EAPI)
19Obsoletes: apache-mod_suid <= 1.1
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
23%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
24
25%description
26Apache module: execution of scripts under their own uids per-vhost.
27
28%description -l pl.UTF-8
29Moduł do apache: wykonywanie skryptów pod wskazanym uidem per-vhost.
30
31%prep
32%setup -q -n mod_%{mod_name}-%{version}
33
34%build
35%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
36
37%install
38rm -rf $RPM_BUILD_ROOT
39install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
40
41install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
42
43echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
44 $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
45
46%clean
47rm -rf $RPM_BUILD_ROOT
48
49%post
50%service -q apache restart
51
52%postun
53if [ "$1" = "0" ]; then
54 %service -q apache restart
55fi
56
57%triggerpostun -- apache1-mod_%{mod_name} < 1.1-1.1
58# check that they're not using old apache.conf
59if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
60 %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
61fi
62
63%files
64%defattr(644,root,root,755)
65%doc CHANGES.txt README
66%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
67%attr(755,root,root) %{_pkglibdir}/*
This page took 0.062028 seconds and 4 git commands to generate.