]> git.pld-linux.org Git - packages/apache-mod_fcgid.git/blame_incremental - apache-mod_fcgid.spec
- added patch to allow setting path to suexec binary
[packages/apache-mod_fcgid.git] / apache-mod_fcgid.spec
... / ...
CommitLineData
1%define mod_name fcgid
2%define apxs /usr/sbin/apxs
3Summary: A binary compatibility alternative to Apache module mod_fastcgi
4Summary(pl.UTF-8): Binarnie kompatybilna alternatywa dla modułu Apache'a mod_fastcgi
5Name: apache-mod_%{mod_name}
6Version: 2.2
7Release: 3
8License: GPL v2
9Group: Networking/Daemons/HTTP
10Source0: http://dl.sourceforge.net/mod-fcgid/mod_%{mod_name}.%{version}.tar.gz
11# Source0-md5: ce7d7b16e69643dbd549d43d85025983
12Source1: %{name}.conf
13Patch0: %{name}-suexec-path.patch
14URL: http://fastcgi.coremail.cn/
15BuildRequires: %{apxs}
16BuildRequires: apache-devel >= 2.0.52-2
17BuildRequires: libtool
18BuildRequires: rpmbuild(macros) >= 1.268
19Requires: apache(modules-api) = %apache_modules_api
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
23%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
24
25%description
26A binary compatibility alternative to Apache module mod_fastcgi.
27mod_fcgid has a new process management strategy, which concentrates on
28reducing the number of fastcgi server, and kick out the corrupt
29fastcgi server as soon as possible.
30
31%description -l pl.UTF-8
32Binarnie kompatybilna alternatywa dla modułu Apache'a mod_fastcgi.
33mod_fcgid to nowa strategia zarządzania procesami, koncentrująca się
34na redukcji liczby serwerów fastcgi i usuwaniu uszkodzonych serwerów
35fastcgi najszybciej jak to możliwe.
36
37%prep
38%setup -q -n mod_%{mod_name}.%{version}
39%patch0 -p1
40
41%build
42%{__make} \
43 top_dir=%{_pkglibdir} \
44 APXS=%{apxs} \
45 INCLUDES="-I%(%{apxs} -q INCLUDEDIR)"
46
47%install
48rm -rf $RPM_BUILD_ROOT
49install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
50
51install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
52install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/70_mod_%{mod_name}.conf
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%post
58%service -q httpd restart
59
60%postun
61if [ "$1" = "0" ]; then
62 %service -q httpd restart
63fi
64
65%files
66%defattr(644,root,root,755)
67%doc AUTHOR ChangeLog
68%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
69%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.056083 seconds and 4 git commands to generate.