]> git.pld-linux.org Git - packages/FreeMat.git/blame_incremental - FreeMat.spec
- add qt4.patch
[packages/FreeMat.git] / FreeMat.spec
... / ...
CommitLineData
1# TODO:
2# - look at MPI support - doesn't work with lam for me :/
3%define fversion %(echo %{version} |tr r -)
4%define mversion %(echo %{version} |cut -f -1 -d r)
5Summary: FreeMat - an environment for rapid engineering and scientific processing
6Summary(pl.UTF-8): FreeMat - środowisko do szybkiego przetwarzania inżynieryjnego i naukowego
7Name: FreeMat
8Version: 3.5
9Release: 0.1
10License: MIT
11Group: Applications/Math
12Source0: http://dl.sourceforge.net/freemat/%{name}-%{fversion}.tar.gz
13# Source0-md5: 4cc41c1f9265a86134fd338076d1a65f
14Source1: %{name}.desktop
15Patch0: %{name}-qt4.patch
16URL: http://freemat.sourceforge.net
17BuildRequires: autoconf
18BuildRequires: automake
19BuildRequires: blas-devel
20BuildRequires: gcc-g77
21BuildRequires: libjpeg-devel
22BuildRequires: libpng-devel
23BuildRequires: libstdc++-devel
24BuildRequires: libtiff-devel
25BuildRequires: ncurses-devel
26BuildRequires: QtCore-devel
27BuildRequires: QtGui-devel
28BuildRequires: QtOpenGL-devel
29BuildRequires: QtNetwork-devel
30BuildRequires: QtXml-devel
31BuildRequires: qt4-build
32BuildRequires: zlib-devel
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36FreeMat is a free environment for rapid entineering and scientific
37prototyping and data processing. It is similar to commercial systems
38such as MATLAB from Mathworks, and IDL from Research Systems, but is
39Open Source. FreeMat includes several novel features such as a
40codeless interface to external C/C++/FORTRAN code,
41parallel/distributed algorithm development (via MPI), and plotting and
42visualiation capabilities.
43
44%description -l pl.UTF-8
45FreeMat jest darmowym środowiskiem do szybkiego przetwarzania
46prototypów i danych dla inżynierów i naukowców. Jest podobny do
47komercyjnych systemów takich jak MATLAB z Mathworks i IDL z Research
48Group, ale na licencji Open Source. FreeMat cechuje się między innymi
49bezkodowym interfejsem do zewnętrznego kodu C/C++/FORTRAN,
50równoległym/rozproszonym algorytmem obliczeń (poprzez MPI), oraz
51rysowaniem i wyświetlaniem możliwości.
52
53%prep
54%setup -q -n %{name}-%{mversion}
55%patch0 -p1
56
57%build
58CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
59CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
60%{__aclocal}
61%{__autoconf}
62%{__automake}
63%configure \
64 --with-ncurses
65
66%{__make}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70install -d $RPM_BUILD_ROOT{%{_infodir},%{_desktopdir}}
71
72%{__make} install \
73 DESTDIR=$RPM_BUILD_ROOT \
74 prefix=$RPM_BUILD_ROOT%{_prefix}
75
76install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%files
82%defattr(644,root,root,755)
83%attr(755,root,root) %{_bindir}/%{name}
84%{_datadir}/%{name}
85%{_desktopdir}/%{name}.desktop
This page took 0.02872 seconds and 4 git commands to generate.