]> git.pld-linux.org Git - packages/Atari800.git/blame_incremental - Atari800.spec
- updated to 4.2.0
[packages/Atari800.git] / Atari800.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with license_agreement # with unzipped ROM files instead of xf25.zip
4#
5Summary: Atari 800 Emulator
6Summary(pl.UTF-8): Emulator Atari 800
7Name: Atari800
8Version: 4.2.0
9Release: 1
10License: GPL v2+ (Atari800), distributable if unmodified (xf25 with ROMs)
11Group: Applications/Emulators
12#Source0Download: https://github.com/atari800/atari800/releases
13Source0: https://github.com/atari800/atari800/releases/download/ATARI800_4_2_0/atari800-%{version}-src.tgz
14# Source0-md5: 695031b9bc3461cd18ec9090779d984b
15# NOTE: ROMs probably can be redistributed only in original XF25 archive
16Source1: http://joy.sophics.cz/www/xf25.zip
17# Source1-md5: 4dc3b6b4313e9596c4d474785a37b94d
18Source2: %{name}-chooser
19URL: https://atari800.github.io/
20BuildRequires: SDL-devel
21BuildRequires: automake
22%if %{with license_agreement}
23BuildRequires: unzip
24%endif
25BuildRequires: xorg-lib-libX11-devel
26BuildRequires: xorg-lib-libXext-devel
27BuildRequires: zlib-devel
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%define specflags -fomit-frame-pointer
31
32%description
33This is Atari 800, 800XL, 130XE and 5200 emulator.
34
35%description -l pl.UTF-8
36To jest emulator Atari 800, 800XL, 130XE i 5200.
37
38%package common
39Summary: Atari 800 Emulator - common files for SDL and X11 versions
40Summary(pl.UTF-8): Emulator Atari 800 - pliki wspólne dla wersji SDL oraz X11
41Group: Applications/Emulators
42Obsoletes: Atari800
43%if %{without license_agreement}
44Requires(post): unzip
45%endif
46
47%description common
48This is Atari 800, 800XL, 130XE and 5200 emulator.
49
50This package contains common files for both SDL and X11 versions
51of Atari800.
52%if %{without license_agreement}
53Note: because of license problems we had to include whole X-Former
54archive (xf25.zip). If you don't want it - rebuild Atari800 (--with
55license_agreement)
56%endif
57
58%description common -l pl.UTF-8
59To jest emulator Atari 800, 800XL, 130XE i 5200.
60
61Ten pakiet zawiera pliki wspólne dla wersji działających pod SDL
62oraz X11.
63%if %{without license_agreement}
64Uwaga: z powodu problemów z licencją musieliśmy załączyć całą paczkę
65z emulatorem X-Former (xf25.zip). Jeśli jej nie chcesz w pakiecie -
66przebuduj pakiet z opcja --with license_agreement.
67%endif
68
69%package x11
70Summary: Atari 800 Emulator - X Window version
71Summary(pl.UTF-8): Emulator Atari 800 - wersja dla systemu X Window
72License: GPL
73Group: Applications/Emulators
74Requires: %{name}-common = %{version}-%{release}
75
76%description x11
77This is Atari 800, 800XL, 130XE and 5200 emulator.
78
79This package contains Atari800 executable file configured for X11 with
80OSS sound and joystick support.
81
82%description x11 -l pl.UTF-8
83To jest emulator Atari 800, 800XL, 130XE i 5200.
84
85Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla X11 z
86obsługą dźwięku OSS i joysticka.
87
88%package SDL
89Summary: Atari 800 Emulator - SDL version
90Summary(pl.UTF-8): Emulator Atari 800 - wersja SDL
91License: GPL
92Group: Applications/Emulators
93Requires: %{name}-common = %{version}-%{release}
94Obsoletes: Atari800-svga
95
96%description SDL
97This is Atari 800, 800XL, 130XE and 5200 emulator.
98
99This package contains Atari800 executable file configured for SDL with
100sound and joystick support.
101
102%description SDL -l pl.UTF-8
103To jest emulator Atari 800, 800XL, 130XE i 5200.
104
105Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla SDL z
106obsługą dźwięku i joysticka.
107
108%prep
109%setup -q -n atari800-%{version}
110
111%build
112cp -f /usr/share/automake/config.sub .
113
114%configure \
115 --target=default \
116 --enable-crashmenu \
117 --disable-silent-rules \
118 --disable-stereosound \
119 --with-sound=sdl \
120 --with-video=sdl
121
122%{__make}
123
124%{__mv} src/atari800 atari800-SDL
125
126%{__make} clean
127
128%configure \
129 --target=x11-shm \
130 --enable-crashmenu \
131 --disable-silent-rules \
132 --disable-stereosound \
133 --with-sound=oss \
134 --with-video=yes
135
136%{__make}
137
138%{__mv} src/atari800 atari800-x11
139
140%install
141rm -rf $RPM_BUILD_ROOT
142install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/atari800,%{_mandir}/man1}
143
144install atari800-x11 $RPM_BUILD_ROOT%{_bindir}
145install atari800-SDL $RPM_BUILD_ROOT%{_bindir}
146cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
147cp -p src/atari800.man $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
148
149%if %{with license_agreement}
150unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
151%{__rm} $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
152%else
153install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
154%endif
155
156%clean
157rm -rf $RPM_BUILD_ROOT
158
159%if %{without license_agreement}
160%post common
161cd %{_datadir}/atari800
162if [ "`echo *.rom`" = "*.rom" ]; then
163 umask 022
164 unzip -q -L xf25.zip
165 rm -f xf25.doc xf25.exe
166fi
167%endif
168
169%files common
170%defattr(644,root,root,755)
171%doc DOC/{BUGS,CREDITS,ChangeLog,FAQ,NEWS,README,TODO,USAGE,*.txt} README.TXT
172%attr(755,root,root) %{_bindir}/atari800
173%{_datadir}/atari800
174%{_mandir}/man1/atari800.1*
175
176%files x11
177%defattr(644,root,root,755)
178%attr(755,root,root) %{_bindir}/atari800-x11
179
180%files SDL
181%defattr(644,root,root,755)
182%attr(755,root,root) %{_bindir}/atari800-SDL
This page took 0.026123 seconds and 4 git commands to generate.