]> git.pld-linux.org Git - packages/apache1-mod_auth_any.git/blame - apache1-mod_auth_any.spec
- tabs in preamble
[packages/apache1-mod_auth_any.git] / apache1-mod_auth_any.spec
CommitLineData
7baf28c3 1%define mod_name auth_any
2%define apxs /usr/sbin/apxs1
fa915c0a 3Summary: Basic authentication for the Apache Web server using arbitrary shell commands
8fa8c4b3
ER
4Summary(cs.UTF-8): Základní autentizace pro WWW server Apache pomocí shellových příkazů
5Summary(da.UTF-8): En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
6Summary(de.UTF-8): Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
7Summary(fr.UTF-8): Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
8Summary(it.UTF-8): Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
9Summary(nb.UTF-8): En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
10Summary(pl.UTF-8): Podstawowy moduł uwierzytelnienia dla Apache, używający poleceń powłoki
11Summary(pt.UTF-8): Um módulo de autenticação de LDAP para o servidor Web Apache
12Summary(sl.UTF-8): Osnovna avtentikacija za spletni strežnik Apache, z uporabo poljubnih lupinskih ukazov
13Summary(sv.UTF-8): Grundläggande autentisering för webbservern Apache med valfria skalkommandon
7baf28c3 14Name: apache1-mod_%{mod_name}
3ea6bdc7 15Version: 1.5
5d640d07 16Release: 2
7baf28c3 17Epoch: 1
3c603230 18License: BSD
2cb4d35a 19Group: Networking/Daemons
7baf28c3 20Source0: http://www.itlab.musc.edu/webNIS/dist/mod_%{mod_name}-%{version}.tar.gz
3ea6bdc7 21# Source0-md5: a78780db253dd2dc33138f8b644423d2
7baf28c3 22URL: http://www.itlab.musc.edu/webNIS/mod_auth_any.html
c5543b7a 23BuildRequires: %{apxs}
d32efb92 24BuildRequires: apache1-devel >= 1.3.33-2
9533ffd9 25BuildRequires: rpmbuild(macros) >= 1.268
d32efb92 26Requires(triggerpostun): %{apxs}
5d640d07 27Requires: apache1(EAPI)
9533ffd9 28Obsoletes: apache-mod_auth_any <= 1:1.5
2cb4d35a 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
d32efb92
ER
31%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
32%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
2cb4d35a 33
34%description
bc29d277
JB
35This module allows you to use any command line program (such as
36webNIS) to authenticate a user.
37
6bb4b356
JR
38%description -l cs.UTF-8
39Balíček mod_auth_any slouží pro omezení přístupu k dokumentům, které
40poskytuje WWW server Apache. Jména a hesla jsou kontrolována pomocí
41jakéhokoliv příkazu (jeho návratovým kódem).
fa915c0a 42
6bb4b356 43%description -l de.UTF-8
fa915c0a 44Mod_auth_any kann verwendet werden, um den Zugriff auf von einem Web-
6bb4b356
JR
45Server bediente Dokumente zu beschränken, indem es den Rückcode eines
46gegebenen arbiträren Befehls prüft.
fa915c0a 47
6bb4b356 48%description -l es.UTF-8
fa915c0a 49Mod_auth_any puede usarse para limitar el acceso a documentos servidos
6bb4b356 50desde un servidor web verificando el código de retorno de un comando
fa915c0a 51arbitrario especificado.
52
6bb4b356
JR
53%description -l fr.UTF-8
54Mod_auth_any peut être utilisé pour limiter l'accès à des documents
55servis par un serveur Web en vérifiant le code de retour d'une
56commande spécifiée arbitraire.
fa915c0a 57
6bb4b356
JR
58%description -l it.UTF-8
59Mod_auth_any può essere utilizzato per limitare l'accesso ai documenti
fa915c0a 60serviti da un server Web controllando il codice di ritorno di un dato
61comando arbitrario.
62
6bb4b356
JR
63%description -l ja.UTF-8
64Mod_auth_any は任意に指定されたコマンドの戻りコードをチェックすること
65によって、Web サーバーが提供するドキュメントへのアクセスを制限すること
66ができます。
fa915c0a 67
6bb4b356
JR
68%description -l pl.UTF-8
69Ten moduł pozwala na użycie dowolnego programu działającego z linii
70poleceń (jak np. webNIS) do uwierzytelniania użytkownika.
2cb4d35a 71
6bb4b356
JR
72%description -l sv.UTF-8
73Mod_auth_any kan användas för att begränsa åtkomsten till dokument
74servade av en webbserver genom att kontrollera returkoden från ett
fa915c0a 75godtyckligt angivet kommando.
76
77%prep
7d35ef11 78%setup -q -n mod_%{mod_name}
6979abf2 79
2cb4d35a 80%build
c5543b7a 81%{apxs} -c src/mod_%{mod_name}.c -o mod_%{mod_name}.so
2cb4d35a 82
83%install
84rm -rf $RPM_BUILD_ROOT
d32efb92 85install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
2cb4d35a 86
87install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
d32efb92
ER
88echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
89 $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
bc29d277 90
bc29d277
JB
91%clean
92rm -rf $RPM_BUILD_ROOT
93
2cb4d35a 94%post
9533ffd9 95%service -q apache restart
2cb4d35a 96
c583b095 97%postun
2cb4d35a 98if [ "$1" = "0" ]; then
9533ffd9 99 %service -q apache restart
2cb4d35a 100fi
101
d32efb92
ER
102%triggerpostun -- apache1-mod_%{mod_name} < 1:1.4-1.1
103# check that they're not using old apache.conf
104if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
105 %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
106fi
107
2cb4d35a 108%files
109%defattr(644,root,root,755)
ed51419d 110%doc docs/*
61b24664 111%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
2cb4d35a 112%attr(755,root,root) %{_pkglibdir}/*
This page took 0.078271 seconds and 4 git commands to generate.