]> git.pld-linux.org Git - packages/OpenAL.git/blame - OpenAL.spec
- updated to 1.16.0
[packages/OpenAL.git] / OpenAL.spec
CommitLineData
68071dbf 1#
a35955a2 2# Conditional build:
f2c99d8a
JB
3%bcond_without alsa # ALSA backend
4%bcond_without fluidsynth # FluidSynth MIDI support
5%bcond_without portaudio # PortAudio backend
6%bcond_without pulseaudio # PulseAudio backend
7%bcond_without gui # alsoft-config GUI
a26f1dac 8#
d451b59a 9Summary: Open Audio Library
8be14136 10Summary(pl.UTF-8): Otwarta Biblioteka Dźwięku
6a3db3d8 11Name: OpenAL
f2c99d8a
JB
12Version: 1.16.0
13Release: 1
65437b48 14License: LGPL v2+
68071dbf 15Group: Libraries
7e80d8dd 16Source0: http://kcat.strangesoft.net/openal-releases/openal-soft-%{version}.tar.bz2
f2c99d8a 17# Source0-md5: 14db4b0d12f07252070b4fe5eb5911f6
7e80d8dd 18#URL: http://kcat.strangesoft.net/openal.html
827050d4 19URL: http://www.openal.org/
e62907a5 20%{?with_alsa:BuildRequires: alsa-lib-devel}
f2c99d8a
JB
21BuildRequires: cmake >= 2.6
22%{?with_fluidsynth:BuildRequires: fluidsynth-devel}
89d1fa49 23BuildRequires: pkgconfig
7e80d8dd 24%{?with_portaudio:BuildRequires: portaudio-devel}
f953b352 25%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f2c99d8a
JB
26%if %{with gui}
27BuildRequires: QtCore-devel >= 4.8.0
28BuildRequires: QtGui-devel >= 4.8.0
29BuildRequires: qt4-build >= 4.8.0
30%endif
6a3db3d8 31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
6a3db3d8 33%description
34OpenAL, the Open Audio Library, is a joint effort to create an open,
35vendor-neutral, cross-platform API for interactive, primarily
36spatialized audio. OpenAL's primary audience are application
37developers and desktop users that rely on portable standards like
38OpenGL, for games and other multimedia applications. OpenAL is already
39supported by a number of hardware vendors and developers.
40
a4959810
JR
41%description -l pl.UTF-8
42OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
43stworzenia otwartego, niezależnego od producentów, międzyplatformowego
44interfejsu projektowania aplikacji w części obsługi dźwięku.
45Biblioteka adresowana jest do twórców aplikacji i użytkowników,
46którzy wybierają przenośne standardy, jak OpenGL, w grach i
47aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
48dostarczycieli sprzętu i programistów.
d451b59a 49
6a3db3d8 50%package devel
d451b59a 51Summary: Headers for OpenAL
8be14136 52Summary(pl.UTF-8): Pliki nagłówkowe do OpenAL
68071dbf 53Group: Development/Libraries
e62907a5 54Requires: %{name} = %{version}-%{release}
6a3db3d8 55
56%description devel
d451b59a 57Header files for OpenAL-based programs.
6a3db3d8 58
a4959810
JR
59%description devel -l pl.UTF-8
60Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
d451b59a 61OpenAL.
62
f2c99d8a
JB
63%package gui
64Summary: OpenAL configuration GUI
65Summary(pl.UTF-8): Graficzny interfejs do konfiguracji biblioteki OpenAL
66Group: X11/Applications/Sound
67Requires: %{name} = %{version}-%{release}
68Requires: QtCore >= 4.8.0
69Requires: QtGui >= 4.8.0
70
71%description gui
72OpenAL configuration GUI.
73
74%description gui -l pl.UTF-8
75Graficzny interfejs do konfiguracji biblioteki OpenAL.
76
6a3db3d8 77%prep
7e80d8dd 78%setup -q -n openal-soft-%{version}
68071dbf 79
6a3db3d8 80%build
65437b48 81%cmake . \
f2c99d8a
JB
82 %{!?with_fluidsynth:-DALSOFT_MIDI_FLUIDSYNTH=ON} \
83 %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
7e80d8dd 84 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
65437b48 85 -DCMAKE_VERBOSE_MAKEFILE=1 \
ce19b7ae 86 -DEXAMPLES=OFF \
f953b352
JB
87 -DLIB_INSTALL_DIR=%{_lib} \
88 %{!?with_alsa:-DALSA=OFF} \
89 %{!?with_portaudio:-DPORTAUDIO=OFF} \
90 %{!?with_pulseaudio:-DPULSEAUDIO=OFF}
65437b48 91
7e80d8dd 92%{__make}
6a3db3d8 93
94%install
95rm -rf $RPM_BUILD_ROOT
6ce9e958 96install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
d451b59a 97
f2c02821 98%{__make} install \
68071dbf 99 DESTDIR=$RPM_BUILD_ROOT
d451b59a 100
c06f4ed0 101install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
6ce9e958 102
6a3db3d8 103%clean
104rm -rf $RPM_BUILD_ROOT
105
404a1bc6
JB
106%post -p /sbin/ldconfig
107%postun -p /sbin/ldconfig
108
6a3db3d8 109%files
3f81b215 110%defattr(644,root,root,755)
6ce9e958 111%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
ce19b7ae 112%attr(755,root,root) %{_bindir}/makehrtf
65437b48 113%attr(755,root,root) %{_bindir}/openal-info
a26f1dac 114%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
65437b48 115%attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
f2c99d8a 116%{_datadir}/openal
6a3db3d8 117
118%files devel
119%defattr(644,root,root,755)
a26f1dac 120%attr(755,root,root) %{_libdir}/libopenal.so
68071dbf 121%{_includedir}/AL
a26f1dac 122%{_pkgconfigdir}/openal.pc
f2c99d8a
JB
123
124%if %{with gui}
125%files gui
126%defattr(644,root,root,755)
127%attr(755,root,root) %{_bindir}/alsoft-config
128%endif
This page took 0.372895 seconds and 4 git commands to generate.