]> git.pld-linux.org Git - packages/MagickWandForPHP.git/blame - MagickWandForPHP.spec
- initial
[packages/MagickWandForPHP.git] / MagickWandForPHP.spec
CommitLineData
cd91de18
PG
1Summary: MagickWand ImageMagick API for PHP
2Name: MagickWandForPHP
3Version: 1.0.5
4Release: 0.1
5License: GPL
6Group: Libraries
7Source0: http://www.magickwand.org/download/php/%{name}-%{version}.tar.bz2
8# Source0-md5: b52a5b7cf4db7078fa3db4cb6e55ecf4
9Source1: %{_name}.ini
10URL: http://eaccelerator.net/
11BuildRequires: ImageMagick-devel
12#BuildRequires: ImageMagick-devel >= 6.3.5.9
13BuildRequires: php-devel >= 3:5.0.0
14BuildRequires: rpmbuild(macros) >= 1.344
15%requires_eq php-common
16%{?requires_php_extension}
17Requires: php-common >= 4:5.0.4
18#Requires: php-zlib
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%define _webapps /etc/webapps
22%define _webapp %{_name}
23%define _sysconfdir %{_webapps}/%{_webapp}
24%define _appdir %{_datadir}/%{_webapp}
25
26%description
27The MagickWand API is the recommended interface between the C programming
28language and the ImageMagick image processing libraries. Unlike the
29MagickCore C API, MagickWand uses only a few opaque types. Accessors are
30available to set or get important wand properties.
31
32%prep
33%setup -q
34
35%build
36phpize
37%configure \
38 --with-php-config=%{_bindir}/php-config
39
40%{__make}
41
42%install
43rm -rf $RPM_BUILD_ROOT
44#install -d $RPM_BUILD_ROOT{%{php_extensiondir},%{_bindir},%{php_sysconfdir}/conf.d,%{_sysconfdir},%{_appdir}}
45
46#install modules/eaccelerator.so $RPM_BUILD_ROOT%{php_extensiondir}
47#install eLoader/modules/eloader.so $RPM_BUILD_ROOT%{php_extensiondir}
48#install %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_name}.ini
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%post
54%php_webserver_restart
55
56%postun
57if [ "$1" = 0 ]; then
58 %php_webserver_restart
59fi
60
61%files
62%defattr(644,root,root,755)
63#%doc AUTHORS ChangeLog NEWS README README.eLoader bugreport.php doc/php
64#%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_name}.ini
65#%attr(755,root,root) %{php_extensiondir}/eaccelerator.so
66#%attr(755,root,root) %{php_extensiondir}/eloader.so
This page took 0.04114 seconds and 4 git commands to generate.