summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorundefine2003-08-16 09:26:25 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit377f2a883037b043666c9da722cd47aa83f2c38f (patch)
tree02f96c59c41347ad641b05e996e96c04f5ed5c9c
downloadusage-377f2a883037b043666c9da722cd47aa83f2c38f.zip
usage-377f2a883037b043666c9da722cd47aa83f2c38f.tar.gz
- initial pld version. i'm not sure if we can redistribute it. when we change
it, we need send changes to author. Changed files: usage.spec -> 1.1
-rw-r--r--usage.spec49
1 files changed, 49 insertions, 0 deletions
diff --git a/usage.spec b/usage.spec
new file mode 100644
index 0000000..5b77872
--- /dev/null
+++ b/usage.spec
@@ -0,0 +1,49 @@
+Summary: Set of programs to see which routines in a c-project are used
+Summary(pl): Zestaw programów do monitorowania wykorzystywanych funkcji w c
+Name: usage
+Version: 1.0
+Release: 1
+License: improve-ware
+Group: Development/Languages
+Source0: http://members.lycos.nl/dpruimboom/%{name}.zip
+# Source0-md5: 6318e9bc869d551686ccab0d09fb3667
+BuildRequires: flex
+URL: http://members.lycos.nl/dpruimboom/
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This set of programs consist of 'usage' that can be used to see which
+routines in a c-project are used and how often and what other routines
+they call. Then there is the CallTree program, this program uses
+output of the 'usage' program to make a call-tree of the c-project.
+
+%description -l pl
+Zestaw programów służących do monitorowania które funkcje w programach
+C są używane i jak często inne funkcje je wywołują. Jest też program
+CallTree, wykorzystujący wyjście z usage do stworzenia drzewa wywołań
+w projekcie c.
+
+%prep
+%setup -q -n %{name}
+
+%build
+flex %{name}.lex
+%{__cc} %{rpmcflags} -o %{name} lex.yy.c sys_nodelib.c -lfl
+cd call_tree
+%{__cc} %{rpmcflags} -o CallTree sys_nodelib.c CallTree.c
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}}
+
+install %{name} call_tree/CallTree $RPM_BUILD_ROOT%{_bindir}
+install %{name}.lst $RPM_BUILD_ROOT%{_sysconfdir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/*
+%verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/%{name}.lst
+%doc Readme