summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2017-11-17 19:37:44 (GMT)
committerJakub Bogusz2017-11-17 19:37:44 (GMT)
commitbef88e35c3002a75d7e756f6a729e7ff25d1db84 (patch)
tree0a98add2dd002f98204a773b86830bab60ded972
parent50af910adcbe9323fbca0661b0bc457761b1ef22 (diff)
downloadprotobuf-auto/th/protobuf-3.5.0-1.zip
protobuf-auto/th/protobuf-3.5.0-1.tar.gz
- updated to 3.5.0 (note: new sonames)auto/th/protobuf-3.5.0-1
- updated system-gtest patch - removed obsolete fix-macro-redefinitions patch
-rw-r--r--protobuf.spec10
-rw-r--r--system-gtest.patch35
2 files changed, 17 insertions, 28 deletions
diff --git a/protobuf.spec b/protobuf.spec
index 13034bd..20578b1 100644
--- a/protobuf.spec
+++ b/protobuf.spec
@@ -16,13 +16,13 @@
Summary: Protocol Buffers - Google's data interchange format
Summary(pl.UTF-8): Protocol Buffers - format wymiany danych Google
Name: protobuf
-Version: 3.3.0
+Version: 3.5.0
Release: 1
License: BSD
Group: Libraries
#Source0Download: https://github.com/google/protobuf/releases
Source0: https://github.com/google/protobuf/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 10644296984c7cbdd1e8436e88b069d2
+# Source0-md5: d95db321e1a9901fffc51ed8994afd36
Source1: ftdetect-proto.vim
Patch0: system-gtest.patch
URL: https://github.com/google/protobuf/
@@ -292,17 +292,17 @@ rm -rf $RPM_BUILD_ROOT
%doc CHANGES.txt CONTRIBUTORS.txt LICENSE README.md
%attr(755,root,root) %{_bindir}/protoc
%attr(755,root,root) %{_libdir}/libprotoc.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libprotoc.so.13
+%attr(755,root,root) %ghost %{_libdir}/libprotoc.so.15
%files libs
%defattr(644,root,root,755)
%attr(755,root,root) %{_libdir}/libprotobuf.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.13
+%attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.15
%files lite
%defattr(644,root,root,755)
%attr(755,root,root) %{_libdir}/libprotobuf-lite.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libprotobuf-lite.so.13
+%attr(755,root,root) %ghost %{_libdir}/libprotobuf-lite.so.15
%files devel
%defattr(644,root,root,755)
diff --git a/system-gtest.patch b/system-gtest.patch
index 2d5f9ef..b51aa9f 100644
--- a/system-gtest.patch
+++ b/system-gtest.patch
@@ -1,6 +1,6 @@
---- protobuf-3.1.0/autogen.sh.orig 2016-12-29 21:02:59.643624708 +0100
-+++ protobuf-3.1.0/autogen.sh 2016-12-29 21:03:02.716958006 +0100
-@@ -27,21 +27,6 @@
+--- protobuf-3.5.0/autogen.sh.orig 2017-11-17 17:49:36.389442867 +0100
++++ protobuf-3.5.0/autogen.sh 2017-11-17 17:51:03.439441874 +0100
+@@ -27,23 +27,6 @@
exit 1
fi
@@ -12,7 +12,9 @@
- unzip -q release-1.7.0.zip
- rm release-1.7.0.zip
- mv googlemock-release-1.7.0 gmock
+-fi
-
+-if test ! -e gmock/gtest; then
- curl $curlopts -L -O https://github.com/google/googletest/archive/release-1.7.0.zip
- unzip -q release-1.7.0.zip
- rm release-1.7.0.zip
@@ -54,9 +56,9 @@
echo "Making clean in conformance"; \
cd conformance && $(MAKE) $(AM_MAKEFLAGS) clean; \
fi; \
---- protobuf-3.3.0/src/Makefile.am.orig 2017-04-27 01:32:21.000000000 +0200
-+++ protobuf-3.3.0/src/Makefile.am 2017-05-27 11:43:16.651910938 +0200
-@@ -744,15 +744,22 @@
+--- protobuf-3.5.0/src/Makefile.am.orig 2017-11-13 19:47:29.000000000 +0100
++++ protobuf-3.5.0/src/Makefile.am 2017-11-17 17:49:36.389442867 +0100
+@@ -756,15 +756,22 @@
google/protobuf/testing/file.cc \
google/protobuf/testing/file.h
@@ -84,7 +86,7 @@
# Disable optimization for tests unless the user explicitly asked for it,
# since test_util.cc takes forever to compile with optimization (with GCC).
# See configure.ac for more info.
-@@ -837,11 +844,11 @@
+@@ -853,11 +860,11 @@
# Run cpp_unittest again with PROTOBUF_TEST_NO_DESCRIPTORS defined.
protobuf_lazy_descriptor_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la \
libprotoc.la \
@@ -101,7 +103,7 @@
-DPROTOBUF_TEST_NO_DESCRIPTORS
protobuf_lazy_descriptor_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
protobuf_lazy_descriptor_test_SOURCES = \
-@@ -862,9 +869,9 @@
+@@ -878,9 +885,9 @@
# full runtime and we want to make sure this test builds without full
# runtime.
protobuf_lite_test_LDADD = $(PTHREAD_LIBS) libprotobuf-lite.la \
@@ -114,7 +116,7 @@
protobuf_lite_test_CPPFLAGS= -I$(srcdir)/../gmock/include \
-I$(srcdir)/../gmock/gtest/include
protobuf_lite_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
-@@ -877,11 +884,11 @@
+@@ -893,11 +900,11 @@
# gtest when building the test internally our memory sanitizer doesn't detect
# memory leaks (don't know why).
protobuf_lite_arena_test_LDADD = $(PTHREAD_LIBS) libprotobuf-lite.la \
@@ -131,7 +133,7 @@
protobuf_lite_arena_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
protobuf_lite_arena_test_SOURCES = \
google/protobuf/lite_arena_unittest.cc \
-@@ -890,8 +897,8 @@
+@@ -906,8 +913,8 @@
# Test plugin binary.
test_plugin_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la \
@@ -142,16 +144,3 @@
test_plugin_SOURCES = \
google/protobuf/compiler/mock_code_generator.cc \
google/protobuf/testing/file.cc \
-@@ -920,9 +927,9 @@
- echo "TEST(NoWarningTest, Empty) {}" >> no_warning_test.cc
-
- no_warning_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la \
-- ../gmock/gtest/lib/libgtest.la \
-- ../gmock/gtest/lib/libgtest_main.la
--no_warning_test_CPPFLAGS = -I$(srcdir)/../gmock/gtest/include
-+ -lgtest \
-+ -lgtest_main
-+no_warning_test_CPPFLAGS = -I$(gtest_inc_dir)
- no_warning_test_CXXFLAGS = $(PTHREAD_CFLAGS) $(PTHREAD_DEF) $(ZLIB_DEF) \
- -Wall -Werror
- nodist_no_warning_test_SOURCES = no_warning_test.cc $(protoc_outputs)