summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2020-09-08 19:36:03 (GMT)
committerJakub Bogusz2020-09-08 19:36:03 (GMT)
commitbb7e48c9d5b1386bc5b2aa2f6814f028951deb67 (patch)
treeebff798cecd66f842acd07f7e0ba5d75de31dd70
parentd2d2012569428d08ea6090d1f52827ea7e5b635b (diff)
downloadprotobuf-auto/th/protobuf-3.13.0-2.zip
protobuf-auto/th/protobuf-3.13.0-2.tar.gz
- added no-wheel patch (don't require wheel module when not creating wheels); release 2auto/th/protobuf-3.13.0-2
-rw-r--r--protobuf-no-wheel.patch10
-rw-r--r--protobuf.spec8
2 files changed, 15 insertions, 3 deletions
diff --git a/protobuf-no-wheel.patch b/protobuf-no-wheel.patch
new file mode 100644
index 0000000..4b9a288
--- /dev/null
+++ b/protobuf-no-wheel.patch
@@ -0,0 +1,10 @@
+--- protobuf-3.13.0/python/setup.py.orig 2020-08-15 01:24:06.000000000 +0200
++++ protobuf-3.13.0/python/setup.py 2020-09-08 21:07:02.277138265 +0200
+@@ -279,7 +279,6 @@
+ 'build_py': build_py,
+ 'test_conformance': test_conformance,
+ },
+- setup_requires = ['wheel'],
+ install_requires=install_requires,
+ ext_modules=ext_module_list,
+ )
diff --git a/protobuf.spec b/protobuf.spec
index 9f19837..35b4ef5 100644
--- a/protobuf.spec
+++ b/protobuf.spec
@@ -13,7 +13,7 @@ Summary: Protocol Buffers - Google's data interchange format
Summary(pl.UTF-8): Protocol Buffers - format wymiany danych Google
Name: protobuf
Version: 3.13.0
-Release: 1
+Release: 2
License: BSD
Group: Libraries
#Source0Download: https://github.com/google/protobuf/releases
@@ -22,6 +22,7 @@ Source0: https://github.com/google/protobuf/releases/download/v%{version}/%{name
Source1: ftdetect-proto.vim
Patch0: system-gtest.patch
Patch1: no-wrap-memcpy.patch
+Patch2: %{name}-no-wheel.patch
URL: https://github.com/google/protobuf/
BuildRequires: autoconf >= 2.59
BuildRequires: automake >= 1:1.9
@@ -31,7 +32,7 @@ BuildRequires: libstdc++-devel >= 6:4.7
BuildRequires: libtool
BuildRequires: pkgconfig
%if %{with python2}
-BuildRequires: python-modules >= 1:2.6
+BuildRequires: python-modules >= 1:2.7
BuildRequires: python-setuptools
%endif
%if %{with python3}
@@ -154,7 +155,7 @@ Statyczne biblioteki buforów protokołowych (Protocol Buffers).
Summary: Python 2 bindings for Protocol Buffers
Summary(pl.UTF-8): Wiązania Pythona 2 do buforów protokołowych (Protocol Buffers)
Group: Development/Languages/Python
-Requires: python-modules >= 1:2.6
+Requires: python-modules >= 1:2.7
# does not use C++ library at this time
%description -n python-protobuf
@@ -206,6 +207,7 @@ opisów buforów protokołowych (Protocol Buffers).
%setup -q
%patch0 -p1
%patch1 -p1
+%patch2 -p1
%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
examples/add_person.py \