summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--poldek-cap_match_req-fix.patch17
-rw-r--r--poldek-deprecated.patch86
-rw-r--r--poldek-desc_in_utf8.patch70
-rw-r--r--poldek-dirdeps.patch106
-rw-r--r--poldek-etc_dir.patch127
-rw-r--r--poldek-fix-multilib.patch49
-rw-r--r--poldek-gcc34.patch12
-rw-r--r--poldek-gcc4.patch33
-rw-r--r--poldek-ignorecaps.patch12
-rw-r--r--poldek-retr_term.patch50
-rw-r--r--poldek-su-sigsev.patch109
-rw-r--r--poldek-types.patch101
-rw-r--r--poldek-uninstall-depfix.patch174
-rw-r--r--poldek.spec17
14 files changed, 23 insertions, 940 deletions
diff --git a/poldek-cap_match_req-fix.patch b/poldek-cap_match_req-fix.patch
deleted file mode 100644
index d8358c0..0000000
--- a/poldek-cap_match_req-fix.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: pkg.c
-===================================================================
-RCS file: /cvsroot/installer/poldek/pkg.c,v
-retrieving revision 1.51.4.2
-diff -u -r1.51.4.2 pkg.c
---- pkg.c 30 Dec 2003 18:19:52 -0000 1.51.4.2
-+++ pkg.c 19 Feb 2004 00:18:18 -0000
-@@ -717,6 +717,9 @@
- if ((strcmp(capreq_name(cap), capreq_name(req))) != 0)
- return 0;
-
-+ if (!capreq_versioned(req))
-+ return 1;
-+
- if (capreq_has_epoch(cap)) {
- if (!capreq_has_epoch(req) && poldek_conf_promote_epoch) {
- if (verbose > 1)
diff --git a/poldek-deprecated.patch b/poldek-deprecated.patch
deleted file mode 100644
index 24fea11..0000000
--- a/poldek-deprecated.patch
+++ /dev/null
@@ -1,86 +0,0 @@
---- poldek-0.20.1-cvs20060823.21/pm/rpm/misc.c~ 2006-07-10 13:17:36.000000000 +0200
-+++ poldek-0.20.1-cvs20060823.21/pm/rpm/misc.c 2006-10-30 16:19:12.548718000 +0100
-@@ -171,24 +171,25 @@
-
- int pm_rpm_machine_score(void *pm_rpm, int tag, const char *val)
- {
-- int rpmtag = 0;
--
- pm_rpm = pm_rpm;
- switch (tag) {
- case PMMSTAG_ARCH:
-- rpmtag = RPM_MACHTABLE_INSTARCH;
-+ return 1;
-+ // no longer supported, decided it was
-+ // not reliable enough
- break;
-
- case PMMSTAG_OS:
-- rpmtag = RPM_MACHTABLE_INSTOS;
-+ return 1;
-+ // no longer supported, always returned 1
-+ // as linux is the only ARCH supported
- break;
-
- default:
- n_assert(0);
- break;
- }
--
-- return rpmMachineScore(rpmtag, val);
-+ return 0;
- }
-
-
-@@ -197,6 +196,6 @@
- if (arch == NULL)
- return 0;
-
-- return rpmMachineScore(RPM_MACHTABLE_INSTARCH, arch);
-+ return 1;
- }
-
---- poldek-0.20.1-cvs20060823.21/configure.in~ 2006-08-21 13:20:12.000000000 +0200
-+++ poldek-0.20.1-cvs20060823.21/configure.in 2006-10-30 16:17:00.008718000 +0100
-@@ -273,7 +273,7 @@
- [$DBLIB -lrpmdb]),
- [$DBLIB])
-
--AC_CHECK_FUNCS(rpmMachineScore,,[ AC_MSG_ERROR(["rpmlib not found"])])
-+#AC_CHECK_FUNCS(rpmMachineScore,,[ AC_MSG_ERROR(["rpmlib not found"])])
- AC_CHECK_FUNCS(rpmlog rpmCheckSig rpmVerifySignature)
-
- dnl rpm 4.2?
---- poldek-0.20.1-cvs20060823.21/pm/rpm/rpm.c~ 2006-08-22 16:53:28.000000000 +0200
-+++ poldek-0.20.1-cvs20060823.21/pm/rpm/rpm.c 2006-11-02 21:10:17.138247000 +0100
-@@ -402,7 +402,7 @@
- #endif /* HAVE_RPMLOG */
-
-
--extern int rpmvercmp(const char *one, const char *two);
-+extern int (*rpmvercmp)(const char *one, const char *two);
- int pm_rpm_vercmp(const char *one, const char *two)
- {
- return rpmvercmp(one, two);
---- poldek-0.20.1-cvs20060823.21/pm/rpm/rpmvercmp.c~ 2004-08-09 01:03:54.000000000 +0200
-+++ poldek-0.20.1-cvs20060823.21/pm/rpm/rpmvercmp.c 2006-11-02 21:15:35.218247000 +0100
-@@ -5,7 +5,7 @@
-
- #include "i18n.h"
-
--extern int rpmvercmp(const char * one, const char * two);
-+extern int (*rpmvercmp)(const char * one, const char * two);
-
-
- int main(int argc, char *argv[])
---- poldek-0.20.1-cvs20060823.21/pm/rpm/misc.c~ 2006-11-02 21:17:09.000000000 +0100
-+++ poldek-0.20.1-cvs20060823.21/pm/rpm/misc.c 2006-11-02 21:39:35.168247000 +0100
-@@ -166,7 +166,7 @@
- const char *pm_rpm_get_arch(void *pm_rpm)
- {
- pm_rpm = pm_rpm;
-- return rpmGetVar(RPM_MACHTABLE_INSTARCH);
-+ return rpmExpand("%{_target_cpu}", NULL);
- }
-
- int pm_rpm_machine_score(void *pm_rpm, int tag, const char *val)
diff --git a/poldek-desc_in_utf8.patch b/poldek-desc_in_utf8.patch
deleted file mode 100644
index 6390132..0000000
--- a/poldek-desc_in_utf8.patch
+++ /dev/null
@@ -1,70 +0,0 @@
---- poldek-0.20.1-cvs20070108.22/pkgdir/pndir/description.c.stare 2007-05-29 22:39:55.000000000 +0200
-+++ poldek-0.20.1-cvs20070108.22/pkgdir/pndir/description.c 2007-05-30 15:11:58.000000000 +0200
-@@ -166,6 +166,7 @@
- for (i = n_array_size(langs) - 1; i >= 0; i--) {
- struct tndb *db;
- const char *lang;
-+ char lang_utf8[24];
- char dkey[512];
- int dklen;
-
-@@ -176,6 +177,19 @@
- if ((db = pndir_db_dscr_h_get(db_dscr_h, lang)) == NULL)
- continue;
-
-+ snprintf(lang_utf8, sizeof(lang_utf8), "%s.UTF-8", lang);
-+
-+ dklen = n_snprintf(dkey, sizeof(dkey), "%s%s", key, lang_utf8);
-+ vlen = tndb_get(db, dkey, dklen, val, sizeof(val));
-+ DBGF("ld %s: %s (%d)\n", pkg_snprintf_s(pkg), lang_utf8, vlen);
-+ if (vlen > 0) {
-+ tn_buf_it it;
-+ n_buf_clean(nbuf);
-+ n_buf_init(nbuf, val, vlen);
-+ n_buf_it_init(&it, nbuf);
-+ pkguinf_restore_i18n(pkgu, &it, lang_utf8);
-+ }
-+
- dklen = n_snprintf(dkey, sizeof(dkey), "%s%s", key, lang);
- vlen = tndb_get(db, dkey, dklen, val, sizeof(val));
- DBGF("ld %s: %s (%d)\n", pkg_snprintf_s(pkg), lang, vlen);
---- poldek-0.20.1-cvs20070108.22/pkgu.c.stare 2007-05-29 21:40:39.000000000 +0200
-+++ poldek-0.20.1-cvs20070108.22/pkgu.c 2007-05-30 16:37:16.000000000 +0200
-@@ -15,6 +15,8 @@
- */
-
- #include <ctype.h>
-+#include <iconv.h>
-+#include <langinfo.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-@@ -576,7 +576,27 @@
- return 0;
- description = n_buf_it_getz(it, &dlen);
-
-- inf = pkguinf_i18n_new(pkgu->_na, summary, description);
-+ if (strstr(lang, "UTF-8")) {
-+ iconv_t cd;
-+ size_t u_slen = slen, u_dlen = dlen;
-+ char *new_s, *new_d;
-+ char *summary_utf8 = n_malloc(u_slen + 1);
-+ char *description_utf8 = n_malloc(u_dlen + 1);
-+
-+ new_s = summary_utf8;
-+ new_d = description_utf8;
-+ cd = iconv_open(nl_langinfo(CODESET), "UTF-8");
-+ iconv(cd, &summary, &slen, &new_s, &u_slen);
-+ iconv(cd, &description, &dlen, &new_d, &u_dlen);
-+ iconv_close(cd);
-+ *new_s = '\0';
-+ *new_d = '\0';
-+ inf = pkguinf_i18n_new(pkgu->_na, summary_utf8, description_utf8);
-+ n_free(summary_utf8);
-+ n_free(description_utf8);
-+ } else {
-+ inf = pkguinf_i18n_new(pkgu->_na, summary, description);
-+ }
- n_hash_insert(pkgu->_ht, lang, inf);
-
- pkgu->summary = inf->summary;
diff --git a/poldek-dirdeps.patch b/poldek-dirdeps.patch
index 7922f80..b099396 100644
--- a/poldek-dirdeps.patch
+++ b/poldek-dirdeps.patch
@@ -1,87 +1,23 @@
---- poldek-0.21-cvs20070703.00/doc/poldek.conf.xml~ 2007-06-30 10:32:47.000000000 +0300
-+++ poldek-0.21-cvs20070703.00/doc/poldek.conf.xml 2008-01-13 16:36:22.437311829 +0200
-@@ -414,8 +414,10 @@
- <option name="dependency engine version" type="integer" default="2" hidden="yes">
- </option>
-
-- <option name="auto directory dependencies" type="boolean3" default="auto" op="AUTODIRDEP">
-+ <option name="auto directory dependencies" type="boolean3" default="no" op="AUTODIRDEP">
-+ <description>
- RPM 4.4.6 introduces auto dependencies based on package directories. Option controls this feature.
-+ </description>
- </option>
-
- <option name="follow" type="boolean" default="yes" op="FOLLOW">
---- poldek/doc/Makefile.am~ 2005-11-06 23:00:58.000000000 +0200
-+++ poldek/doc/Makefile.am 2008-01-14 10:11:50.113470814 +0200
-@@ -8,7 +8,7 @@
+--- poldek-0.21-cvs20070703.00/conf/poldek.conf~ 2008-02-14 16:12:15.604671074 +0200
++++ poldek-0.21-cvs20070703.00/conf/poldek.conf 2008-02-14 16:13:12.373118918 +0200
+@@ -160,6 +160,9 @@
+ # Subtle dependency processing options, they should not be changed
+ # unless you know what you are doing
- # xml configuration description & co.
- CONFXMLS = poldek.conf.xml conf-xml2.sh \
-- conf-xml2conf.xsl conf-xml2refentry.xsl conf-xml2docb.xsl
-+ conf-xml2c.xsl conf-xml2conf.xsl conf-xml2refentry.xsl conf-xml2docb.xsl
-
- # manual sources
- MANUALS = manual.xml manual.css manual.xsl
---- /dev/null 2006-03-28 14:00:37.000000000 +0300
-+++ poldek/doc/conf-xml2c.xsl 2005-11-01 21:08:20.000000000 +0200
-@@ -0,0 +1,59 @@
-+<xsl:stylesheet version="1.0"
-+ xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
-+
-+<!-- poldek.conf.xml -> conf_sections.c -->
-+<!-- $Id$ -->
-+
-+<xsl:output method="text" indent="no" />
-+<xsl:template match="/">
-+/* This file is generated from poldek.conf.xml. Do not edit */
-+#include &lt;stdlib.h&gt;
-+#include "conf_intern.h"
-+#include "poldek_ts.h"
-+ <xsl:for-each select="config/confsection">
-+static struct poldek_conf_tag <xsl:value-of select="@name"/>_tags[] = {
-+ <xsl:for-each select="optiongroup">
-+ <xsl:for-each select="option">
-+ { "<xsl:value-of select="@name"/>",
-+ CONF_TYPE_<xsl:value-of select="translate(@type,'abcdefghijklmnopqrstuvwxyz','ABCDEFGHIJKLMNOPQRSTUVWXYZ')"/>
-+ <xsl:if test="@multiple='yes'"> | CONF_TYPE_F_MULTI</xsl:if>
-+ <xsl:if test="@required='yes'"> | CONF_TYPE_F_REQUIRED</xsl:if>
-+ <xsl:if test="@env='yes'"> | CONF_TYPE_F_ENV</xsl:if>
-+ <xsl:if test="@list='yes'"> | CONF_TYPE_F_LIST</xsl:if>
-+ <xsl:if test="@path='yes'"> | CONF_TYPE_F_PATH</xsl:if>
-+ <xsl:if test="@obsoleted='yes'"> | CONF_TYPE_F_OBSL</xsl:if>,
-+ <xsl:choose>
-+ <xsl:when test="string-length(@default) > 0">"<xsl:value-of select="@default"/>"</xsl:when>
-+ <xsl:otherwise>NULL</xsl:otherwise>
-+ </xsl:choose>,
-+ <xsl:choose>
-+ <xsl:when test="string-length(@op) > 0">POLDEK_OP_<xsl:value-of select="@op"/></xsl:when>
-+ <xsl:otherwise>0</xsl:otherwise>
-+ </xsl:choose>, { 0 } },
-+ <xsl:for-each select="alias">
-+ { "<xsl:value-of select="@name"/>", CONF_TYPE_F_ALIAS<xsl:if test="@obsoleted='yes'"> | CONF_TYPE_F_OBSL</xsl:if>, NULL, 0, { 0 } },
-+ </xsl:for-each>
-+
-+ </xsl:for-each>
-+ </xsl:for-each>
-+ { NULL, 0, NULL, 0, { 0 } }
-+};
-+
-+ </xsl:for-each>
-+
-+
-+struct poldek_conf_section poldek_conf_sections[] = {
-+ <xsl:for-each select="config/confsection">
-+ { "<xsl:value-of select="@name"/>", <xsl:value-of select="@name"/>_tags,
-+ <xsl:choose>
-+ <xsl:when test="@multiple='yes'">1</xsl:when>
-+ <xsl:otherwise>0</xsl:otherwise>
-+ </xsl:choose>,
-+ },
-+ </xsl:for-each>
-+ { NULL, 0, 0 }
-+};
-+
-+</xsl:template>
-+</xsl:stylesheet>
++# RPM 4.4.6 introduces auto dependencies based on package directories. Option controls this feature.
++auto directory dependencies = no
+
+ # Automatically install packages required by installed ones.
+ #follow = yes
+
+--- poldek-0.21-cvs20070703.00/conf_sections.c~ 2007-06-30 10:42:33.000000000 +0300
++++ poldek-0.21-cvs20070703.00/conf_sections.c 2008-02-15 05:00:16.039094830 +0200
+@@ -205,7 +205,7 @@
+
+ { "auto directory dependencies",
+ CONF_TYPE_BOOLEAN3,
+- "auto",
++ "no",
+ POLDEK_OP_AUTODIRDEP, { 0 } },
+
+ { "follow",
diff --git a/poldek-etc_dir.patch b/poldek-etc_dir.patch
deleted file mode 100644
index a4a13f3..0000000
--- a/poldek-etc_dir.patch
+++ /dev/null
@@ -1,127 +0,0 @@
-diff -Nru poldek-0.18.1/conf.c poldek-0.18.1.new/conf.c
---- poldek-0.18.1/conf.c Fri Oct 18 16:19:42 2002
-+++ poldek-0.18.1.new/conf.c Mon Mar 10 07:39:16 2003
-@@ -374,14 +374,23 @@
- tn_hash *ldconf_deafult(void)
- {
- char *homedir;
-+ char *etc_dir;
- char *etcpath = "/etc/poldek.conf";
-
-- if ((homedir = getenv("HOME")) != NULL) {
-+ if ((etc_dir = getenv("HOME_ETC")) != NULL) {
-+ char path[PATH_MAX];
-+
-+ snprintf(path, sizeof(path), "%s/.poldekrc", etc_dir);
-+ if (access(path, R_OK) == 0)
-+ return ldconf(path);
-+ } else {
-+ if ((homedir = getenv("HOME")) != NULL) {
- char path[PATH_MAX];
-
- snprintf(path, sizeof(path), "%s/.poldekrc", homedir);
- if (access(path, R_OK) == 0)
- return ldconf(path);
-+ }
- }
-
- if (access(etcpath, R_OK) == 0)
-diff -Nru poldek-0.18.1/pkgscore.c poldek-0.18.1.new/pkgscore.c
---- poldek-0.18.1/pkgscore.c Fri Nov 22 17:08:53 2002
-+++ poldek-0.18.1.new/pkgscore.c Mon Mar 10 07:44:02 2003
-@@ -40,26 +40,46 @@
-
- if (fpath == NULL) {
- char *homedir;
-+ char *etc_dir;
-
-- if ((homedir = getenv("HOME")) == NULL)
-+ if ((etc_dir = getenv("HOME_ETC")) != NULL) {
-+ switch (type) {
-+ case PKG_HELD:
-+ snprintf(path, sizeof(path), "%s/.poldek-hold", etc_dir);
-+ if (access(path, R_OK) != 0) /* backward compat */
-+ snprintf(path, sizeof(path), "%s/.poldek_hold", etc_dir);
-+
-+ break;
-+
-+ case PKG_IGNORED:
-+ snprintf(path, sizeof(path), "%s/.poldek-ignore", etc_dir);
-+ break;
-+
-+ default:
-+ n_assert(0);
-+ break;
-+ }
-+ } else {
-+ if ((homedir = getenv("HOME")) == NULL)
- return NULL;
-
-- switch (type) {
-- case PKG_HELD:
-- snprintf(path, sizeof(path), "%s/.poldek-hold", homedir);
-- if (access(path, R_OK) != 0) /* backward compat */
-+ switch (type) {
-+ case PKG_HELD:
-+ snprintf(path, sizeof(path), "%s/.poldek-hold", homedir);
-+ if (access(path, R_OK) != 0) /* backward compat */
- snprintf(path, sizeof(path), "%s/.poldek_hold", homedir);
--
-- break;
-+
-+ break;
-+
-+ case PKG_IGNORED:
-+ snprintf(path, sizeof(path), "%s/.poldek-ignore", homedir);
-+ break;
-
-- case PKG_IGNORED:
-- snprintf(path, sizeof(path), "%s/.poldek-ignore", homedir);
-- break;
--
-- default:
-- n_assert(0);
-- break;
-- }
-+ default:
-+ n_assert(0);
-+ break;
-+ }
-+ }
-
- if (access(path, R_OK) != 0)
- return patterns;
-diff -Nru poldek-0.18.1/shell/shell.c poldek-0.18.1.new/shell/shell.c
---- poldek-0.18.1/shell/shell.c Tue Oct 29 16:55:58 2002
-+++ poldek-0.18.1.new/shell/shell.c Mon Mar 10 07:50:21 2003
-@@ -1226,7 +1226,7 @@
-
- int shell_main(struct pkgset *ps, struct inst_s *inst, int skip_installed)
- {
-- char *line, *s, *home;
-+ char *line, *s, *home, *etc_dir;
-
-
- if (!isatty(fileno(stdout))) {
-@@ -1240,12 +1240,19 @@
- initialize_readline();
- histfile = NULL;
-
-- if ((home = getenv("HOME"))) {
-+ if ((etc_dir = getenv("HOME_ETC"))) {
-+ int len = strlen(etc_dir) + strlen("/.poldek_history") + 2;
-+ histfile = alloca(len);
-+ snprintf(histfile, len, "%s/.poldek_history", etc_dir);
-+ read_history(histfile);
-+ } else {
-+ if ((home = getenv("HOME"))) {
- int len = strlen(home) + strlen("/.poldek_history") + 2;
- histfile = alloca(len);
- snprintf(histfile, len, "%s/.poldek_history", home);
- read_history(histfile);
-- }
-+ }
-+ }
-
- sigint_init();
- sigint_reached_cb = sigint_reached_fn;
diff --git a/poldek-fix-multilib.patch b/poldek-fix-multilib.patch
deleted file mode 100644
index 52fa124..0000000
--- a/poldek-fix-multilib.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-Index: install/install.c
-===================================================================
-RCS file: /cvsroot/poldek/poldek/install/install.c,v
-retrieving revision 1.6
-retrieving revision 1.7
-diff -u -r1.6 -r1.7
---- install/install.c 17 Jun 2007 20:24:47 -0000 1.6
-+++ install/install.c 18 Jun 2007 16:12:43 -0000 1.7
-@@ -11,7 +11,7 @@
- */
-
- /*
-- $Id$
-+ $Id$
- */
-
- #include <vfile/vfile.h>
-@@ -315,7 +315,8 @@
- {
- struct pkg *pkg, *pkg2;
- int i, n, nmarked = 0;
--
-+ int multilib = poldek_conf_MULTILIB; /* just for short */
-+
- if (n_array_size(pkgs) < 2)
- return n_array_size(pkgs);
-
-@@ -334,14 +335,16 @@
-
- if (i == n_array_size(pkgs))
- break;
--
-+
- pkg2 = n_array_nth(pkgs, i);
- while (pkg_cmp_name(pkg, pkg2) == 0) {
-- pkg_unmark(pms, pkg2);
-- DBGF("unmark %s\n", pkg_id(pkg2));
--
-+ if (!multilib || (multilib && pkg_cmp_arch(pkg, pkg2) == 0)) {
-+ pkg_unmark(pms, pkg2);
-+ DBGF("unmark %s\n", pkg_id(pkg2));
-+ n++;
-+ }
-+
- i++;
-- n++;
- if (i == n_array_size(pkgs))
- break;
- pkg2 = n_array_nth(pkgs, i);
diff --git a/poldek-gcc34.patch b/poldek-gcc34.patch
deleted file mode 100644
index bfa4bf0..0000000
--- a/poldek-gcc34.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN poldek-0.19.0-cvs20040928./lib_pkgset.c poldek-0.19.0-cvs20040928/lib_pkgset.c
---- poldek-0.19.0-cvs20040928./lib_pkgset.c 2004-09-21 12:13:58.000000000 +0200
-+++ poldek-0.19.0-cvs20040928/lib_pkgset.c 2004-09-29 16:20:24.512095120 +0200
-@@ -96,7 +96,7 @@
- }
-
- tn_array *poldek_search_avail_packages(struct poldek_ctx *ctx,
-- enum pkgset_search_tag tag,
-+ enum poldek_search_tag tag,
- const char *value)
- {
- if (!poldek_load_sources(ctx))
diff --git a/poldek-gcc4.patch b/poldek-gcc4.patch
deleted file mode 100644
index 10942ce..0000000
--- a/poldek-gcc4.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-#
-# sigint.c:25: error: static declaration of 'sigint_reached_cb' follows non-static declaration
-# sigint.h:5: error: previous declaration of 'sigint_reached_cb' was here
-#
-# main.c:50: error: static declaration of 'argp_program_version' follows non-static declaration
-# /usr/include/argp.h:423: error: previous declaration of 'argp_program_version' was here
-#
-# cli/main.c | 2 +-
-# sigint/sigint.h | 2 --
-# 2 files changed, 1 insertion(+), 3 deletions(-)
-#
---- poldek-0.19.0-cvs20041011.21/sigint/sigint.h.orig 2004-09-26 22:39:57.000000000 +0200
-+++ poldek-0.19.0-cvs20041011.21/sigint/sigint.h 2004-12-14 15:31:53.387046032 +0100
-@@ -2,8 +2,6 @@
- #ifndef POLDEK_SIGINT_H
- #define POLDEK_SIGINT_H
-
--extern void (*sigint_reached_cb)(void);
--
- void sigint_init(void);
- void sigint_destroy(void);
- void sigint_reset(void);
---- poldek-0.19.0-cvs20041011.21/cli/main.c.orig 2004-10-09 14:53:51.000000000 +0200
-+++ poldek-0.19.0-cvs20041011.21/cli/main.c 2004-12-14 15:37:39.181477288 +0100
-@@ -47,7 +47,7 @@
-
- extern int poclidek_shell(struct poclidek_ctx *cctx);
-
--static const char *argp_program_version = poldek_VERSION_BANNER;
-+const char *argp_program_version = poldek_VERSION_BANNER;
- const char *argp_program_bug_address = poldek_BUG_MAILADDR;
- static char args_doc[] = N_("[PACKAGE...]");
-
diff --git a/poldek-ignorecaps.patch b/poldek-ignorecaps.patch
deleted file mode 100644
index da36e45..0000000
--- a/poldek-ignorecaps.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- poldek-0.20.1-cvs20070618.11/pkgset-req.c~ 2007-06-18 11:12:35.000000000 +0300
-+++ [oldek-0.20.1-cvs20070618.11/pkgset-req.c 2007-06-19 14:10:11.000000000 +0300
-@@ -364,6 +364,9 @@
- if (strncmp("rpmlib", capreq_name(req), 6) == 0 && !capreq_is_rpmlib(req))
- n_assert(0);
- */
-+
-+ if (strncmp("cpuinfo(", capreq_name(req), sizeof("cpuinfo(")-1) == 0 || strncmp("uname(", capreq_name(req), sizeof("uname(")-1) == 0)
-+ matched = 1;
-
- if (capreq_is_rpmlib(req) && matched) {
- int i;
diff --git a/poldek-retr_term.patch b/poldek-retr_term.patch
deleted file mode 100644
index 0704ddc..0000000
--- a/poldek-retr_term.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-diff -urN poldek-0.18.1.orig/vfile/Makefile.am poldek-0.18.1/vfile/Makefile.am
---- poldek-0.18.1.orig/vfile/Makefile.am Thu Oct 24 18:23:12 2002
-+++ poldek-0.18.1/vfile/Makefile.am Fri May 2 10:55:06 2003
-@@ -21,10 +21,10 @@
- vlibs = vftp/libvftp.a vhttp/libvhttp.a
-
- noinst_PROGRAMS = sample ttest
--sample_SOURCES = sample.c
-+sample_SOURCES = sample.c ../poldek_term.c ../log.c
- sample_LDADD = libvfile.a $(vlibs) @TRURL_LDFLAG@ $(LDADD_) $(top_srcdir)/sigint/libsigint.a
-
--ttest_SOURCES = ttest.c
-+ttest_SOURCES = ttest.c ../poldek_term.c ../log.c
- ttest_LDADD = libvfile.a $(vlibs) @TRURL_LDFLAG@ $(LDADD_) $(top_srcdir)/sigint/libsigint.a
- EXTRA_DIST = $(VFCURL_SRCS) \
- testcookie.c test_progress.c
-diff -urN poldek-0.18.1.orig/vfile/vfile.c poldek-0.18.1/vfile/vfile.c
---- poldek-0.18.1.orig/vfile/vfile.c Tue Oct 29 17:55:56 2002
-+++ poldek-0.18.1/vfile/vfile.c Fri May 2 10:59:25 2003
-@@ -42,6 +42,7 @@
- #include <trurl/nmalloc.h>
-
- #include "i18n.h"
-+#include "../poldek_term.h"
-
- #define VFILE_INTERNAL
- #include "vfile.h"
-@@ -224,6 +225,10 @@
- return mod;
- }
-
-+const char *PR_URL(const char *url) {
-+ return vf_url_slim_s(url, term_get_width()-strlen(_("Retrieving %s...\n"))-4);
-+}
-+
- int vfile_fetcha(const char *destdir, tn_array *urls, int urltype)
- {
- const struct vf_module *mod = NULL;
-diff -urN poldek-0.18.1.orig/vfile/vfile.h poldek-0.18.1/vfile/vfile.h
---- poldek-0.18.1.orig/vfile/vfile.h Thu Nov 7 17:43:29 2002
-+++ poldek-0.18.1/vfile/vfile.h Fri May 2 10:20:18 2003
-@@ -189,7 +189,7 @@
-
- /* short alias for */
- #define CL_URL(url) vf_url_hidepasswd_s(url)
--#define PR_URL(url) vf_url_slim_s(url, 60)
-+//#define PR_URL(url) vf_url_slim_s(url, 60)
-
-
-
diff --git a/poldek-su-sigsev.patch b/poldek-su-sigsev.patch
deleted file mode 100644
index 740d680..0000000
--- a/poldek-su-sigsev.patch
+++ /dev/null
@@ -1,109 +0,0 @@
-Index: conf.c
-===================================================================
-RCS file: /cvsroot/poldek/poldek/conf.c,v
-retrieving revision 1.84
-diff -u -r1.84 conf.c
---- conf.c 27 Jun 2007 21:47:43 -0000 1.84
-+++ conf.c 28 Jun 2007 15:47:04 -0000
-@@ -944,6 +944,9 @@
- addparam_flags |= ADD_PARAM_FOREIGN;
- }
-
-+ if (flags & POLDEK_LDCONF_NOVALIDATE)
-+ validate = 0;
-+
- if (flags & POLDEK_LDCONF_UPDATE)
- update = 1;
-
-Index: conf.h
-===================================================================
-RCS file: /cvsroot/poldek/poldek/conf.h,v
-retrieving revision 1.18
-diff -u -r1.18 conf.h
---- conf.h 27 Jun 2007 00:44:47 -0000 1.18
-+++ conf.h 28 Jun 2007 15:47:04 -0000
-@@ -6,10 +6,11 @@
- #include <trurl/narray.h>
- #include <trurl/nhash.h>
-
--#define POLDEK_LDCONF_FOREIGN (1 << 0) /* not a poldek file */
--#define POLDEK_LDCONF_UPDATE (1 << 1) /* resync with remote config */
--#define POLDEK_LDCONF_NOINCLUDE (1 << 2) /* ignore %include directives */
--#define POLDEK_LDCONF_GLOBALONLY (1 << 9) /* for early cachedir setup */
-+#define POLDEK_LDCONF_FOREIGN (1 << 0) /* not a poldek config file */
-+#define POLDEK_LDCONF_NOVALIDATE (1 << 1) /* do not validate config variables */
-+#define POLDEK_LDCONF_UPDATE (1 << 2) /* resync with remote config */
-+#define POLDEK_LDCONF_NOINCLUDE (1 << 3) /* ignore %include directives */
-+#define POLDEK_LDCONF_GLOBALONLY (1 << 4) /* for early cachedir setup */
-
- /* default localization is used if path is NULL */
- tn_hash *poldek_conf_load(const char *path, unsigned flags);
-Index: cli/main.c
-===================================================================
-RCS file: /cvsroot/poldek/poldek/cli/main.c,v
-retrieving revision 1.56
-diff -u -r1.56 main.c
---- cli/main.c 27 Jun 2007 00:44:47 -0000 1.56
-+++ cli/main.c 28 Jun 2007 15:47:05 -0000
-@@ -587,7 +587,8 @@
- } else if (noautosu == 0 && getuid() == 0) { /* check config's runas */
- tn_hash *cnf;
-
-- cnf = poldek_conf_load_default(POLDEK_LDCONF_NOINCLUDE | POLDEK_LDCONF_FOREIGN);
-+ cnf = poldek_conf_load_default(POLDEK_LDCONF_GLOBALONLY |
-+ POLDEK_LDCONF_NOVALIDATE);
- if (cnf) {
- tn_hash *global;
- const char *u;
-Index: tests/sh/04-conf
-===================================================================
-RCS file: /cvsroot/poldek/poldek/tests/sh/04-conf,v
-retrieving revision 1.2
-diff -u -r1.2 04-conf
---- tests/sh/04-conf 27 Jun 2007 21:47:42 -0000 1.2
-+++ tests/sh/04-conf 28 Jun 2007 15:47:05 -0000
-@@ -28,12 +28,43 @@
-
- is_verbose_mode && $poldek_l
-
-- n=$($poldek_l | grep -vE '^dbg:' | wc -l)
-+ n=$($poldek_l | grep 'test://' | wc -l)
- assertEquals "2 sources expected" "$n" "2"
-
- n=$($poldek_l | grep -E '^test[12] ' | wc -l)
- assertEquals "2 sources expected, but not those" "$n" "2"
- }
-+
-+testConfAsRoot()
-+{
-+ create_local_conf
-+ msgn "--conf"
-+ poldek_l="$POLDEK --conf $TMPDIR/poldek.conf -q -l"
-+
-+ is_verbose_mode && $poldek_l
-+
-+ n=$(fakeroot $poldek_l | grep 'test://' | wc -l)
-+ assertEquals "2 sources expected" "$n" "2"
-+
-+ n=$(fakeroot $poldek_l | grep -E '^test[12] ' | wc -l)
-+ assertEquals "2 sources expected, but not those" "$n" "2"
-+
-+ msgn "default conf"
-+ mkdir $TMPDIR/home || fail "mkdir"
-+ mv -f $TMPDIR/poldek.conf $TMPDIR/home/.poldekrc
-+ HOME=$TMPDIR/home
-+ export HOME
-+
-+ poldek_l="$POLDEK -q -l"
-+ is_verbose_mode && $poldek_l
-+
-+ n=$(fakeroot $poldek_l | grep 'test://' | wc -l)
-+ assertEquals "2 sources expected" "$n" "2"
-+
-+ n=$(fakeroot $poldek_l | grep -E '^test[12] ' | wc -l)
-+ assertEquals "2 sources expected, but not those" "$n" "2"
-+}
-+
-
- testConfInclude()
- {
diff --git a/poldek-types.patch b/poldek-types.patch
deleted file mode 100644
index 87e48bd..0000000
--- a/poldek-types.patch
+++ /dev/null
@@ -1,101 +0,0 @@
---- poldek-cvs20040323/pkgdir_digest.c.orig 2002-05-15 17:53:22.000000000 +0200
-+++ poldek-cvs20040323/pkgdir_digest.c 2004-04-24 23:39:17.927522138 +0200
-@@ -197,7 +197,8 @@
- static
- int hdr_digest(FILE *stream, unsigned char *md, int *md_size, EVP_MD_CTX *_ctx)
- {
-- int line_size = 0, nread, len, endvhdr_found = 0;
-+ size_t line_size = 0;
-+ int nread, len, endvhdr_found = 0;
- unsigned char buf[256];
- char *linebuf = NULL;
- EVP_MD_CTX ctx;
---- poldek-cvs20040323/trurlib/n_array_dump_stats.c.orig 2000-10-29 22:12:21.000000000 +0100
-+++ poldek-cvs20040323/trurlib/n_array_dump_stats.c 2004-04-24 23:45:50.159356575 +0200
-@@ -5,6 +5,6 @@
- void n_array_dump_stats(const tn_array *arr, const char *name)
- {
-
-- printf("\nArray \"%s\" [memsize, items, start_index] = %d, %d, %d\n",
-+ printf("\nArray \"%s\" [memsize, items, start_index] = %zd, %zd, %zd\n",
- name ? name : "", arr->allocated, arr->items, arr->start_index);
- }
---- poldek-cvs20040323/trurlib/n_hash_stats.c.orig 2000-10-29 22:12:21.000000000 +0100
-+++ poldek-cvs20040323/trurlib/n_hash_stats.c 2004-04-24 23:47:50.222234706 +0200
-@@ -31,7 +31,7 @@
- maxdeep = deep;
- }
-
-- printf("%p %d items, %d emptys, %d collisions, maxdeep %d\n", ht,
-+ printf("%p %zd items, %d emptys, %d collisions, maxdeep %d\n", ht,
- ht->items, nempts, ncolls, maxdeep);
- return n;
- }
---- poldek-cvs20040323/trurlib/nstr_tokl.c.orig 2003-04-30 17:53:02.000000000 +0200
-+++ poldek-cvs20040323/trurlib/nstr_tokl.c 2004-04-24 23:48:43.078415374 +0200
-@@ -24,6 +24,7 @@
- */
- #include <ctype.h>
- #include <stdlib.h>
-+#include <stdio.h>
- #include <string.h>
-
- #include "nmalloc.h"
---- poldek-cvs20040323/vfile/vhttp/test_vhttp.c.orig 2002-04-08 19:21:37.000000000 +0200
-+++ poldek-cvs20040323/vfile/vhttp/test_vhttp.c 2004-04-24 23:52:37.708518571 +0200
-@@ -1,4 +1,5 @@
- #include <stdio.h>
-+#include <stdlib.h>
- #include "vhttp.h"
- #include "http.h"
-
---- poldek-cvs20040323/pkgdir.c.orig 2004-03-11 00:27:42.000000000 +0100
-+++ poldek-cvs20040323/pkgdir.c 2004-04-24 23:57:45.955765417 +0200
-@@ -509,7 +509,8 @@
- char *dn, *bn;
- struct vfile *vf;
- char *linebuf = NULL;
-- int line_size = 0, nread, nerr = 0, rc;
-+ size_t line_size = 0;
-+ int nread, nerr = 0, rc;
- const char *errmsg_broken_difftoc = _("%s: broken patch list");
- char current_mdd[PDIGEST_SIZE + 1];
- struct pdigest pdg_current;
-@@ -719,7 +720,8 @@
- struct pkgdir *pkgdir = NULL;
- struct vfile *vf;
- char *linebuf;
-- int line_size, nline;
-+ size_t line_size;
-+ int nline;
- int nerr = 0, nread;
- struct pkgroup_idx *pkgroups = NULL;
- time_t ts = 0, ts_orig = 0;
-@@ -990,7 +992,7 @@
- struct pkgtags_s pkgt;
- off_t offs;
- char *linebuf;
-- int line_size;
-+ size_t line_size;
- int nerr = 0, nread, i;
- struct vfile *vf;
- int flag_skip_bastards = 0, flag_fullflist = 0;
---- poldek-cvs20040323/rpm_signature.c.orig 2003-07-16 12:49:28.000000000 +0200
-+++ poldek-cvs20040323/rpm_signature.c 2004-04-25 00:04:20.178184651 +0200
-@@ -52,7 +52,15 @@
- #include "capreq.h"
- #include "rpmdb_it.h"
-
--
-+#ifdef HAVE_RPM_4_2
-+/* from internal lib/signature.h, no public prototype (at least in 4.3 snaps) */
-+typedef enum sigType_e {
-+ RPMSIGTYPE_HEADERSIG= 5 /*!< Header style signature */
-+} sigType;
-+rpmRC rpmReadSignature(FD_t fd, Header *sighp, sigType sig_type, const char ** msg);
-+/* lib/rpmlead.h */
-+rpmRC readLead(FD_t fd, /*@out@*/ struct rpmlead *lead);
-+#endif
-
- static int rpm_read_signature(FD_t fd, Header *sighp, int sig_type)
- {
diff --git a/poldek-uninstall-depfix.patch b/poldek-uninstall-depfix.patch
deleted file mode 100644
index 41f9c4e..0000000
--- a/poldek-uninstall-depfix.patch
+++ /dev/null
@@ -1,174 +0,0 @@
-Index: capreq.c
-===================================================================
-RCS file: /cvsroot/poldek/poldek/capreq.c,v
-retrieving revision 1.44
-diff -u -r1.44 capreq.c
---- capreq.c 21 Jun 2007 16:47:45 -0000 1.44
-+++ capreq.c 29 Jun 2007 20:10:22 -0000
-@@ -59,7 +59,7 @@
- return strcmp(capreq_name(cr1), capreq_name(cr2));
- }
-
--__inline__
-+__inline__ static
- int capreq_cmp2name(struct capreq *cr1, const char *name)
- {
- return strcmp(capreq_name(cr1), name);
-@@ -427,9 +427,24 @@
- __inline__
- int capreq_arr_find(tn_array *capreqs, const char *name)
- {
-+ /* capreq_cmp2name is compilant with capreq_cmp_name_evr */
-+ if (!n_array_is_sorted(capreqs))
-+ n_array_sort(capreqs);
-+
- return n_array_bsearch_idx_ex(capreqs, name,
- (tn_fn_cmp)capreq_cmp2name);
- }
-+
-+__inline__
-+int capreq_arr_contains(tn_array *capreqs, const char *name)
-+{
-+ if (!n_array_is_sorted(capreqs))
-+ n_array_sort(capreqs); /* capreq_cmp2name */
-+
-+ return n_array_bsearch_idx_ex(capreqs, name,
-+ (tn_fn_cmp)capreq_cmp2name) > -1;
-+}
-+
-
- tn_buf *capreq_arr_join(tn_array *capreqs, tn_buf *nbuf, const char *sep)
- {
-Index: capreq.h
-===================================================================
-RCS file: /cvsroot/poldek/poldek/capreq.h,v
-retrieving revision 1.30
-diff -u -r1.30 capreq.h
---- capreq.h 21 Jun 2007 22:29:49 -0000 1.30
-+++ capreq.h 29 Jun 2007 20:10:22 -0000
-@@ -117,12 +117,12 @@
- int capreq_strcmp_name_evr(struct capreq *pr1, struct capreq *pr2);
-
- int capreq_cmp_name(struct capreq *cr1, struct capreq *cr2);
--int capreq_cmp2name(struct capreq *pr1, const char *name);
- int capreq_cmp_name_evr(struct capreq *cr1, struct capreq *cr2);
-
- #ifndef SWIG
- tn_array *capreq_arr_new(int size);
--int capreq_arr_find(tn_array *capreqs, const char *name);
-+int capreq_arr_find(tn_array *capreqs, const char *name); /* returns index */
-+int capreq_arr_contains(tn_array *capreqs, const char *name); /* returns bool */
- tn_buf *capreq_arr_join(tn_array *capreqs, tn_buf *nbuf, const char *sep);
-
- int capreq_arr_store_n(tn_array *arr);
-Index: libpoldek.sym
-===================================================================
-RCS file: /cvsroot/poldek/poldek/libpoldek.sym,v
-retrieving revision 1.28
-diff -u -r1.28 libpoldek.sym
---- libpoldek.sym 28 Jun 2007 22:28:21 -0000 1.