summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Banasiak2012-02-19 16:07:52 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitf42057957f89e7488857bdf0f73c42e960b2662c (patch)
tree136672023785afa515c0bca0beb916654a906789
parente46f6b38fd3558972759b77bf9e969327e916499 (diff)
downloadpoldek-auto/th/poldek-0_30-1_rc4_2.zip
poldek-auto/th/poldek-0_30-1_rc4_2.tar.gz
- backported patch from git to fix data types usageauto/th/poldek-0_30-1_rc4_2
- release 2 Changed files: poldek-git.patch -> 1.1 poldek.spec -> 1.436
-rw-r--r--poldek-git.patch20
-rw-r--r--poldek.spec4
2 files changed, 23 insertions, 1 deletions
diff --git a/poldek-git.patch b/poldek-git.patch
new file mode 100644
index 0000000..69a34ea
--- /dev/null
+++ b/poldek-git.patch
@@ -0,0 +1,20 @@
+commit f18bedfa368995550e231f382718029bdc2300df
+Author: Marcin Banasiak <marcin.banasiak@gmail.com>
+Date: Sun Feb 19 16:55:35 2012 +0100
+
+ Fix types in tndb_get_all
+
+diff --git a/read.c b/read.c
+index b57bb50..d560799 100644
+--- a/tndb/read.c
++++ b/tndb/read.c
+@@ -497,7 +497,8 @@ size_t tndb_get_all(struct tndb *db, const void *key, size_t klen,
+ void **val)
+ {
+ off_t voffs;
+- size_t nread = 0, vlen;
++ size_t nread = 0;
++ unsigned int vlen;
+
+ if (tndb_get_voff(db, key, klen, &voffs, &vlen)) {
+ *val = n_malloc(vlen + 1); /* extra byte for \0 */
diff --git a/poldek.spec b/poldek.spec
index af5d517..f9bde96 100644
--- a/poldek.spec
+++ b/poldek.spec
@@ -17,7 +17,7 @@
%define ver_rpm 4.5-49
%define snap rc4
-%define rel 1
+%define rel 2
Summary: RPM packages management helper tool
Summary(hu.UTF-8): RPM csomagkezelést segítő eszköz
Summary(pl.UTF-8): Pomocnicze narzędzie do zarządzania pakietami RPM
@@ -44,6 +44,7 @@ Patch0: %{name}-vserver-packages.patch
Patch1: %{name}-config.patch
Patch2: %{name}-size-type.patch
Patch3: %{name}-Os-fail-workaround.patch
+Patch4: %{name}-git.patch
URL: http://poldek.pld-linux.org/
BuildRequires: autoconf
BuildRequires: automake
@@ -204,6 +205,7 @@ Moduły języka Python dla poldka.
%patch1 -p1
%patch2 -p1
%patch3 -p1
+%patch4 -p1
rm -f m4/libtool.m4 m4/lt*.m4