summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArkadiusz Miśkiewicz2021-03-01 23:09:19 (GMT)
committerArkadiusz Miśkiewicz2021-03-01 23:09:19 (GMT)
commitdb15c97870bc19c8ffe77c5971ac1259d4f7164e (patch)
tree626cf70fdae13ca99c4703d785c7df53e95c2e94
parent7ae7664a768d1e154c0287494bb89cde3e48cf15 (diff)
downloadopenssh-auto/th/openssh-8.4p1-5.zip
openssh-auto/th/openssh-8.4p1-5.tar.gz
- rel 5; fix x32 (seccomp was killing it)auto/th/openssh-8.4p1-5
-rw-r--r--openssh.spec5
-rw-r--r--x32.patch34
2 files changed, 37 insertions, 2 deletions
diff --git a/openssh.spec b/openssh.spec
index 9914d26..77674c5 100644
--- a/openssh.spec
+++ b/openssh.spec
@@ -37,7 +37,7 @@ Summary(ru.UTF-8): OpenSSH - свободная реализация прото
Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
Name: openssh
Version: 8.4p1
-Release: 4
+Release: 5
Epoch: 2
License: BSD
Group: Applications/Networking
@@ -68,7 +68,7 @@ Patch8: ldap-helper-sigpipe.patch
# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
Patch9: %{name}-5.2p1-hpn13v6.diff
-
+Patch10: x32.patch
Patch11: %{name}-chroot.patch
Patch12: openssh-bug-2905.patch
Patch13: %{name}-skip-interop-tests.patch
@@ -552,6 +552,7 @@ openldap-a.
%{?with_hpn:%patch9 -p1}
+%patch10 -p1
%patch11 -p1
%patch12 -p1
%patch13 -p1
diff --git a/x32.patch b/x32.patch
new file mode 100644
index 0000000..534596a
--- /dev/null
+++ b/x32.patch
@@ -0,0 +1,34 @@
+commit e3f27006f15abacb7e89fda3f5e9a0bd420b7e38
+Author: Damien Miller <djm@mindrot.org>
+Date: Fri Nov 13 14:20:43 2020 +1100
+
+ Revert "detect Linux/X32 systems"
+
+ This reverts commit 5b56bd0affea7b02b540bdbc4d1d271b0e4fc885.
+
+ The approach used was incorrect; discussion in bz#3085
+
+diff --git a/configure.ac b/configure.ac
+index d3f4f570..842c255e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -532,8 +532,6 @@ SPP_MSG="no"
+ # the --with-solaris-privs option and --with-sandbox=solaris).
+ SOLARIS_PRIVS="no"
+
+-AC_CHECK_SIZEOF([size_t])
+-
+ # Check for some target-specific stuff
+ case "$host" in
+ *-*-aix*)
+@@ -878,10 +876,6 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
+ case "$host" in
+ x86_64-*)
+ seccomp_audit_arch=AUDIT_ARCH_X86_64
+- # X32: AMD64 instructions in 32bit address space.
+- if test "x$ac_cv_sizeof_size_t" = "x4" ; then
+- seccomp_audit_arch=AUDIT_ARCH_I386
+- fi
+ ;;
+ i*86-*)
+ seccomp_audit_arch=AUDIT_ARCH_I386