summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ladspa-rev-plugins-misc_fixes.patch44
-rw-r--r--ladspa-rev-plugins.spec20
2 files changed, 36 insertions, 28 deletions
diff --git a/ladspa-rev-plugins-misc_fixes.patch b/ladspa-rev-plugins-misc_fixes.patch
index 872e36e..ab9fced 100644
--- a/ladspa-rev-plugins-misc_fixes.patch
+++ b/ladspa-rev-plugins-misc_fixes.patch
@@ -1,31 +1,39 @@
-diff -ur REV-plugins-0.2.1.orig/Makefile REV-plugins-0.2.1/Makefile
---- REV-plugins-0.2.1.orig/Makefile 2003-12-01 21:18:18.000000000 +0100
-+++ REV-plugins-0.2.1/Makefile 2004-10-05 01:58:21.267530256 +0200
-@@ -1,5 +1,6 @@
+--- REV-plugins-0.7.1/Makefile.orig 2022-01-23 19:49:10.480719586 +0100
++++ REV-plugins-0.7.1/Makefile 2022-01-23 20:10:49.480348969 +0100
+@@ -19,21 +19,22 @@
+ # -----------------------------------------------------------------------
- CPPFLAGS += -I. -fPIC -D_REENTRANT -Wall -O2
-+INSTALL_PLUGINS_DIR=/usr/lib/ladspa
++CXX = g++
+ CPPFLAGS += -I. -fPIC -D_REENTRANT
+-CXXFLAGS += -Wall -O2
++CXXFLAGS += -Wall
- all: g2reverb.so
-@@ -13,7 +14,7 @@
+ all: zita-reverbs.so
+ REVERBS_O = reverbs.o reverbs_if.o zreverb.o pareq.o
+ zita-reverbs.so: $(REVERBS_O)
+- g++ -shared -o $@ $(REVERBS_O)
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -shared -o $@ $(REVERBS_O)
+
+ reverbs.o: ladspaplugin.h reverbs.h zreverb.h pareq.h
+ reverbs_if.o: ladspaplugin.h reverbs.h zreverb.h pareq.h
- install:
-- cp *.so /usr/lib/ladspa
-+ cp *.so $(DESTDIR)$(INSTALL_PLUGINS_DIR)
+ install: zita-reverbs.so
+- cp *.so /usr/lib/ladspa
++ cp -p *.so $(DESTDIR)$(INSTALL_PLUGINS_DIR)
- DIR := $(shell basename `pwd`)
-diff -ur REV-plugins-0.2.1.orig/ladspaplugin.h REV-plugins-0.2.1/ladspaplugin.h
---- REV-plugins-0.2.1.orig/ladspaplugin.h 2003-12-01 21:18:18.000000000 +0100
-+++ REV-plugins-0.2.1/ladspaplugin.h 2004-10-05 01:57:39.839828224 +0200
-@@ -21,7 +21,7 @@
+ clean:
+ rm -rf *~ *.o *.so
+--- REV-plugins-0.7.1/ladspaplugin.h.orig 2022-01-23 19:49:10.480719586 +0100
++++ REV-plugins-0.7.1/ladspaplugin.h 2022-01-23 20:11:23.316832328 +0100
+@@ -23,7 +23,7 @@
#define __LADSPAPLUGIN_H
--#include "ladspa.h" // use local version
+-#include "ladspa.h"
+#include <ladspa.h>
-
+ class LadspaPlugin
diff --git a/ladspa-rev-plugins.spec b/ladspa-rev-plugins.spec
index 36543e7..181b690 100644
--- a/ladspa-rev-plugins.spec
+++ b/ladspa-rev-plugins.spec
@@ -1,16 +1,14 @@
-%define _name REV-plugins
Summary: Stereo reverb LADSPA plugin
Summary(pl.UTF-8): Wtyczka LADSPA - stereofoniczny pogłos
Name: ladspa-rev-plugins
-Version: 0.3.1
+Version: 0.7.1
Release: 1
License: GPL v2+
Group: Applications/Sound
-#Source0Download: http://users.skynet.be/solaris/linuxaudio/getit.html
-Source0: http://users.skynet.be/solaris/linuxaudio/downloads/%{_name}-%{version}.tar.bz2
-# Source0-md5: bca920c2cbf5e33989e7cafab6fbaee4
+Source0: http://kokkinizita.linuxaudio.org/linuxaudio/downloads/REV-plugins-%{version}.tar.bz2
+# Source0-md5: 9f0be0d26592f67ba5fe16102c6bc332
Patch0: %{name}-misc_fixes.patch
-URL: http://users.skynet.be/solaris/linuxaudio/
+URL: http://kokkinizita.linuxaudio.org/linuxaudio/ladspa/index.html
BuildRequires: ladspa-devel
BuildRequires: libstdc++-devel
Requires: ladspa-common
@@ -25,13 +23,15 @@ Ta wtyczka LADSPA zawiera cyfrową implementację stereofonicznego
efektu pogłosu.
%prep
-%setup -q -n %{_name}-%{version}
+%setup -q -n REV-plugins-%{version}
%patch0 -p1
%build
+CPPFLAGS="%{rpmcppflags}" \
+CXXFLAGS="%{rpmcxxflags}" \
+LDFLAGS="%{rpmldflags}" \
%{__make} \
- CXX="%{__cxx}" \
- CPPFLAGS="-I. -fPIC -D_REENTRANT -Wall %{rpmcflags}"
+ CXX="%{__cxx}"
%install
rm -rf $RPM_BUILD_ROOT
@@ -47,4 +47,4 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(644,root,root,755)
%doc AUTHORS README
-%attr(755,root,root) %{_libdir}/ladspa/g2reverb.so
+%attr(755,root,root) %{_libdir}/ladspa/zita-reverbs.so