summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkloczek2000-01-05 23:15:52 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit81714278a34a700431fbbf12818f85c9a080f574 (patch)
treee9a5c49169ce56491f3a50d4601cd88dd914b9c5
downloadcurl-81714278a34a700431fbbf12818f85c9a080f574.zip
curl-81714278a34a700431fbbf12818f85c9a080f574.tar.gz
- raw version.
Changed files: curl.spec -> 1.1
-rw-r--r--curl.spec60
1 files changed, 60 insertions, 0 deletions
diff --git a/curl.spec b/curl.spec
new file mode 100644
index 0000000..a03a2ed
--- /dev/null
+++ b/curl.spec
@@ -0,0 +1,60 @@
+%define name curl
+%define version 5.11
+%define release 3
+%define prefix /usr
+
+%define builddir $RPM_BUILD_DIR/%{name}-%{version}
+
+Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
+Name: %{name}
+Version: %{version}
+Release: %{release}
+Copyright: MPL
+Vendor: Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
+Packager: Troy Engel <tengel@sonic.net>
+Group: Applications/Internet
+Source: %{name}-%{version}.tar.gz
+URL: http://www.fts.frontec.se/~dast/curl/
+BuildRoot: /var/tmp/%{name}-%{version}-root
+
+%description
+cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
+Dict servers, using any of the supported protocols. cURL is designed
+to work without user interaction or any kind of interactivity. cURL
+offers many useful capabilities, like proxy support, user
+authentication, FTP upload, HTTP post, and file transfer resume. Note
+that while cURL also supports the SSL protocol, this version is
+compiled without SSL (https:) support.
+
+%prep
+rm -rf $RPM_BUILD_ROOT
+rm -rf %{builddir}
+
+%setup -q
+
+%build
+export CFLAGS=$RPM_OPT_FLAGS
+./configure --prefix=%{prefix}
+make
+
+%install
+make prefix=$RPM_BUILD_ROOT%{prefix} install-strip
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+rm -rf %{builddir}
+
+%files
+%defattr(-,root,root)
+%attr(0755,root,root) %{prefix}/bin/curl
+/usr/man/man1/curl.1
+%doc curl.1 README* CHANGES CONTRIBUTE FAQ INSTALL LEGAL MPL-1.0.txt RESOURCES TODO perl/
+
+%changelog
+* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
+- changed group
+
+* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
+- changelog started
+- general cleanups, changed prefix to /usr, added manpage to files section
+- including in Powertools