summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cryptsetup.spec9
-rw-r--r--dont-drag-more-libs.patch22
2 files changed, 3 insertions, 28 deletions
diff --git a/cryptsetup.spec b/cryptsetup.spec
index 3fa8bd4..7a024a5 100644
--- a/cryptsetup.spec
+++ b/cryptsetup.spec
@@ -1,21 +1,20 @@
#
# Conditonal build:
%bcond_without initrd # don't build initrd version
-%bcond_without dietlibc # build initrd version with static glibc instead of dietlibc
+%bcond_with dietlibc # build initrd version with static glibc instead of dietlibc
%bcond_without python # Python binding
Summary: LUKS for dm-crypt implemented in cryptsetup
Summary(pl.UTF-8): LUKS dla dm-crypta zaimplementowany w cryptsetup
Name: cryptsetup
Version: 1.4.2
-Release: 2
+Release: 3
License: GPL v2
Group: Base
#Source0Download: http://code.google.com/p/cryptsetup/downloads/list
Source0: http://cryptsetup.googlecode.com/files/%{name}-%{version}.tar.bz2
# Source0-md5: db2e6189e1b191a279a1f508396d3373
Patch0: diet.patch
-Patch1: dont-drag-more-libs.patch
URL: http://code.google.com/p/cryptsetup/
BuildRequires: autoconf >= 2.67
BuildRequires: automake
@@ -48,6 +47,7 @@ BuildRequires: libselinux-static
BuildRequires: libsepol-static
BuildRequires: libuuid-static
BuildRequires: popt-static
+BuildRequires: udev-static
%endif
%endif
Requires: popt >= 1.7
@@ -145,7 +145,6 @@ cryptsetup - wersję statycznie zlinkowaną dla initrd.
%prep
%setup -q
%patch0 -p1
-%patch1 -p1
%{__rm} po/stamp-po
@@ -161,7 +160,6 @@ cryptsetup - wersję statycznie zlinkowaną dla initrd.
CC="%{__cc}"
%configure \
%if %{with dietlibc}
-%configure \
CC="diet ${CC#ccache } %{rpmcppflags} %{rpmcflags} %{rpmldflags} -Os" \
LIBS="-lcompat" \
ac_cv_lib_popt_poptConfigFileToString=yes \
@@ -174,7 +172,6 @@ CC="%{__cc}"
--disable-shared \
--enable-static \
--enable-static-cryptsetup \
- --disable-udev \
--disable-nls
%{__make} -C lib
diff --git a/dont-drag-more-libs.patch b/dont-drag-more-libs.patch
deleted file mode 100644
index 820c597..0000000
--- a/dont-drag-more-libs.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- cryptsetup-1.3.1/configure.in~ 2011-05-30 15:48:40.361712101 +0200
-+++ cryptsetup-1.3.1/configure.in 2011-05-30 15:52:03.021018901 +0200
-@@ -157,7 +157,7 @@
- [disable udev support]),[], enable_udev=yes)
-
- dnl Try to use pkg-config for devmapper, but fallback to old detection
--PKG_CHECK_MODULES([DEVMAPPER], [devmapper >= 1.02.03],, [
-+PKG_CHECK_MODULES([DEVMAPPER], [devmapper-always-use-fallback-so-only-required-libs-will-go-in >= 1.02.03],, [
- AC_CHECK_LIB(devmapper, dm_task_set_name,,
- [AC_MSG_ERROR([You need the device-mapper library.])])
- AC_CHECK_LIB(devmapper, dm_task_set_message,,
---- cryptsetup-1.3.1/configure.in~ 2011-05-30 16:04:32.645465788 +0200
-+++ cryptsetup-1.3.1/configure.in 2011-05-30 16:06:09.913262079 +0200
-@@ -208,7 +208,7 @@
-
- dnl Try to detect needed device-mapper static libraries, try pkg-config first.
- LIBS="$saved_LIBS -static"
-- PKG_CHECK_MODULES([DEVMAPPER_STATIC], [devmapper >= 1.02.27],,[
-+ PKG_CHECK_MODULES([DEVMAPPER_STATIC], [devmapper-without-tons-of-deps >= 1.02.27],,[
- DEVMAPPER_STATIC_LIBS=$DEVMAPPER_LIBS
- if test "x$enable_selinux" != xno; then
- AC_CHECK_LIB(sepol, sepol_bool_set)