summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Rękorajski2009-03-23 14:10:51 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit593621cbd67acf10f03bd88ea692df47fb522a56 (patch)
tree5a182cdf79b77888fb9cb89bcd93129b09a722ce
parent763db42e28a97c12ba8272025fdf92a7e2de8d2b (diff)
downloadcryptsetup-593621cbd67acf10f03bd88ea692df47fb522a56.zip
cryptsetup-593621cbd67acf10f03bd88ea692df47fb522a56.tar.gz
- unify dietlibc compile options and calls
Changed files: cryptsetup.spec -> 1.43
-rw-r--r--cryptsetup.spec7
1 files changed, 4 insertions, 3 deletions
diff --git a/cryptsetup.spec b/cryptsetup.spec
index f836808..1c0b3e0 100644
--- a/cryptsetup.spec
+++ b/cryptsetup.spec
@@ -152,7 +152,7 @@ install %{SOURCE5} README.initramfs
%if %{with initrd}
%configure \
%if %{with dietlibc}
- CC="diet %{__cc} -Os %{rpmldflags}" \
+ CC="diet %{__cc} %{rpmcflags} %{rpmldflags} -Os" \
ac_cv_lib_popt_poptConfigFileToString=yes \
ac_cv_lib_sepol_sepol_bool_set=no \
ac_cv_lib_selinux_is_selinux_enabled=no \
@@ -168,8 +168,9 @@ install %{SOURCE5} README.initramfs
%if %{with dietlibc}
# we have to do it by hand cause libtool "know better" and forces
# static libs from /usr/lib
-diet %{__cc} -Os -I./lib -static -o cryptsetup-initrd src/cryptsetup.c \
- ./lib/.libs/libcryptsetup.a -lpopt -lgcrypt -lgpg-error -ldevmapper -luuid -lcompat
+diet %{__cc} %{rpmcflags} %{rpmldflags} -Os -I./lib -static \
+ -o cryptsetup-initrd src/cryptsetup.c ./lib/.libs/libcryptsetup.a \
+ -lpopt -lgcrypt -lgpg-error -ldevmapper -luuid -lcompat
%else
%{__make} -C src
mv src/cryptsetup cryptsetup-initrd