summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2023-02-07 16:17:27 (GMT)
committerJakub Bogusz2023-02-07 16:17:27 (GMT)
commit90bde2897a7d65bd946ddab4da4aca1269b378e3 (patch)
tree85b76aa00aa248d56ee64a4255e3eefdc26987fb
parent98e2ea3dc88414fe8dddc4b6b544b4c788bfc49b (diff)
downloadcproto-auto/th/cproto-4.7u-1.zip
cproto-auto/th/cproto-4.7u-1.tar.gz
- switched to maintained version, updated to 4.7u; removed outdated patchesauto/th/cproto-4.7u-1
-rw-r--r--cproto-DESTDIR.patch35
-rw-r--r--cproto-acfix.patch26
-rw-r--r--cproto-varargs.patch10
-rw-r--r--cproto.patch65
-rw-r--r--cproto.spec29
5 files changed, 10 insertions, 155 deletions
diff --git a/cproto-DESTDIR.patch b/cproto-DESTDIR.patch
deleted file mode 100644
index b238db3..0000000
--- a/cproto-DESTDIR.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -Nru cproto-4.6/Makefile.in cproto-4.6.new/Makefile.in
---- cproto-4.6/Makefile.in Sat Nov 25 03:17:39 2000
-+++ cproto-4.6.new/Makefile.in Sat Nov 25 03:18:40 2000
-@@ -29,8 +29,8 @@
- prefix = @prefix@
- exec_prefix = @exec_prefix@
-
--bindir = $(exec_prefix)/bin
--mandir = $(prefix)/man/man1
-+bindir = @bindir@
-+mandir = @mandir@/man1
- manext = 1
-
- #### End of system configuration section. ####
-@@ -83,15 +83,15 @@
- all : $(THIS) # $(THIS).man
-
- install: all installdirs
-- $(INSTALL_PROGRAM) $(THIS) $(bindir)/$(THIS)
-- - $(INSTALL_DATA) $(srcdir)/$(THIS).1 $(mandir)/$(THIS).$(manext)
-+ $(INSTALL_PROGRAM) $(THIS) $(DESTDIR)$(bindir)/$(THIS)
-+ - $(INSTALL_DATA) $(srcdir)/$(THIS).1 $(DESTDIR)$(mandir)/$(THIS).$(manext)
-
- installdirs:
-- $(SHELL) ${srcdir}/mkdirs.sh $(bindir)
-- - $(SHELL) ${srcdir}/mkdirs.sh $(mandir)
-+ $(SHELL) ${srcdir}/mkdirs.sh $(DESTDIR)$(bindir)
-+ - $(SHELL) ${srcdir}/mkdirs.sh $(DESTDIR)$(mandir)
-
- uninstall:
-- - rm -f $(bindir)/$(THIS) $(mandir)/$(THIS).$(manext)
-+ - rm -f $(bindir)/$(THIS) $(DESTDIR)$(mandir)/$(THIS).$(manext)
-
- $(THIS) : $(OBJECTS)
- $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(OBJECTS) $(LIBS)
diff --git a/cproto-acfix.patch b/cproto-acfix.patch
deleted file mode 100644
index 0a60f2b..0000000
--- a/cproto-acfix.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- cproto-4.6/configure.in.orig Sat Jan 24 02:42:05 1998
-+++ cproto-4.6/configure.in Sat Oct 20 16:33:07 2001
-@@ -57,19 +57,17 @@
- AC_DEFINE_UNQUOTED(CPP,"$CPP")
-
- ### output makefile and config.h
--changequote({,})dnl
- AC_OUTPUT(Makefile config_h,
--{
-+[
- echo creating config.h
- sed -e '/^# /d' \
-- -e 's/ -D/\
-+ -e 's/ \?-D/\
- #define /g' \
-- -e 's/\(#define [A-Za-z_][A-Za-z0-9_]*\)=/\1 /g' \
-+ -e ['s/\(#define [A-Za-z_][A-Za-z0-9_]*\)=/\1 /g'] \
- -e 's/\\//g' \
- config_h >config.h
--}
-+]
- echo removing config_h
- rm config_h
- )
--changequote([,])dnl
- touch stamp-h
diff --git a/cproto-varargs.patch b/cproto-varargs.patch
deleted file mode 100644
index 01cf75a..0000000
--- a/cproto-varargs.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- cproto-4.6/grammar.y.orig Tue Jan 20 19:55:55 1998
-+++ cproto-4.6/grammar.y Mon Aug 13 18:39:07 2001
-@@ -835,6 +835,7 @@
- "__const__", "__const",
- "__volatile__", "__volatile",
- "__inline__", "__inline",
-+ "__builtin_va_list",
- #endif
- };
- int i;
diff --git a/cproto.patch b/cproto.patch
deleted file mode 100644
index 25662c8..0000000
--- a/cproto.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-diff -uNr cproto-4.6/Makefile.in cproto-4.6.new/Makefile.in
---- cproto-4.6/Makefile.in Sat Jan 24 03:42:00 1998
-+++ cproto-4.6.new/Makefile.in Mon Mar 15 17:59:07 1999
-@@ -4,7 +4,7 @@
- # UNIX template-makefile for C prototype generator
-
- THIS = cproto
--RELEASE = 4_6
-+RELEASE = 4_6_1
-
- #### Start of system configuration section. ####
-
-@@ -21,7 +21,7 @@
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
- INSTALL_DATA = @INSTALL_DATA@
-
--DEFINES =
-+DEFINES = -DMAX_INC_DIR=64 -DMAX_INC_DEPTH=64
- CPPFLAGS = -I$(srcdir) $(DEFINES) -DHAVE_CONFIG_H @CPPFLAGS@
- CFLAGS = @CFLAGS@ $(CPPFLAGS)
- LIBS = @LIBS@ @LEXLIB@
-diff -uNr cproto-4.6/cproto.c cproto-4.6.new/cproto.c
---- cproto-4.6/cproto.c Sat Jan 24 03:42:07 1998
-+++ cproto-4.6.new/cproto.c Mon Mar 15 18:00:01 1999
-@@ -2,7 +2,7 @@
- *
- * C function prototype generator and function definition converter
- */
--#define VERSION "4.6"
-+#define VERSION "4.6.1"
-
- #include <stdio.h>
- #include <ctype.h>
-diff -uNr cproto-4.6/yyerror.c cproto-4.6.new/yyerror.c
---- cproto-4.6/yyerror.c Sat Apr 13 07:29:18 1996
-+++ cproto-4.6.new/yyerror.c Mon Mar 15 17:58:29 1999
-@@ -126,22 +126,16 @@
- if (count < 0) {
- if (last++ >= 0) {
- qsort((char *)vec, (size_t)last, sizeof(vec[0]), compar);
-- /* limit length of error message */
-- k = 80 - (strlen(vec[last-1]) + 2);
-+
- for (j = 0; j < last; j++) {
- tag = j ? " " : "Expected: ";
-- s = vec[j];
-- if (j != (last - 1)) {
-- x = strlen(s) + strlen(tag);
-- if (k <= 0)
-- continue;
-- else if ((k - x) <= 0)
-- s = "...";
-- k -= x;
-- }
-- fprintf(stderr, "%s%s", tag, s);
-+
-+ if (vec[j])
-+ fprintf(stderr, "%s%s", tag, vec[j]);
- }
-+
- fprintf(stderr, "\n");
-+
- while (--last >= 0)
- free(vec[last]);
- }
diff --git a/cproto.spec b/cproto.spec
index 079869d..46f4c92 100644
--- a/cproto.spec
+++ b/cproto.spec
@@ -8,20 +8,16 @@ Summary(ru.UTF-8): Генерирует прототипы функций и дÐ
Summary(tr.UTF-8): C prototip aracı
Summary(uk.UTF-8): Генерує прототипи функцій та декларації змінних з коду на C
Name: cproto
-Version: 4.6
-Release: 18
+Version: 4.7u
+Release: 1
License: Public Domain
Group: Development/Tools
-Source0: http://dl.sourceforge.net/cproto/%{name}-%{version}.tar.gz
-# Source0-md5: 5968d18e9508b2892471e6ef16e140e3
-Patch0: %{name}.patch
-Patch1: %{name}-DESTDIR.patch
-Patch2: %{name}-acfix.patch
-Patch3: %{name}-varargs.patch
-URL: http://cproto.sourceforge.net/
-BuildRequires: autoconf
+Source0: https://invisible-island.net/archives/cproto/%{name}-%{version}.tgz
+# Source0-md5: eebf3353591be158b518bb40a58f1536
+URL: https://invisible-island.net/cproto/
BuildRequires: bison
BuildRequires: flex
+BuildRequires: groff
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
%description
@@ -94,15 +90,10 @@ verilmemiÅŸse, cproto girdi olarak standart giriÅŸten bilgi okur.
%prep
%setup -q
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
%build
-%{__autoconf}
-%configure \
- CPPFLAGS="-DYYSTYPE=YYSTYPE"
+%configure
+
%{__make}
%install
@@ -116,6 +107,6 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(644,root,root,755)
-%doc README CHANGES
+%doc AUTHORS CHANGES LICENSE README
%attr(755,root,root) %{_bindir}/cproto
-%{_mandir}/man1/*
+%{_mandir}/man1/cproto.1*