summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArkadiusz Miśkiewicz2013-08-02 07:58:51 (GMT)
committerArkadiusz Miśkiewicz2013-08-02 07:58:51 (GMT)
commit5c3acaa003210942edb4aab9c8557f0a1942fa79 (patch)
tree9b3f99698a94da1b19470b4746cb36dd35b5474b
parent26c3364c156f1c8f6793138043eec8b944ed9ee2 (diff)
downloadMesa-auto/th/Mesa-9.1.6-1.zip
Mesa-auto/th/Mesa-9.1.6-1.tar.gz
-rw-r--r--Mesa-llvm.patch11
-rw-r--r--Mesa.spec8
2 files changed, 15 insertions, 4 deletions
diff --git a/Mesa-llvm.patch b/Mesa-llvm.patch
index b7aea5d..1b0e690 100644
--- a/Mesa-llvm.patch
+++ b/Mesa-llvm.patch
@@ -363,3 +363,14 @@ index 86617d4..1c886ea 100644
$(LLVM_LIBS)
+--- Mesa-9.1.6/configure.ac~ 2013-08-01 23:14:58.000000000 +0200
++++ Mesa-9.1.6/configure.ac 2013-08-02 09:44:02.661826293 +0200
+@@ -1779,7 +1779,7 @@
+
+ radeon_llvm_check() {
+ LLVM_REQUIRED_VERSION_MAJOR="3"
+- LLVM_REQUIRED_VERSION_MINOR="2"
++ LLVM_REQUIRED_VERSION_MINOR="3"
+ if test "$LLVM_VERSION_INT" -ne "${LLVM_REQUIRED_VERSION_MAJOR}0${LLVM_REQUIRED_VERSION_MINOR}"; then
+ AC_MSG_ERROR([LLVM $LLVM_REQUIRED_VERSION_MAJOR.$LLVM_REQUIRED_VERSION_MINOR with R600 target enabled is required.
+ To use the r600/radeonsi LLVM backend, you need to fetch the LLVM source from:
diff --git a/Mesa.spec b/Mesa.spec
index 84737a7..c9d11e7 100644
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -21,7 +21,7 @@
# (until they start to be somehow versioned themselves)
%define glapi_ver 7.1.0
# internal API version (libdricore); a.b.c for Mesa-a.b.c, a.b.0 for Mesa-a.b
-%define int_sover 9.1.5
+%define int_sover 9.1.6
# minimal supported xserver version
%define xserver_ver 1.5.0
# other packages
@@ -32,12 +32,12 @@
Summary: Free OpenGL implementation
Summary(pl.UTF-8): Wolnodostępna implementacja standardu OpenGL
Name: Mesa
-Version: 9.1.5
+Version: 9.1.6
Release: 1
License: MIT (core) and others - see license.html file
Group: X11/Libraries
Source0: ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
-# Source0-md5: 4ed2af5943141a85a21869053a2fc2eb
+# Source0-md5: 443a2a352667294b53d56cb1a74114e9
Patch0: %{name}-link.patch
Patch1: %{name}-llvm.patch
URL: http://www.mesa3d.org/
@@ -54,7 +54,7 @@ BuildRequires: libtalloc-devel >= 2:2.0.1
BuildRequires: libtool >= 2:2.2
BuildRequires: libvdpau-devel >= 0.4.1
BuildRequires: libxcb-devel >= 1.9
-BuildRequires: llvm-devel >= 3.2
+BuildRequires: llvm-devel >= 3.3
%{?with_opencl:BuildRequires: llvm-libclc}
BuildRequires: perl-base
BuildRequires: pixman-devel