]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - ocaml.spec
pecl: add example how to make failed tests as XFAIL
[projects/template-specs.git] / ocaml.spec
index 0b956e1fd56ca8e4964d9042ded6ff354e54e9b1..41a410f91a47ab41ff7340b019e7d81ca4086cb3 100644 (file)
@@ -1,16 +1,10 @@
 #
 # Conditional build:
-%bcond_without ocaml_opt               # build opt
+%bcond_without ocaml_opt       # skip building native optimized binaries (bytecode is always built)
 
-%ifarch x32
-# not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
-%undefine▸      with_ocaml_opt
-%endif
-
-%if %{without ocaml_opt}
-%define▸▸       no_install_post_strip▸  1
-# no opt means no native binary, stripping bytecode breaks such programs
-%define▸▸       _enable_debug_packages▸ 0
+# not yet available on x32 (ocaml 4.02.1), update when upstream will support it
+%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
+%undefine      with_ocaml_opt
 %endif
 
 %define                module  %{module}
@@ -30,14 +24,19 @@ BuildRequires:      ocaml >= 3.04-7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                debug_package   %{nil}
+%if %{without ocaml_opt}
+%define                no_install_post_strip   1
+# no opt means no native binary, stripping bytecode breaks such programs
+%define                _enable_debug_packages  0
+%endif
 
 %description
 This package contains files needed to run bytecode executables using
-this library.
+TEMPLATE library.
 
 %description -l pl.UTF-8
 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
-używających tej biblioteki.
+używających biblioteki TEMPLATE.
 
 %package devel
 Summary:       TEMPLATE binding for OCaml - development part
@@ -52,7 +51,7 @@ TEMPLATE library.
 
 %description devel -l pl.UTF-8
 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
-TEMPLATE biblioteki.
+biblioteki TEMPLATE.
 
 %prep
 %setup -q -n %{module}-%{version}
@@ -85,15 +84,21 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/ocaml/stublibs/*.so
+%dir %{_libdir}/ocaml/%{module}
+%{_libdir}/ocaml/%{module}/*.cma
+%if %{with ocaml_opt}
+%attr(755,root,root) %{_libdir}/ocaml/%{module}/*.cmxs
+%endif
 
 %files devel
 %defattr(644,root,root,755)
 %doc LICENSE
-%{_libdir}/ocaml/%{module}/*.cm[xi]
+%{_libdir}/ocaml/%{module}/*.cmi
 %{_libdir}/ocaml/%{module}/*.cmo
 %{_libdir}/ocaml/%{module}/*.mli
 %if %{with ocaml_opt}
 %{_libdir}/ocaml/%{module}/*.[ao]
+%{_libdir}/ocaml/%{module}/*.cmx
 %{_libdir}/ocaml/%{module}/*.cmxa
 %endif
 %{_libdir}/ocaml/site-lib/%{module}
This page took 0.270363 seconds and 4 git commands to generate.