]> git.pld-linux.org Git - projects/template-specs.git/blame - php4-pecl.spec
pecl: add example how to make failed tests as XFAIL
[projects/template-specs.git] / php4-pecl.spec
CommitLineData
9c1382a2
ER
1%define _modname -
2%define _status -
9c1382a2 3Summary: %{_modname} -
ce39d734 4Summary(pl.UTF-8): %{_modname} -
c1b0fa36 5Name: php4-pecl-%{_modname}
9c1382a2
ER
6Version: 1.0
7Release: 1
8License: PHP 2.02
9Group: Development/Languages/PHP
10Source0: http://pecl.php.net/get/%{_modname}-%{version}.tgz
11URL: http://pecl.php.net/package/Modname/
76f4ce5a 12BuildRequires: php4-devel >= 3:4.0.0
7c5d3695 13BuildRequires: rpmbuild(macros) >= 1.519
29f9e4d2 14Requires: php4-common >= 3:4.4.0-3
783f2229 15%{?requires_php_extension}
9c1382a2
ER
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
9c1382a2
ER
18%description
19
20In PECL status of this extension is: %{_status}.
21
9be49f18 22%description -l pl.UTF-8
9c1382a2
ER
23
24To rozszerzenie ma w PECL status: %{_status}.
25
26%prep
27%setup -q -c
f8cfa67b 28mv %{_modname}-%{version}/* .
9c1382a2
ER
29
30%build
9c1382a2
ER
31phpize
32%configure
33%{__make}
34
35%install
36rm -rf $RPM_BUILD_ROOT
3dbbb463 37install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
9c1382a2 38
852624ea 39%{__make} install \
852624ea 40 INSTALL_ROOT=$RPM_BUILD_ROOT \
6e284c47
ER
41 EXTENSION_DIR=%{php_extensiondir}
42cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
01382157
ER
43; Enable %{_modname} extension module
44extension=%{_modname}.so
45EOF
9c1382a2
ER
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%post
6e284c47 51%php4_webserver_restart
9c1382a2 52
01382157
ER
53%postun
54if [ "$1" = 0 ]; then
6e284c47 55 %php4_webserver_restart
9c1382a2
ER
56fi
57
58%files
59%defattr(644,root,root,755)
f8cfa67b 60%doc CREDITS EXPERIMENTAL TODO README
6e284c47
ER
61%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
62%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.842147 seconds and 4 git commands to generate.