]> git.pld-linux.org Git - projects/template-specs.git/blame - php-pecl.spec
update to use _noautoreq_pear
[projects/template-specs.git] / php-pecl.spec
CommitLineData
fc1df23f
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
9ec83f18 5%define php_name php%{?php_suffix}
fc1df23f
ER
6%define modname -
7Summary: %{modname} -
8Summary(pl.UTF-8): %{modname} -
9ec83f18 9Name: %{php_name}-pecl-%{modname}
a7223ec4
AG
10Version: 1.0
11Release: 1
4099af7d 12License: PHP 3.01
a7223ec4 13Group: Development/Languages/PHP
fc1df23f 14Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
dc5e1efb 15# Source0-md5: -
9ec83f18
ER
16URL: http://pecl.php.net/package/modname/
17BuildRequires: %{php_name}-devel
3ad11c3e 18BuildRequires: rpmbuild(macros) >= 1.666
672c5afc 19%{?requires_php_extension}
a7223ec4
AG
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
a7223ec4
AG
22%description
23
9be49f18 24%description -l pl.UTF-8
a7223ec4 25
a7223ec4 26%prep
05e722ff 27%setup -qc
fc1df23f 28mv %{modname}-%{version}/* .
a7223ec4
AG
29
30%build
a7223ec4
AG
31phpize
32%configure
33%{__make}
34
35%install
36rm -rf $RPM_BUILD_ROOT
f6dd55ea 37install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
9c71ffdc
ER
38install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
39install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
a7223ec4 40
852624ea 41%{__make} install \
0ec203b9
ER
42 EXTENSION_DIR=%{php_extensiondir} \
43 INSTALL_ROOT=$RPM_BUILD_ROOT
01c11931
ER
44
45install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
fc1df23f
ER
46cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
47; Enable %{modname} extension module
48extension=%{modname}.so
ceb2ba66 49EOF
a7223ec4 50
68c7fa4c 51install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
9c71ffdc
ER
52cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
a7223ec4
AG
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%post
6e284c47 58%php_webserver_restart
a7223ec4 59
ceb2ba66
AG
60%postun
61if [ "$1" = 0 ]; then
6e284c47 62 %php_webserver_restart
a7223ec4
AG
63fi
64
65%files
66%defattr(644,root,root,755)
f8cfa67b 67%doc CREDITS EXPERIMENTAL
fc1df23f
ER
68%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
69%attr(755,root,root) %{php_extensiondir}/%{modname}.so
9c71ffdc 70%{_examplesdir}/%{name}-%{version}
This page took 0.393299 seconds and 4 git commands to generate.