]> git.pld-linux.org Git - projects/template-specs.git/blame - lib.spec
move destdir to install section
[projects/template-specs.git] / lib.spec
CommitLineData
3cb1cd3d 1#
66df3cad
ER
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
aed9d573 4%bcond_without static_libs # don't build static libraries
66df3cad 5#
f9986cd5 6Summary: -
ce39d734 7Summary(pl.UTF-8): -
3f8f5e5b
ER
8Name: ---
9Version: 0.1
10Release: 0.1
f9986cd5
JB
11License: - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12Group: Libraries
13Source0: %{name}-%{version}.tar.gz
14# Source0-md5: -
3f8f5e5b
ER
15#Patch0: %{name}-what.patch
16#URL: -
17#BuildRequires: -
c53387e8
ER
18#BuildRequires: autoconf
19#BuildRequires: automake
20#BuildRequires: intltool
21#BuildRequires: libtool
3f8f5e5b
ER
22#Requires(postun): -
23#Requires(pre,post): -
24#Requires(preun): -
25#Requires: -
26#Provides: -
27#Obsoletes: -
28#Conflicts: -
f9986cd5
JB
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
a1a32384
ER
31# do not keep them in newly created specs
32# these are only here to help fixing quickly broken specs
33%define filterout_ld -Wl,--no-copy-dt-needed-entries
34%define filterout_ld -Wl,--as-needed
35
20667fb2 36# Ignore file in __spec_install_post_check_so
5346ce74 37BuildRequires: rpmbuild(macros) >= 1.583
e24df1c5 38%define skip_post_check_so libunresolved.so.*
20667fb2 39
f9986cd5
JB
40%description
41
3f8f5e5b 42#%description -l pl.UTF-8
f9986cd5 43
41119926 44%package common
ca8abdb7
TP
45Summary: Common files for %{name} library
46Summary(pl.UTF-8): Wspólne pliki biblioteki %{name}
41119926
TP
47Group: Libraries
48Requires: %{name} = %{version}-%{release}
49
50%description common
ca8abdb7 51Common files for %{name} library.
41119926
TP
52
53%description common -l pl.UTF-8
ca8abdb7 54Wspólne pliki biblioteki %{name}.
41119926 55
f9986cd5 56%package devel
ca8abdb7
TP
57Summary: Header files for %{name} library
58Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
f9986cd5 59Group: Development/Libraries
d7dd7729 60Requires: %{name} = %{version}-%{release}
f9986cd5
JB
61
62%description devel
ca8abdb7 63Header files for %{name} library.
f9986cd5 64
9be49f18 65%description devel -l pl.UTF-8
ca8abdb7 66Pliki nagłówkowe biblioteki %{name}.
f9986cd5
JB
67
68%package static
ca8abdb7
TP
69Summary: Static %{name} library
70Summary(pl.UTF-8): Statyczna biblioteka %{name}
f9986cd5 71Group: Development/Libraries
d7dd7729 72Requires: %{name}-devel = %{version}-%{release}
f9986cd5
JB
73
74%description static
ca8abdb7 75Static %{name} library.
f9986cd5 76
9be49f18 77%description static -l pl.UTF-8
ca8abdb7 78Statyczna biblioteka %{name}.
f9986cd5 79
66df3cad 80%package apidocs
ca8abdb7
TP
81Summary: %{name} API documentation
82Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
66df3cad
ER
83Group: Documentation
84
85%description apidocs
e077345b 86API documentation for %{name} library.
66df3cad 87
3cb1cd3d 88%description apidocs -l pl.UTF-8
ca8abdb7 89Dokumentacja API biblioteki %{name}.
3cb1cd3d 90
f9986cd5
JB
91%prep
92%setup -q
1c854c4b 93#%patch0 -p1
f9986cd5
JB
94
95%build
c42a30cf
JB
96# if ac/am/lt/* rebuilding is necessary, do it in this order and add
97# appropriate BuildRequires
98#%{__libtoolize}
99#%{__aclocal}
100#%{__autoconf}
101#%{__autoheader}
102#%{__automake}
f6de6810
ER
103%configure \
104 %{!?with_static_libs:--disable-static}
f9986cd5
JB
105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109# create directories if necessary
110#install -d $RPM_BUILD_ROOT
111
112%{__make} install \
113 DESTDIR=$RPM_BUILD_ROOT
114
14750145
JB
115# if library provides pkgconfig file containing proper {Requires,Libs}.private
116# then remove .la pollution
4b532792
JR
117#%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
118
f9986cd5
JB
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post -p /sbin/ldconfig
123%postun -p /sbin/ldconfig
124
125%files
126%defattr(644,root,root,755)
41119926
TP
127%doc AUTHORS CREDITS README THANKS
128%attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
129%attr(755,root,root) %ghost %{_libdir}/%{name}.so.N
130
131%files common
132%defattr(644,root,root,755)
133%attr(755,root,root) %{_bindir}/%{name}*
f9986cd5
JB
134%{_datadir}/%{name}
135
136%files devel
137%defattr(644,root,root,755)
41119926
TP
138%doc devel-doc/* ChangeLog NEWS TODO
139%attr(755,root,root) %{_libdir}/%{name}.so
14750145
JB
140# if no pkgconfig support, or it misses .private deps, then include .la file
141#%{_libdir}/libFOO.la
41119926
TP
142%{_includedir}/%{name}
143%{_aclocaldir}/%{name}.m4
144%{_pkgconfigdir}/%{name}.pc
f9986cd5 145
f6de6810 146%if %{with static_libs}
f9986cd5
JB
147%files static
148%defattr(644,root,root,755)
41119926 149%{_libdir}/%{name}.a
f6de6810 150%endif
66df3cad 151
a5f7d790 152%if %{with apidocs}
66df3cad
ER
153%files apidocs
154%defattr(644,root,root,755)
155%doc apidocs/*
a5f7d790 156%endif
This page took 0.095422 seconds and 4 git commands to generate.