]> git.pld-linux.org Git - projects/template-specs.git/blame - kernel-module.spec
- adapterized. ipv6 comments. VERSION was for trigger not for package version
[projects/template-specs.git] / kernel-module.spec
CommitLineData
f9ab3660 1#
5ff61201
AM
2# Replace MODULE_NAME with real module name and MODULE_DIR
3# with required directory name.
4#
f9ab3660
PS
5# Conditional build:
6%bcond_without dist_kernel # allow non-distribution kernel
7%bcond_without kernel # don't build kernel modules
8%bcond_without smp # don't build SMP module
9%bcond_without userspace # don't build userspace module
10%bcond_with verbose # verbose build (V=1)
4e1a22e1
PS
11
12%if %{without kernel}
13%undefine with_dist_kernel
14%endif
15
f9ab3660
PS
16#
17# main package.
18#
62d8299f
PS
19Summary: -
20Summary(pl): -
21Name: -
22Version: -
96f971dd 23%define _rel 0.1
6e5f56d1 24Release: %{_rel}
96f971dd
ER
25Epoch: 0
26#License: - (enter GPL/LGPL/BSD/BSD-like/other license name here)
62d8299f
PS
27Group: -
28Vendor: -
29Icon: -
30Source0: %{name}-%{version}.tar.gz
31# Source0-md5: -
96f971dd 32#Source1: -
62d8299f 33# Source1-md5: -
96f971dd
ER
34#Patch0: %{name}-what.patch
35#URL: -
063b9033
JB
36%if %{with kernel}
37%{?with_dist_kernel:BuildRequires: kernel-module-build >= 2.6.7}
f7e95648 38BuildRequires: rpmbuild(macros) >= 1.217
063b9033 39%endif
96f971dd
ER
40#BuildRequires: -
41#PreReq: -
42#Requires(pre,post): -
43#Requires(preun): -
44#Requires(postun): -
45#Requires: -
46#Provides: -
47#Obsoletes: -
48#Conflicts: -
62d8299f
PS
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52
53%description -l pl
f9ab3660
PS
54
55# kernel subpackages.
56
96f971dd
ER
57%package -n kernel-MODULE_DIR-MODULE_NAME
58Summary: Linux driver for MODULE_NAME
59Summary(pl): Sterownik dla Linuksa do MODULE_NAME
f9ab3660
PS
60Release: %{_rel}@%{_kernel_ver_str}
61Group: Base/Kernel
f9ab3660 62Requires(post,postun): /sbin/depmod
8fad52ee
PS
63%if %{with dist_kernel}
64%requires_releq_kernel_up
b76f8d77 65Requires(postun): %releq_kernel_up
8fad52ee 66%endif
f9ab3660 67
96f971dd
ER
68%description -n kernel-MODULE_DIR-MODULE_NAME
69This is driver for MODULE_NAME for Linux.
f9ab3660
PS
70
71This package contains Linux module.
72
96f971dd
ER
73%description -n kernel-MODULE_DIR-MODULE_NAME -l pl
74Sterownik dla Linuksa do MODULE_NAME.
f9ab3660
PS
75
76