]> git.pld-linux.org Git - projects/template-specs.git/blame - drupal-mod.spec
pecl: add example how to make failed tests as XFAIL
[projects/template-specs.git] / drupal-mod.spec
CommitLineData
d8505666
ER
1%define modname ...
2Summary: Drupal ... Module
be6a9dea
ER
3Name: drupal-mod-%{modname}
4Version: 4.6.0
5Release: 0.1
d8505666 6License: GPL / GPL v2
be6a9dea
ER
7Group: Applications/WWW
8Source0: http://drupal.org/files/projects/%{modname}-%{version}.tar.gz
9# Source0-md5: 0d218124ee86584375d4981ee1646a06
10URL: http://drupal.org/project/image
62794dbf 11# for %%banner
be6a9dea
ER
12#BuildRequires: rpmbuild(macros) >= 1.194
13Requires: drupal >= 4.6.0
14BuildArch: noarch
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%define _sysconfdir /etc/drupal
18%define _drupaldir %{_datadir}/drupal
19%define _moddir %{_drupaldir}/modules
20%define _incdir %{_drupaldir}/includes
21%define _htdocs %{_drupaldir}/htdocs
22%define _podir %{_drupaldir}/po/%{modname}
23%define _htmlmoddir %{_htdocs}/modules
d8505666 24%define _htmlmoddir %{_htdocs}/modules/%{modname}
be6a9dea
ER
25
26%description
27
28%prep
29%setup -q -n %{modname}
d8505666
ER
30#rm -f LICENSE.txt # GPL
31#rm -f LICENSE.txt # GPL v2
be6a9dea
ER
32
33%install
34rm -rf $RPM_BUILD_ROOT
35install -d $RPM_BUILD_ROOT{%{_moddir},%{_podir},%{_htmlmoddir},%{_incdir},%{_htdocs}}
d8505666 36install -d $RPM_BUILD_ROOT%{_moddir}
be6a9dea
ER
37
38install *.module $RPM_BUILD_ROOT%{_moddir}
39install *.inc $RPM_BUILD_ROOT%{_incdir}
40install *.css $RPM_BUILD_ROOT%{_htmlmoddir}
41cp -a po/*.po $RPM_BUILD_ROOT%{_podir}
42
43%clean
44rm -rf $RPM_BUILD_ROOT
45
46%post
47if [ "$1" = 1 ]; then
48%banner -e %{name} <<EOF
49If you want to use localization, then you need to upload .po files
50from %{_podir} via drupal locatization admin.
51
52EOF
53fi
54
d8505666
ER
55#%post
56if [ "$1" = 1 ]; then
57%banner -e %{name} <<EOF
58To create ... MySQL database tables, import:
59zcat %{_docdir}/%{name}-%{version}/%{modname}.mysql.gz | mysql drupal
60For Postgresql file is:
61%{_docdir}/%{name}-%{version}/%{modname}.pgsql.gz
62EOF
63fi
64
be6a9dea
ER
65%files
66%defattr(644,root,root,755)
67%doc *.txt po/*.pot *.php
d8505666
ER
68%doc *.txt
69%doc %{modname}.{mysql,pgsql}
70%doc %{modname}.mysql
be6a9dea
ER
71%{_moddir}/*.module
72%{_incdir}/*.inc
73%{_podir}
74%{_htmlmoddir}/*.css
This page took 0.909775 seconds and 4 git commands to generate.