]> git.pld-linux.org Git - packages/zsh.git/commitdiff
- do not use fucking terminal sequences!!!
authorTomasz Pala <gotar@pld-linux.org>
Tue, 16 Sep 2003 09:04:52 +0000 (09:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added bindkey for quoted insert,
- two aliases for mc not to mess history,
- release 6.

Changed files:
    zsh.spec -> 1.87

zsh.spec

index 8f36eec94496de75099bea617c0e464b69968605..92f8bd8ae9a2d1f1d8436c3c2139d2d4a1eb90a7 100644 (file)
--- a/zsh.spec
+++ b/zsh.spec
@@ -13,7 +13,7 @@ Summary(tr):  Geli
 Summary(uk):   ëÏÍÁÎÄÎÉÊ ÐÒÏÃÅÓÏÒ (shell) ÓÈÏÖÉÊ ÎÁ ksh, ÁÌÅ Ú ÐÏËÒÁÝÅÎÎÑÍÉ
 Name:          zsh
 Version:       4.1.1
-Release:       5
+Release:       6
 License:       BSD-like
 Group:         Applications/Shells
 URL:           http://www.zsh.org/
@@ -182,20 +182,15 @@ cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/zshrc
 
 # Aliases:
 alias which=whence
+alias cd='builtin cd'
+alias precmd=' precmd'
 
 # Setup key bindings:
 bindkey -e >/dev/null 2>&1
-bindkey "^[[1~" beginning-of-line >/dev/null 2>&1
-bindkey "^[[H" beginning-of-line >/dev/null 2>&1
-bindkey "^[[4~" end-of-line >/dev/null 2>&1
-bindkey "^[[F" end-of-line >/dev/null 2>&1
-bindkey "^[[3~" delete-char >/dev/null 2>&1
-bindkey "^[[5~" history-search-backward >/dev/null 2>&1
-bindkey "^[[6~" history-search-forward >/dev/null 2>&1
-
-# xterm:
+
 bindkey \`tput khome\` beginning-of-line >/dev/null 2>&1
 bindkey \`tput kend\` end-of-line >/dev/null 2>&1
+bindkey \`tput kich1\` quoted-insert >/dev/null 2>&1
 bindkey \`tput kdch1\` delete-char >/dev/null 2>&1
 bindkey \`tput kpp\` up-history >/dev/null 2>&1
 bindkey \`tput knp\` end-of-history >/dev/null 2>&1
@@ -203,12 +198,6 @@ bindkey \`tput kcuu1\` history-beginning-search-backward >/dev/null 2>&1
 bindkey \`tput kcud1\` history-beginning-search-forward >/dev/null 2>&1
 
 case "$TERM" in
-       aterm)
-               bindkey '^[[A' up-line-or-history >/dev/null 2>&1
-               bindkey '^[[B' down-line-or-history >/dev/null 2>&1
-               bindkey '^[[D' backward-char >/dev/null 2>&1
-               bindkey '^[[C' forward-char >/dev/null 2>&1
-               ;;
        xterm*)
                precmd () { print -Pn "\e]0;%n@%m: %~\a"i; }
                ;;
This page took 0.105017 seconds and 4 git commands to generate.