]> git.pld-linux.org Git - packages/zsh.git/commitdiff
when completing ssh host always use both known_hosts and config; rel 3 master auto/th/zsh-5.9-3
authorJan Palus <atler@pld-linux.org>
Wed, 12 Jul 2023 12:45:20 +0000 (14:45 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 12 Jul 2023 12:45:20 +0000 (14:45 +0200)
by default zsh skips config if known_hosts has any match. also see:

https://www.zsh.org/mla/workers/2022/msg01475.html

comp-all-ssh-hosts.patch [new file with mode: 0644]
zsh.spec

diff --git a/comp-all-ssh-hosts.patch b/comp-all-ssh-hosts.patch
new file mode 100644 (file)
index 0000000..d405dc1
--- /dev/null
@@ -0,0 +1,15 @@
+--- zsh-5.9/Completion/Unix/Type/_ssh_hosts.orig       2022-05-08 08:18:22.000000000 +0200
++++ zsh-5.9/Completion/Unix/Type/_ssh_hosts    2023-07-12 14:35:18.406156647 +0200
+@@ -6,10 +6,10 @@
+ # If users-hosts matches, we shouldn't complete anything else.
+ if [[ "$IPREFIX" == *@ ]]; then
+-  _combination -s '[:@]' my-accounts users-hosts "users=${IPREFIX/@}" hosts "$@" && return
++  _combination -s '[:@]' my-accounts users-hosts "users=${IPREFIX/@}" hosts "$@" #&& return
+ else
+   _combination -s '[:@]' my-accounts users-hosts \
+-    ${opt_args[-l]:+"users=${opt_args[-l]:q}"} hosts "$@" && return
++    ${opt_args[-l]:+"users=${opt_args[-l]:q}"} hosts "$@" #&& return
+ fi
+ if (( ind = ${words[(I)-F]} )); then
+   config=${~words[ind+1]} 2>/dev/null
index 87c7f99b6df063969c307968b64dd7cc06834ced..e57cc3bac0d76a7e669faabbb87b7ecca4f538fa 100644 (file)
--- a/zsh.spec
+++ b/zsh.spec
@@ -16,7 +16,7 @@ Summary(tr.UTF-8):    Gelişmiş bir BASH sürümü
 Summary(uk.UTF-8):     Командний процесор (shell) схожий на ksh, але з покращеннями
 Name:          zsh
 Version:       5.9
-Release:       2
+Release:       3
 License:       BSD-like
 Group:         Applications/Shells
 Source0:       https://downloads.sourceforge.net/zsh/%{name}-%{version}.tar.xz
@@ -29,7 +29,8 @@ Source4:      %{name}rc
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-addons.patch
 Patch2:                %{name}-paths.patch
-Patch4:                %{name}-nolibs.patch
+Patch3:                %{name}-nolibs.patch
+Patch4:                comp-all-ssh-hosts.patch
 URL:           http://www.zsh.org/
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake
@@ -169,6 +170,7 @@ Podręcznik Użytkownika Z-Shella.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 %patch4 -p1
 
 install %{SOURCE2} .
This page took 0.078194 seconds and 4 git commands to generate.