]> git.pld-linux.org Git - packages/zsh.git/blobdiff - zsh.spec
up to 5.7
[packages/zsh.git] / zsh.spec
index 279de1062a16b3300baa1b2240b0c089f2e40189..45675aa522796ee237f5878135a24b70c1153482 100644 (file)
--- a/zsh.spec
+++ b/zsh.spec
@@ -1,5 +1,8 @@
+#
+# TODO: package http://www.zsh.org/pub/zsh-%{version}-doc.tar.xz
 # Conditional build:
-%bcond_with    static # build static version
+%bcond_with    static  # build static version
+%bcond_without tests   # don't perform "make test"
 #
 Summary:       Enhanced Bourne shell
 Summary(de.UTF-8):     Enhanced Bourne Shell
@@ -12,33 +15,34 @@ Summary(ru.UTF-8):  Командный процессор (shell) похожый
 Summary(tr.UTF-8):     Gelişmiş bir BASH sürümü
 Summary(uk.UTF-8):     Командний процесор (shell) схожий на ksh, але з покращеннями
 Name:          zsh
-Version:       4.3.12
-Release:       2
+Version:       5.7
+Release:       1
 License:       BSD-like
 Group:         Applications/Shells
-Source0:       ftp://sunsite.icm.edu.pl/pub/unix/shells/zsh/%{name}-%{version}.tar.bz2
-# Source0-md5: 7a82c0bf0635e046ca4e9ec1bdef3811
-#Source0:      ftp://ftp.zsh.org/pub/%{name}-%{version}.tar.bz2
+Source0:       http://downloads.sourceforge.net/zsh/%{name}-%{version}.tar.xz
+# Source0-md5: 4f855abd9be566bcb204e407cf571d09
 Source1:       %{name}.1.pl
 Source2:       http://zsh.sunsite.dk/Guide/%{name}guide.pdf
 # Source2-md5: 70cc3760dd8140f9aed693d484cd87dc
 Source3:       zprofile
 Source4:       %{name}rc
-Patch0:                %{name}-info.patch
 Patch1:                %{name}-addons.patch
 Patch2:                %{name}-paths.patch
 Patch3:                %{name}-completions.patch
 Patch4:                %{name}-nolibs.patch
 URL:           http://www.zsh.org/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.60
 BuildRequires: automake
+BuildRequires: gdbm-devel
 %{?with_static:BuildRequires:  glibc-static}
 BuildRequires: libcap-devel
 BuildRequires: ncurses-devel >= 5.1
 %{?with_static:BuildRequires:  ncurses-static}
 BuildRequires: pcre-devel
 BuildRequires: rpmbuild(macros) >= 1.470
+BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo
+BuildRequires: xz
 BuildRequires: yodl
 Requires(post,preun):  grep
 Requires(preun):       fileutils
@@ -72,7 +76,7 @@ shell) に似ていますが,かなり拡張されています. zsh
 グ可能なコマンド補完機能, (動的ロードされる)シェル機能, ヒストリ機構
 などを持ちます.
 
-%description  -l hu.UTF-8
+%description -l hu.UTF-8
 zsh a Bourne shell egy kiterjesztett verziója csh kiegészítésekkel és
 a ksh, bash és csh legtöbb lehetőségével felvértezve.
 
@@ -159,7 +163,6 @@ Podręcznik Użytkownika Z-Shella.
 
 %prep
 %setup -q
-%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
@@ -185,7 +188,7 @@ LDFLAGS="%{rpmldflags} -static"
        --disable-dynamic
 %{__make} \
        DLLDFLAGS=""
-mv -f Src/zsh Src/zsh.static
+%{__mv} Src/zsh Src/zsh.static
 %{__make} clean || :
 LDFLAGS="%{rpmldflags}"
 %endif
@@ -196,13 +199,19 @@ LDFLAGS="%{rpmldflags}"
        --enable-cap \
        --enable-pcre \
        --enable-multibyte \
-       --with-term-lib="tinfo" \
-       --with-curses-terminfo \
        --with-tcsetpgrp
 %{__make}
 
 cd Doc
 makeinfo zsh.texi
+cd ..
+
+%if %{with tests}
+if ! tty; then
+       %{__rm} Test/{C02cond,Y01completion,Y02compmatch,Y03arguments,V08zpty,W02jobs,X02zlevi,X03zlebindkey}.ztst
+fi
+%{__make} test
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -219,7 +228,7 @@ touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogin,zlogout,zprofile,zshenv,zshrc}.zwc
 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
 
-%{__rm} Etc/Makefile*
+%{__rm} -f Etc/Makefile*
 find Functions Util StartupFiles -name .distfiles -o -name .cvsignore | xargs rm -f
 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/zsh.1
 
@@ -268,22 +277,20 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc Etc/* README LICENCE ChangeLog META-FAQ Util StartupFiles
+%doc Etc/* ChangeLog FEATURES LICENCE META-FAQ README Misc StartupFiles Util
 %attr(755,root,root) %{_bindir}/zsh
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/*[!w]?
-%ghost %{_sysconfdir}/*.zwc
-%dir %{_libdir}/zsh
-%dir %{_libdir}/zsh/%{version}*
-%dir %{_datadir}/zsh
-%dir %{_datadir}/zsh/site-functions
-%{_datadir}/zsh/latest
+%ghost %{_sysconfdir}/z*.zwc
 %dir %{_datadir}/zsh/%{version}*
-%dir %{_datadir}/zsh/%{version}*/scripts
-%{_datadir}/zsh/%{version}*/scripts/newuser
 %dir %{_datadir}/zsh/%{version}*/functions
 %{_datadir}/zsh/%{version}*/functions/[!_c]*
 %{_datadir}/zsh/%{version}*/functions/c[!o]*
 %{_datadir}/zsh/%{version}*/functions/co[!m]*
+%{_datadir}/zsh/%{version}*/help
+%{_datadir}/zsh/%{version}*/scripts
+%{_datadir}/zsh/latest
+%dir %{_libdir}/zsh
+%dir %{_libdir}/zsh/%{version}*
 %attr(755,root,root) %{_libdir}/zsh/%{version}*/*
 %{_infodir}/zsh.info*
 %{_mandir}/man1/zsh*.1*
This page took 0.147074 seconds and 4 git commands to generate.