]> git.pld-linux.org Git - packages/zsh.git/blobdiff - zsh.spec
up to 5.7
[packages/zsh.git] / zsh.spec
index 0b5d0e3247e4eab40e3aa43897417c65aa189635..45675aa522796ee237f5878135a24b70c1153482 100644 (file)
--- a/zsh.spec
+++ b/zsh.spec
@@ -1,7 +1,8 @@
 #
+# TODO: package http://www.zsh.org/pub/zsh-%{version}-doc.tar.xz
 # Conditional build:
 %bcond_with    static  # build static version
-%bcond_without tests
+%bcond_without tests   # don't perform "make test"
 #
 Summary:       Enhanced Bourne shell
 Summary(de.UTF-8):     Enhanced Bourne Shell
@@ -14,19 +15,17 @@ Summary(ru.UTF-8):  Командный процессор (shell) похожый
 Summary(tr.UTF-8):     Gelişmiş bir BASH sürümü
 Summary(uk.UTF-8):     Командний процесор (shell) схожий на ksh, але з покращеннями
 Name:          zsh
-Version:       5.0.2
+Version:       5.7
 Release:       1
 License:       BSD-like
 Group:         Applications/Shells
-Source0:       ftp://sunsite.icm.edu.pl/pub/unix/shells/zsh/%{name}-%{version}.tar.bz2
-# Source0-md5: b8f2ad691acf58b3252225746480dcad
-#Source0:      ftp://ftp.zsh.org/pub/%{name}-%{version}.tar.bz2
+Source0:       http://downloads.sourceforge.net/zsh/%{name}-%{version}.tar.xz
+# Source0-md5: 4f855abd9be566bcb204e407cf571d09
 Source1:       %{name}.1.pl
 Source2:       http://zsh.sunsite.dk/Guide/%{name}guide.pdf
 # Source2-md5: 70cc3760dd8140f9aed693d484cd87dc
 Source3:       zprofile
 Source4:       %{name}rc
-Patch0:                %{name}-info.patch
 Patch1:                %{name}-addons.patch
 Patch2:                %{name}-paths.patch
 Patch3:                %{name}-completions.patch
@@ -41,7 +40,9 @@ BuildRequires:        ncurses-devel >= 5.1
 %{?with_static:BuildRequires:  ncurses-static}
 BuildRequires: pcre-devel
 BuildRequires: rpmbuild(macros) >= 1.470
+BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo
+BuildRequires: xz
 BuildRequires: yodl
 Requires(post,preun):  grep
 Requires(preun):       fileutils
@@ -75,7 +76,7 @@ shell) に似ていますが,かなり拡張されています. zsh
 グ可能なコマンド補完機能, (動的ロードされる)シェル機能, ヒストリ機構
 などを持ちます.
 
-%description  -l hu.UTF-8
+%description -l hu.UTF-8
 zsh a Bourne shell egy kiterjesztett verziója csh kiegészítésekkel és
 a ksh, bash és csh legtöbb lehetőségével felvértezve.
 
@@ -162,7 +163,6 @@ Podręcznik Użytkownika Z-Shella.
 
 %prep
 %setup -q
-%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
@@ -188,7 +188,7 @@ LDFLAGS="%{rpmldflags} -static"
        --disable-dynamic
 %{__make} \
        DLLDFLAGS=""
-mv -f Src/zsh Src/zsh.static
+%{__mv} Src/zsh Src/zsh.static
 %{__make} clean || :
 LDFLAGS="%{rpmldflags}"
 %endif
@@ -206,7 +206,12 @@ cd Doc
 makeinfo zsh.texi
 cd ..
 
-%{?with_tests:%{__make} test}
+%if %{with tests}
+if ! tty; then
+       %{__rm} Test/{C02cond,Y01completion,Y02compmatch,Y03arguments,V08zpty,W02jobs,X02zlevi,X03zlebindkey}.ztst
+fi
+%{__make} test
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -223,7 +228,7 @@ touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogin,zlogout,zprofile,zshenv,zshrc}.zwc
 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
 
-%{__rm} Etc/Makefile*
+%{__rm} -f Etc/Makefile*
 find Functions Util StartupFiles -name .distfiles -o -name .cvsignore | xargs rm -f
 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/zsh.1
 
@@ -272,22 +277,20 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc Etc/* README LICENCE ChangeLog META-FAQ Util StartupFiles
+%doc Etc/* ChangeLog FEATURES LICENCE META-FAQ README Misc StartupFiles Util
 %attr(755,root,root) %{_bindir}/zsh
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/*[!w]?
-%ghost %{_sysconfdir}/*.zwc
-%dir %{_libdir}/zsh
-%dir %{_libdir}/zsh/%{version}*
-%dir %{_datadir}/zsh
-%dir %{_datadir}/zsh/site-functions
-%{_datadir}/zsh/latest
+%ghost %{_sysconfdir}/z*.zwc
 %dir %{_datadir}/zsh/%{version}*
-%dir %{_datadir}/zsh/%{version}*/scripts
-%{_datadir}/zsh/%{version}*/scripts/newuser
 %dir %{_datadir}/zsh/%{version}*/functions
 %{_datadir}/zsh/%{version}*/functions/[!_c]*
 %{_datadir}/zsh/%{version}*/functions/c[!o]*
 %{_datadir}/zsh/%{version}*/functions/co[!m]*
+%{_datadir}/zsh/%{version}*/help
+%{_datadir}/zsh/%{version}*/scripts
+%{_datadir}/zsh/latest
+%dir %{_libdir}/zsh
+%dir %{_libdir}/zsh/%{version}*
 %attr(755,root,root) %{_libdir}/zsh/%{version}*/*
 %{_infodir}/zsh.info*
 %{_mandir}/man1/zsh*.1*
This page took 0.07126 seconds and 4 git commands to generate.