]> git.pld-linux.org Git - packages/zfs.git/blobdiff - zfs.spec
- fix building with kernel 5.8
[packages/zfs.git] / zfs.spec
index 6fc1084c682475b5ad955dc54d4561f91a61f542..3034720fed79ca3301cfdbc1a50e4e86ffc18322 100644 (file)
--- a/zfs.spec
+++ b/zfs.spec
@@ -1,51 +1,89 @@
-# TODO: PLDify init script
+# TODO:
+# - PLDify init script
+# - unpackaged initramfs-tools support:
+#   /usr/share/initramfs-tools/conf-hooks.d/zfs
+#   /usr/share/initramfs-tools/hooks/zfs
+#   /usr/share/initramfs-tools/scripts/zfs
 #
 # Conditional build:
-%bcond_without dist_kernel     # allow non-distribution kernel
 %bcond_without kernel          # don't build kernel modules
 %bcond_without userspace       # don't build userspace programs
+%bcond_without python2         # CPython 2.x module
+%bcond_without python3         # CPython 3.x module
 %bcond_with    verbose         # verbose build (V=1)
 #
-%if %{without kernel}
-%undefine      with_dist_kernel
-%endif
-%if "%{_alt_kernel}" != "%{nil}"
-%undefine      with_userspace
+# The goal here is to have main, userspace, package built once with
+# simple release number, and only rebuild kernel packages with kernel
+# version as part of release number, without the need to bump release
+# with every kernel change.
+%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
+%{error:kernel and userspace cannot be built at the same time on PLD builders}
+exit 1
 %endif
+
 %if %{without userspace}
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 %endif
+
+%define                _duplicate_files_terminate_build        0
+
+%define        rel     1
+%define        pname   zfs
 Summary:       Native Linux port of the ZFS filesystem
 Summary(pl.UTF-8):     Natywny linuksowy port systemu plików ZFS
-%define        pname   zfs
-Name:          %{pname}%{_alt_kernel}
-Version:       0.6.3
-%define        rel     1
-Release:       %{rel}
-License:       CDDL (ZFS), GPL v2+ (ZPIOS)
+Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
+Version:       0.8.4
+Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
+License:       CDDL
 Group:         Applications/System
-Source0:       http://archive.zfsonlinux.org/downloads/zfsonlinux/zfs/%{pname}-%{version}.tar.gz
-# Source0-md5: 5bcc32c122934d421eba68e16826637d
-Patch0:                %{name}-link.patch
-URL:           http://zfsonlinux.org/
+Source0:       https://github.com/openzfs/zfs/releases/download/zfs-%{version}/%{pname}-%{version}.tar.gz
+# Source0-md5: f0c203c59c4fcd44187a64758707469f
+Patch0:                x32.patch
+Patch1:                am.patch
+Patch2:                %{pname}-sh.patch
+Patch3:                link.patch
+Patch4:                kernel-5.8.patch
+URL:           https://zfsonlinux.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: libtool
+BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with kernel}
-%{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.26}
-BuildRequires: kernel%{_alt_kernel}-spl-devel >= 0.6.3
-BuildRequires: rpmbuild(macros) >= 1.379
+%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 %endif
 %if %{with userspace}
+# only for mmap_libaio test command
+#BuildRequires:        libaio-devel
 BuildRequires: libblkid-devel
 BuildRequires: libselinux-devel
+# if xdr gets removed from glibc
+#BuildRequires:        libtirpc-devel
 BuildRequires: libuuid-devel
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
+BuildRequires: udev-devel
 BuildRequires: zlib-devel
+%if %{with python2}
+BuildRequires: python-cffi
+BuildRequires: python-modules >= 1:2.6
+BuildRequires: python-setuptools
+%endif
+%if %{with python3}
+BuildRequires: python3-cffi
+BuildRequires: python3-modules >= 1:3.4
+BuildRequires: python3-setuptools
+%endif
+%if %{with python2} || %{with python3}
+BuildRequires: rpm-pythonprov
+%endif
 %endif
 Requires:      %{pname}-libs = %{version}-%{release}
+Obsoletes:     spl < 0.7.9-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                dracutlibdir    %{_prefix}/lib/dracut
+
 %description
 ZFS is an advanced file system and volume manager which was originally
 developed for Solaris and is now maintained by the Illumos community.
@@ -67,6 +105,7 @@ Summary:     ZFS on Linux libraries
 Summary(pl.UTF-8):     Biblioteki ZFS-a dla Linuksa
 License:       CDDL
 Group:         Libraries
+Requires(post,postun): /sbin/ldconfig
 
 %description libs
 ZFS on Linux libraries.
@@ -116,41 +155,138 @@ ZFS support for Dracut.
 %description -n dracut-zfs -l pl.UTF-8
 Obsługa ZFS-a dla Dracuta.
 
-%package -n kernel%{_alt_kernel}-zfs
-Summary:       ZFS Linux kernel modules
-Summary(pl.UTF-8):     ZFS - moduły jądra Linuksa
-Release:       %{rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-Requires(post,postun): /sbin/depmod
-%if %{with dist_kernel}
-%requires_releq_kernel
-Requires(postun):      %releq_kernel
-%endif
+%package -n python-pyzfs
+Summary:       Python 2 wrapper for libzfs_core C library
+Summary(pl.UTF-8):     Interfejs Pythona 2 do biblioteki C libzfs_core
+License:       Apache v2.0
+Group:         Libraries/Python
+Requires:      %{pname}-libs = %{version}-%{release}
 
-%description -n kernel%{_alt_kernel}-zfs
-ZFS Linux kernel modules.
+%description -n python-pyzfs
+Python 2 wrapper for libzfs_core C library.
 
-%description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8
-ZFS - moduły jądra Linuksa.
+%description -n python-pyzfs -l pl.UTF-8
+Interfejs Pythona 2 do biblioteki C libzfs_core.
+
+%package -n python3-pyzfs
+Summary:       Python 3 wrapper for libzfs_core C library
+Summary(pl.UTF-8):     Interfejs Pythona 3 do biblioteki C libzfs_core
+License:       Apache v2.0
+Group:         Libraries/Python
+Requires:      %{pname}-libs = %{version}-%{release}
 
-%package -n kernel%{_alt_kernel}-zfs-devel
+%description -n python3-pyzfs
+Python 3 wrapper for libzfs_core C library.
+
+%description -n python3-pyzfs -l pl.UTF-8
+Interfejs Pythona 3 do biblioteki C libzfs_core.
+
+%package -n kernel-zfs-common-devel
 Summary:       ZFS Linux kernel headers
 Summary(pl.UTF-8):     ZFS - pliki nagłówkowe jądra Linuksa
-Release:       %{rel}@%{_kernel_ver_str}
 Group:         Development/Building
-%{?with_dist_kernel:Requires:  kernel%{_alt_kernel}-headers}
-
-%description -n kernel%{_alt_kernel}-zfs-devel
-ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},
-version %{_kernel_ver}.
-
-%description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8
-ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z
-pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.
+Obsoletes:     kernel-spl-common-devel < 0.7.9-2
+
+%description -n kernel-zfs-common-devel
+ZFS Linux kernel headers common for all PLD kernel versions.
+
+%description -n kernel-zfs-common-devel -l pl.UTF-8
+ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
+wersji jąder PLD.
+
+%define        kernel_pkg()\
+%package -n kernel%{_alt_kernel}-zfs\
+Summary:       ZFS Linux kernel modules\
+Summary(pl.UTF-8):     ZFS - moduły jądra Linuksa\
+Release:       %{rel}@%{_kernel_ver_str}\
+Group:         Base/Kernel\
+Requires(post,postun): /sbin/depmod\
+%requires_releq_kernel\
+Requires(postun):      %releq_kernel\
+\
+%description -n kernel%{_alt_kernel}-zfs\
+ZFS Linux kernel modules.\
+\
+%description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
+ZFS - moduły jądra Linuksa.\
+\
+%package -n kernel%{_alt_kernel}-zfs-devel\
+Summary:       ZFS Linux kernel headers\
+Summary(pl.UTF-8):     ZFS - pliki nagłówkowe jądra Linuksa\
+Release:       %{rel}@%{_kernel_ver_str}\
+Group:         Development/Building\
+Requires:      kernel%{_alt_kernel}-headers\
+Requires:      kernel-zfs-common-devel\
+Obsoletes:     kernel-spl-devel < 0.7.9-2\
+\
+%description -n kernel%{_alt_kernel}-zfs-devel\
+ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
+version %{_kernel_ver}.\
+\
+%description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
+ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
+pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
+\
+%files -n kernel%{_alt_kernel}-zfs\
+%defattr(644,root,root,755)\
+%dir /lib/modules/%{_kernel_ver}/misc/lua\
+/lib/modules/%{_kernel_ver}/misc/lua/zlua.ko*\
+%dir /lib/modules/%{_kernel_ver}/misc/avl\
+/lib/modules/%{_kernel_ver}/misc/avl/zavl.ko*\
+%dir /lib/modules/%{_kernel_ver}/misc/icp\
+/lib/modules/%{_kernel_ver}/misc/icp/icp.ko*\
+%dir /lib/modules/%{_kernel_ver}/misc/nvpair\
+/lib/modules/%{_kernel_ver}/misc/nvpair/znvpair.ko*\
+%dir /lib/modules/%{_kernel_ver}/misc/spl\
+/lib/modules/%{_kernel_ver}/misc/spl/spl.ko*\
+%dir /lib/modules/%{_kernel_ver}/misc/unicode\
+/lib/modules/%{_kernel_ver}/misc/unicode/zunicode.ko*\
+%dir /lib/modules/%{_kernel_ver}/misc/zcommon\
+/lib/modules/%{_kernel_ver}/misc/zcommon/zcommon.ko*\
+%dir /lib/modules/%{_kernel_ver}/misc/zfs\
+/lib/modules/%{_kernel_ver}/misc/zfs/zfs.ko*\
+\
+%files -n kernel%{_alt_kernel}-zfs-devel\
+%defattr(644,root,root,755)\
+/usr/src/zfs-%{version}/%{_kernel_ver}\
+\
+%post  -n kernel%{_alt_kernel}-zfs\
+%depmod %{_kernel_ver}\
+\
+%postun        -n kernel%{_alt_kernel}-zfs\
+%depmod %{_kernel_ver}\
+%{nil}
+
+%define build_kernel_pkg()\
+%configure \\\
+       --disable-silent-rules \\\
+       --with-config="kernel" \\\
+       --with-linux=%{_kernelsrcdir}\\\
+       --with-linux-obj=%{_kernelsrcdir}\
+\
+%{__make} clean\
+%{__make} %{?with_verbose:V=1}\
+p=`pwd`\
+%{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
+%{nil}
+
+%{?with_kernel:%{expand:%create_kernel_packages}}
 
 %prep
-%setup -q
+%setup -q -n %{pname}-%{version}
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
+      cmd/arc_summary/arc_summary2
+
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
+      cmd/arc_summary/arc_summary3 \
+      cmd/arcstat/arcstat \
+      cmd/dbufstat/dbufstat
 
 %build
 %{__libtoolize}
@@ -158,42 +294,106 @@ pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.
 %{__autoconf}
 %{__autoheader}
 %{__automake}
+%{?with_kernel:%{expand:%build_kernel_packages}}
+
+%if %{with userspace}
 %configure \
        --disable-silent-rules \
-       --with-config="%{?with_kernel:%{?with_userspace:all}}%{!?with_kernel:user}%{!?with_userspace:kernel}" \
+       --enable-systemd \
+       --with-config="user" \
        --with-linux=%{_kernelsrcdir} \
        --with-systemdunitdir=%{systemdunitdir} \
        --with-systemdpresetdir=/etc/systemd/system-preset \
+       --with-systemdmodulesloaddir=/etc/modules-load.d \
+       --with-systemdgeneratordir=/lib/systemd/system-generators \
        --with-udevdir=/lib/udev
 
 %{__make} \
        %{?with_verbose:V=1}
 
+%if %{with python2}
+cd contrib/pyzfs
+%py_build
+cd ../..
+%endif
+
+%if %{with python3}
+cd contrib/pyzfs
+%py3_build
+cd ../..
+%endif
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with kernel}
+install -d $RPM_BUILD_ROOT
+cp -a installed/* $RPM_BUILD_ROOT
+# Drop unneeded spl compat links
+%{__rm} -r $RPM_BUILD_ROOT/usr/src/spl-%{version}
+%endif
+
+%if %{with userspace}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
-       DEFAULT_INIT_DIR=/etc/rc.d/init.d \
-       INSTALL_MOD_DIR=misc
+       DEFAULT_INIT_DIR=/etc/rc.d/init.d
+
+%if %{with python2}
+%{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}
+cd contrib/pyzfs
+%py_install
+
+%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
+%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
+
+%py_postclean
+cd ../..
+%{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/libzfs_core/test
+%endif
+
+%if %{with python3}
+%{__rm} -rf $RPM_BUILD_ROOT{%{py3_sitescriptdir},/usr/local/share/python3*}
+cd contrib/pyzfs
+%py3_install
+cd ../..
+%{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/libzfs_core/test
+%endif
+
+install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
+%{__mv} $RPM_BUILD_ROOT%{_npkgconfigdir}/* $RPM_BUILD_ROOT%{_pkgconfigdir}
+
+# Debian specific stuff
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/initramfs-tools
+
+# Package these? These are integration tests of the implementation.
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/zfs/{zfs-tests,test-runner,runfiles}
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{raidz_test,test-runner}.1*
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/raidz_test
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
+
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYRIGHT DISCLAIMER OPENSOLARIS.LICENSE README.markdown
+%doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
 %attr(755,root,root) /sbin/mount.zfs
-%attr(755,root,root) %{_bindir}/arcstat.py
-%attr(755,root,root) %{_bindir}/dbufstat.py
+%attr(755,root,root) %{_bindir}/arc_summary
+%attr(755,root,root) %{_bindir}/arcstat
+%attr(755,root,root) %{_bindir}/dbufstat
+%attr(755,root,root) %{_bindir}/zgenhostid
+%attr(755,root,root) %{_bindir}/zvol_wait
 %attr(755,root,root) %{_sbindir}/fsck.zfs
 %attr(755,root,root) %{_sbindir}/zdb
 %attr(755,root,root) %{_sbindir}/zed
 %attr(755,root,root) %{_sbindir}/zfs
 %attr(755,root,root) %{_sbindir}/zhack
 %attr(755,root,root) %{_sbindir}/zinject
-%attr(755,root,root) %{_sbindir}/zpios
 %attr(755,root,root) %{_sbindir}/zpool
 %attr(755,root,root) %{_sbindir}/zstreamdump
 %attr(755,root,root) %{_sbindir}/ztest
@@ -203,35 +403,45 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_sysconfdir}/zfs/zed.d
 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
-%attr(754,root,root) /etc/rc.d/init.d/zfs
-/usr/lib/modules-load.d/zfs.conf
+%dir %{_sysconfdir}/zfs/zpool.d
+%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zpool.d/*
+%attr(754,root,root) /etc/rc.d/init.d/zfs-import
+%attr(754,root,root) /etc/rc.d/init.d/zfs-mount
+%attr(754,root,root) /etc/rc.d/init.d/zfs-share
+%attr(754,root,root) /etc/rc.d/init.d/zfs-zed
+%config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
+/etc/zfs/zfs-functions
+%config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/zfs.conf
 /etc/systemd/system-preset/50-zfs.preset
-%{systemdunitdir}/zed.service
+/lib/systemd/system-generators/zfs-mount-generator
 %{systemdunitdir}/zfs.target
+%{systemdunitdir}/zfs-import.service
+%{systemdunitdir}/zfs-import.target
 %{systemdunitdir}/zfs-import-cache.service
 %{systemdunitdir}/zfs-import-scan.service
 %{systemdunitdir}/zfs-mount.service
 %{systemdunitdir}/zfs-share.service
+%{systemdunitdir}/zfs-volume-wait.service
+%{systemdunitdir}/zfs-volumes.target
+%{systemdunitdir}/zfs-zed.service
 %attr(755,root,root) /lib/udev/vdev_id
 %attr(755,root,root) /lib/udev/zvol_id
 /lib/udev/rules.d/60-zvol.rules
 /lib/udev/rules.d/69-vdev.rules
 /lib/udev/rules.d/90-zfs.rules
-%dir %{_libdir}/zfs
-%dir %{_libdir}/zfs/zed.d
-%attr(755,root,root) %{_libdir}/zfs/zed.d/*.sh
+%dir %{_libexecdir}/zfs
+%dir %{_libexecdir}/zfs/zed.d
+%attr(755,root,root) %{_libexecdir}/zfs/zed.d/*.sh
+%dir %{_libexecdir}/zfs/zpool.d
+%attr(755,root,root) %{_libexecdir}/zfs/zpool.d/*
 %dir %{_datadir}/zfs
 %attr(755,root,root) %{_datadir}/zfs/*.sh
-%dir %{_datadir}/zfs/zpios-profile
-%attr(755,root,root) %{_datadir}/zfs/zpios-profile/*.sh
-%dir %{_datadir}/zfs/zpios-test
-%attr(755,root,root) %{_datadir}/zfs/zpios-test/*.sh
-%dir %{_datadir}/zfs/zpool-config
-%attr(755,root,root) %{_datadir}/zfs/zpool-config/*.sh
 %{_mandir}/man1/zhack.1*
-%{_mandir}/man1/zpios.1*
 %{_mandir}/man1/ztest.1*
+%{_mandir}/man1/zvol_wait.1*
+%{_mandir}/man5/spl-module-parameters.5*
 %{_mandir}/man5/vdev_id.conf.5*
+%{_mandir}/man5/zfs-events.5*
 %{_mandir}/man5/zfs-module-parameters.5*
 %{_mandir}/man5/zpool-features.5*
 %{_mandir}/man8/fsck.zfs.8*
@@ -240,6 +450,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man8/zdb.8*
 %{_mandir}/man8/zed.8*
 %{_mandir}/man8/zfs.8*
+%{_mandir}/man8/zfs-mount-generator.8*
+%{_mandir}/man8/zfs-program.8*
+%{_mandir}/man8/zgenhostid.8*
 %{_mandir}/man8/zinject.8*
 %{_mandir}/man8/zpool.8*
 %{_mandir}/man8/zstreamdump.8*
@@ -271,6 +484,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libzpool.la
 %{_includedir}/libspl
 %{_includedir}/libzfs
+%{_pkgconfigdir}/libzfs.pc
+%{_pkgconfigdir}/libzfs_core.pc
 
 %files static
 %defattr(644,root,root,755)
@@ -282,30 +497,42 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n dracut-zfs
 %defattr(644,root,root,755)
-%doc dracut/README.dracut.markdown
-%dir %{_libdir}/dracut/modules.d/90zfs
-%attr(755,root,root) %{_libdir}/dracut/modules.d/90zfs/module-setup.sh
-%attr(755,root,root) %{_libdir}/dracut/modules.d/90zfs/mount-zfs.sh
-%attr(755,root,root) %{_libdir}/dracut/modules.d/90zfs/parse-zfs.sh
+%doc contrib/dracut/README.dracut.markdown
+%dir %{dracutlibdir}/modules.d/02zfsexpandknowledge
+%attr(755,root,root) %{dracutlibdir}/modules.d/02zfsexpandknowledge/module-setup.sh
+%dir %{dracutlibdir}/modules.d/90zfs
+%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
+%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
+%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
+%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
+%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-env-bootfs.service
+%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-generator.sh
+%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
+%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-load-key.sh
+%attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-needshutdown.sh
+
+%if %{with python2}
+%files -n python-pyzfs
+%defattr(644,root,root,755)
+%doc contrib/pyzfs/README
+%{py_sitescriptdir}/libzfs_core
+%{py_sitescriptdir}/pyzfs-*-py*.egg-info
 %endif
 
-%if %{with kernel}
-%files -n kernel%{_alt_kernel}-zfs
+%if %{with python3}
+%files -n python3-pyzfs
 %defattr(644,root,root,755)
-%dir /lib/modules/%{_kernel_ver}/misc/avl
-/lib/modules/%{_kernel_ver}/misc/avl/zavl.ko*
-%dir /lib/modules/%{_kernel_ver}/misc/nvpair
-/lib/modules/%{_kernel_ver}/misc/nvpair/znvpair.ko*
-%dir /lib/modules/%{_kernel_ver}/misc/unicode
-/lib/modules/%{_kernel_ver}/misc/unicode/zunicode.ko*
-%dir /lib/modules/%{_kernel_ver}/misc/zcommon
-/lib/modules/%{_kernel_ver}/misc/zcommon/zcommon.ko*
-%dir /lib/modules/%{_kernel_ver}/misc/zfs
-/lib/modules/%{_kernel_ver}/misc/zfs/zfs.ko*
-%dir /lib/modules/%{_kernel_ver}/misc/zpios
-/lib/modules/%{_kernel_ver}/misc/zpios/zpios.ko*
-
-%files -n kernel%{_alt_kernel}-zfs-devel
+%doc contrib/pyzfs/README
+%{py3_sitescriptdir}/libzfs_core
+%{py3_sitescriptdir}/pyzfs-*-py*.egg-info
+%endif
+%endif
+
+%if %{with kernel}
+%files -n kernel-zfs-common-devel
 %defattr(644,root,root,755)
-/usr/src/zfs-%{version}
+%dir /usr/src/zfs-%{version}
+/usr/src/zfs-%{version}/include
+/usr/src/zfs-%{version}/zfs.release
+/usr/src/zfs-%{version}/zfs_config.h
 %endif
This page took 0.084143 seconds and 4 git commands to generate.